aboutsummaryrefslogtreecommitdiff
path: root/misc/xosd
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-05-06 12:40:24 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-05-06 12:40:24 +0000
commitf4c8f0c8090dc924888d3ee9fcb8309d342ebfba (patch)
tree727e054bb64201b93a89a5625c12856a4e232b6f /misc/xosd
parent69ba81477e3532bbc44b65272f3ee5995b73fc3e (diff)
downloadports-f4c8f0c8090dc924888d3ee9fcb8309d342ebfba.tar.gz
ports-f4c8f0c8090dc924888d3ee9fcb8309d342ebfba.zip
Notes
Diffstat (limited to 'misc/xosd')
-rw-r--r--misc/xosd/Makefile14
-rw-r--r--misc/xosd/distinfo2
-rw-r--r--misc/xosd/files/patch-xosd.c14
-rw-r--r--misc/xosd/pkg-plist6
4 files changed, 23 insertions, 13 deletions
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index a0f8f78a6bb9..bbdee3a3ca7f 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xosd
-PORTVERSION= 2.1.3
+PORTVERSION= 2.2.1
CATEGORIES= misc
MASTER_SITES= http://www.ignavus.net/ \
${MASTER_SITE_LOCAL}
@@ -16,8 +16,10 @@ MAINTAINER= perky@FreeBSD.org
COMMENT= X On-Screen-Display Library and XMMS plug-in
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- xmms.3:${PORTSDIR}/multimedia/xmms \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+.if !defined(WITHOUT_XMMS)
+LIB_DEPENDS+= xmms.3:${PORTSDIR}/multimedia/xmms
+.endif
XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
USE_X_PREFIX= yes
@@ -30,6 +32,13 @@ CONFIGURE_ENV= LIBS=${PTHREAD_LIBS}' -L${LOCALBASE}/lib -lgnugetopt' \
CFLAGS='${CFLAGS}' X11BASE='${X11BASE}' \
GTK_CONFIG='${GTK_CONFIG}' GLIB_CONFIG='${GLIB_CONFIG}' \
XMMS_PLUGINDIR=${X11BASE}/lib/xmms
+.if defined(WITHOUT_XMMS)
+CONFIGURE_ARGS= --disable-new-plugin
+PLIST_SUB= WITH_XMMS="@comment "
+PKGNAMESUFFIX= -without-xmms
+.else
+PLIST_SUB= WITH_XMMS=""
+.endif
MAN1= osd_cat.1 xosd-config.1
MAN3= xosd_destroy.3 xosd_is_onscreen.3 xosd_set_shadow_offset.3 \
@@ -39,6 +48,7 @@ MAN3= xosd_destroy.3 xosd_is_onscreen.3 xosd_set_shadow_offset.3 \
pre-patch:
${REINPLACE_CMD} -e 's,-lc_r,-lblahblah,g' ${WRKSRC}/ltmain.sh
+ ${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
.for f in src/libxosd/Makefile.in src/xmms_plugin/Makefile.in
${REINPLACE_CMD} -e 's,^\(CFLAGS =\)\(.*\)$$,\1 -I.. \2,g' ${WRKSRC}/$f
.endfor
diff --git a/misc/xosd/distinfo b/misc/xosd/distinfo
index 736a084fcc15..3571a06fd702 100644
--- a/misc/xosd/distinfo
+++ b/misc/xosd/distinfo
@@ -1 +1 @@
-MD5 (xosd-2.1.3.tar.gz) = 400315c785735d19cddaa98c78808448
+MD5 (xosd-2.2.1.tar.gz) = def0a24f0e2716f4e8c01308445605b3
diff --git a/misc/xosd/files/patch-xosd.c b/misc/xosd/files/patch-xosd.c
index 0251602472b0..6f207c5a548e 100644
--- a/misc/xosd/files/patch-xosd.c
+++ b/misc/xosd/files/patch-xosd.c
@@ -1,11 +1,11 @@
--- src/libxosd/xosd.c.orig Wed Feb 19 10:53:59 2003
+++ src/libxosd/xosd.c Mon Mar 31 14:00:23 2003
-@@ -278,7 +278,7 @@
+@@ -332,7 +332,7 @@
- DEBUG("event thread started");
- assert (osd);
-- usleep (500);
-+ usleep (100000);
+ DEBUG("event thread started");
+ assert (osd);
+- usleep (500);
++ usleep (100000);
- while (!osd->done) {
- //DEBUG("checking window event");
+ while (!osd->done) {
+ //DEBUG("checking window event");
diff --git a/misc/xosd/pkg-plist b/misc/xosd/pkg-plist
index 4dbe153125cb..c8a76bc14427 100644
--- a/misc/xosd/pkg-plist
+++ b/misc/xosd/pkg-plist
@@ -4,9 +4,9 @@ include/xosd.h
lib/libxosd.a
lib/libxosd.la
lib/libxosd.so
-lib/libxosd.so.3
-lib/xmms/General/libxmms_osd.la
-lib/xmms/General/libxmms_osd.so
+lib/libxosd.so.4
+%%WITH_XMMS%%lib/xmms/General/libxmms_osd.la
+%%WITH_XMMS%%lib/xmms/General/libxmms_osd.so
share/aclocal/libxosd.m4
share/xosd/bottom-left.png
share/xosd/bottom-right.png