aboutsummaryrefslogtreecommitdiff
path: root/misc/yaunc
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-04-27 17:30:07 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-04-27 17:30:07 +0000
commitccbc927c381e0b5ce2572ab401d4748f0db2c3e2 (patch)
tree66fcf5121e5a6ce760beeae196a1546830128705 /misc/yaunc
parentb5007127c886c78139c7d94832b93ea16311085f (diff)
downloadports-ccbc927c381e0b5ce2572ab401d4748f0db2c3e2.tar.gz
ports-ccbc927c381e0b5ce2572ab401d4748f0db2c3e2.zip
Notes
Diffstat (limited to 'misc/yaunc')
-rw-r--r--misc/yaunc/Makefile9
-rw-r--r--misc/yaunc/distinfo2
-rw-r--r--misc/yaunc/files/patch-Makefile24
-rw-r--r--misc/yaunc/files/patch-ac14
-rw-r--r--misc/yaunc/files/patch-ae36
-rw-r--r--misc/yaunc/files/patch-yaunc.h (renamed from misc/yaunc/files/patch-my_hdrs.h)8
6 files changed, 41 insertions, 52 deletions
diff --git a/misc/yaunc/Makefile b/misc/yaunc/Makefile
index 72446c80a2d1..fa297cfad42a 100644
--- a/misc/yaunc/Makefile
+++ b/misc/yaunc/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= yaunc
-PORTVERSION= 0.06
-PORTREVISION= 1
+PORTVERSION= 1.00
CATEGORIES= misc
MASTER_SITES= http://www.redterror.net/code/yaunc/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Yet Another uptimes.net client
+COMMENT= Yet another uptimes.net client
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+ALL_TARGET= bsd
+CFLAGS+= -DCONFFILE=\\\"${PREFIX}/etc/yaunc.conf\\\"
+
MAN1= yaunc.1
post-patch:
diff --git a/misc/yaunc/distinfo b/misc/yaunc/distinfo
index 22c3545c30a0..3c2f5647139e 100644
--- a/misc/yaunc/distinfo
+++ b/misc/yaunc/distinfo
@@ -1 +1 @@
-MD5 (yaunc-0.06.tar.gz) = c1d737eec608db98331a015d0fa2b08d
+MD5 (yaunc-1.00.tar.gz) = 9495b42fa70d6b6031b4dbf30be9720b
diff --git a/misc/yaunc/files/patch-Makefile b/misc/yaunc/files/patch-Makefile
new file mode 100644
index 000000000000..2ac182383546
--- /dev/null
+++ b/misc/yaunc/files/patch-Makefile
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- Makefile.orig Sun Apr 27 19:23:16 2003
++++ Makefile Sun Apr 27 19:23:38 2003
+@@ -1,7 +1,7 @@
+ # Compiler, flags, etc...
+-CC = cc
++#CC = cc
+ #CFLAGS = -Wall -g -DDEBUG2 -DDEBUG1
+-CFLAGS=-Wall -O2
++#CFLAGS=-Wall -O2
+
+ # program variables
+ FILENAME = yaunc
+@@ -12,7 +12,7 @@
+
+ # platform dependant stuff has the appropriate suffix :)
+ OBJ1 = read_conf.o usage.o unp_error.o encode.o unp_sock_wrappers.o \
+- unp_inet_pton.o unp_inet_ntop.o unp_wraplib.o send_data.o \
++ unp_wraplib.o send_data.o \
+ resolv.o daemon_init.o sigfuncs.o inlines.o
+ OBJ_LIN = $(OBJ1) linux_funcs.o
+ OBJ_SUN = $(OBJ1) get_ut_proc.o
diff --git a/misc/yaunc/files/patch-ac b/misc/yaunc/files/patch-ac
index 95539380ef71..7176a089aa3c 100644
--- a/misc/yaunc/files/patch-ac
+++ b/misc/yaunc/files/patch-ac
@@ -1,14 +1,14 @@
---- usage.c.orig Wed Jul 26 09:38:02 2000
-+++ usage.c Mon Dec 25 20:10:10 2000
-@@ -10,9 +10,9 @@
+
+$FreeBSD$
+
+--- usage.c.orig Sun Apr 27 19:11:03 2003
++++ usage.c Sun Apr 27 19:11:26 2003
+@@ -10,7 +10,7 @@
fprintf(stderr, "\n");
fprintf(stderr, "Options:\n");
fprintf(stderr, "\t-f <config file> - use the specified config file instead of \n");
- fprintf(stderr, "\t of /etc/yaunc.conf\n");
-+ fprintf(stderr, "\t " SYSCONFDIR "/yaunc.conf\n");
- fprintf(stderr, "\t-d <0/1> - turn daemon mode off/on\n");
-- fprintf(stderr, "\t-l <0/1> - specify logging off/on");
-+ fprintf(stderr, "\t-l <0/1> - specify logging off/on\n");
++ fprintf(stderr, "\t of " CONFFILE "\n");
fprintf(stderr, "\t-h - display this help\n");
fprintf(stderr, "\n");
exit(0);
diff --git a/misc/yaunc/files/patch-ae b/misc/yaunc/files/patch-ae
deleted file mode 100644
index ea17e1f4202a..000000000000
--- a/misc/yaunc/files/patch-ae
+++ /dev/null
@@ -1,36 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Sun Dec 24 02:37:08 2000
-+++ Makefile.in Sun Dec 22 16:34:26 2002
-@@ -71,7 +71,7 @@
-
- bin_PROGRAMS = yaunc
-
--yaunc_SOURCES = daemon_init.c form_data.c inlines.c main.c misc.c read_conf.c resolv.c send_data.c sigfuncs.c unp_error.c unp_inet_ntop.c unp_inet_pton.c unp_sock_wrappers.c unp_wraplib.c usage.c os_specific.c my_hdrs.h yaunc.h
-+yaunc_SOURCES = daemon_init.c form_data.c inlines.c main.c misc.c read_conf.c resolv.c send_data.c sigfuncs.c unp_error.c unp_sock_wrappers.c unp_wraplib.c usage.c os_specific.c my_hdrs.h yaunc.h
-
-
- EXTRA_yaunc_SOURCES = get_ut_bsd.c get_ut_sun.c get_ut_linux.c
-@@ -83,8 +83,8 @@
- # To tell automake that these should go in the tar
- EXTRA_DIST = $(man_MANS) $(sysconf_DATA) TO-DO
-
--CFLAGS = @CFLAGS@ -Wall -Werror -DSYSCONFDIR=\"$(sysconfdir)\"
--LDFLAGS = @LDFLAGS@ -Wall -Werror
-+CFLAGS = @CFLAGS@ -DSYSCONFDIR=\"$(sysconfdir)\"
-+LDFLAGS = @LDFLAGS@
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = config.h
-@@ -96,8 +96,8 @@
- CPPFLAGS = @CPPFLAGS@
- LIBS = @LIBS@
- yaunc_OBJECTS = daemon_init.o form_data.o inlines.o main.o misc.o \
--read_conf.o resolv.o send_data.o sigfuncs.o unp_error.o unp_inet_ntop.o \
--unp_inet_pton.o unp_sock_wrappers.o unp_wraplib.o usage.o os_specific.o
-+read_conf.o resolv.o send_data.o sigfuncs.o unp_error.o \
-+unp_sock_wrappers.o unp_wraplib.o usage.o os_specific.o
- yaunc_LDADD = $(LDADD)
- yaunc_DEPENDENCIES =
- yaunc_LDFLAGS =
diff --git a/misc/yaunc/files/patch-my_hdrs.h b/misc/yaunc/files/patch-yaunc.h
index 521ba7341382..23832978b8e7 100644
--- a/misc/yaunc/files/patch-my_hdrs.h
+++ b/misc/yaunc/files/patch-yaunc.h
@@ -1,10 +1,10 @@
$FreeBSD$
---- my_hdrs.h.orig Thu Mar 23 03:32:02 2000
-+++ my_hdrs.h Sun Dec 22 16:33:44 2002
-@@ -34,8 +34,6 @@
- ssize_t Recvfrom(int, void *, size_t, int, struct sockaddr *, socklen_t *);
+--- yaunc.h.orig Fri Mar 14 07:14:11 2003
++++ yaunc.h Sun Apr 27 19:15:49 2003
+@@ -107,8 +107,6 @@
+ int Socket(int, int, int );
/* other networking function */
-int inet_pton(int, const char *, void *);