aboutsummaryrefslogtreecommitdiff
path: root/misc/zaptel/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2005-04-17 07:41:56 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2005-04-17 07:41:56 +0000
commitff8cbab99a5ae2865bf422a41b8dab51b6550b0e (patch)
tree4ca7be721ec3d5ebab053f2c094d130ce02b6dbd /misc/zaptel/Makefile
parent2fb4cdb284d8ebe4823812e64e1d39613b58a0a7 (diff)
downloadports-ff8cbab99a5ae2865bf422a41b8dab51b6550b0e.tar.gz
ports-ff8cbab99a5ae2865bf422a41b8dab51b6550b0e.zip
Notes
Diffstat (limited to 'misc/zaptel/Makefile')
-rw-r--r--misc/zaptel/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/misc/zaptel/Makefile b/misc/zaptel/Makefile
index fcda076a1a7f..43ae89f3a9b2 100644
--- a/misc/zaptel/Makefile
+++ b/misc/zaptel/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= zaptel
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.9
CATEGORIES= misc
MASTER_SITES= http://www.portaone.com/~sobomax/
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-COMMENT= A FreeBSD Driver for Digium X100P/TDM400P Telephony Cards
+COMMENT= A FreeBSD Driver for FXO, FXS, BRI and PRI Telephony Cards
LIB_DEPENDS= newt.51:${PORTSDIR}/devel/newt
@@ -24,6 +23,12 @@ ONLY_FOR_ARCHS= i386
PKGMESSAGE= ${WRKSRC}/.MESSAGE
MAKE_ENV= KMODDIR=${PREFIX}/lib/zaptel
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "FreeBSD versions below 5.x is not supported yet. If you can add support please do it and send your patches to Alexander Timoshenko <gonzo@portaone.com>. We will integrate into the driver. Thanks!"
+.endif
+
pre-everything::
@if [ ! -f /usr/src/sys/Makefile ]; then \
${ECHO_MSG} ">> The zaptel port needs FreeBSD kernel source code to compile."; \
@@ -43,4 +48,4 @@ post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/zaptel.sh.sample ${PREFIX}/etc/rc.d
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>