aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
commit741aa714833b9bb1e9afaaf5124d3f5c60b5e49c (patch)
treee9b79b363f2fc4a63535a25c71491fa49a79b556 /misc
parente6b2e4b3537ce43e377d2f4fe0ac46b6ab8c4395 (diff)
downloadports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.tar.gz
ports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=218938
Diffstat (limited to 'misc')
-rw-r--r--misc/amanda-server/Makefile2
-rw-r--r--misc/amanda25-server/Makefile2
-rw-r--r--misc/amanda26-server/Makefile2
-rw-r--r--misc/amanda32-server/Makefile2
-rw-r--r--misc/bibletime-kde3/Makefile1
-rw-r--r--misc/bibletime/Makefile1
-rw-r--r--misc/clpbar/Makefile1
-rw-r--r--misc/dejagnu/Makefile1
-rw-r--r--misc/diction/Makefile1
-rw-r--r--misc/hello/Makefile1
-rw-r--r--misc/iselect/Makefile1
-rw-r--r--misc/kcd-devel/Makefile3
-rw-r--r--misc/kcd/Makefile3
-rw-r--r--misc/latex-mk/Makefile1
-rw-r--r--misc/lifelines/Makefile1
-rw-r--r--misc/ossp-uuid/Makefile1
-rw-r--r--misc/patchutils/Makefile1
-rw-r--r--misc/skyutils/Makefile1
-rw-r--r--misc/smssend/Makefile1
-rw-r--r--misc/sword/Makefile1
-rw-r--r--misc/sword15/Makefile1
-rw-r--r--misc/talkfilters/Makefile1
-rw-r--r--misc/uf-view/Makefile1
-rw-r--r--misc/wmwork/Makefile1
-rw-r--r--misc/xbiso/Makefile1
-rw-r--r--misc/xdelta/Makefile1
-rw-r--r--misc/xfce4-artwork/Makefile1
27 files changed, 2 insertions, 33 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 780c278ef83d..1d1bc274cfb7 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -38,8 +38,6 @@ OPTIONS= GNUTAR "use GNU tar" on \
.include <bsd.port.pre.mk>
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
AMANDA_USER?= operator
AMANDA_GROUP?= operator
AMANDA_GNUTAR_LISTDIR?= ${PREFIX}/var/amanda/gnutar-lists
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index 780c278ef83d..1d1bc274cfb7 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -38,8 +38,6 @@ OPTIONS= GNUTAR "use GNU tar" on \
.include <bsd.port.pre.mk>
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
AMANDA_USER?= operator
AMANDA_GROUP?= operator
AMANDA_GNUTAR_LISTDIR?= ${PREFIX}/var/amanda/gnutar-lists
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index 780c278ef83d..1d1bc274cfb7 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -38,8 +38,6 @@ OPTIONS= GNUTAR "use GNU tar" on \
.include <bsd.port.pre.mk>
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
AMANDA_USER?= operator
AMANDA_GROUP?= operator
AMANDA_GNUTAR_LISTDIR?= ${PREFIX}/var/amanda/gnutar-lists
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 780c278ef83d..1d1bc274cfb7 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -38,8 +38,6 @@ OPTIONS= GNUTAR "use GNU tar" on \
.include <bsd.port.pre.mk>
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
AMANDA_USER?= operator
AMANDA_GROUP?= operator
AMANDA_GNUTAR_LISTDIR?= ${PREFIX}/var/amanda/gnutar-lists
diff --git a/misc/bibletime-kde3/Makefile b/misc/bibletime-kde3/Makefile
index bcb963195bf2..7d786e563608 100644
--- a/misc/bibletime-kde3/Makefile
+++ b/misc/bibletime-kde3/Makefile
@@ -23,7 +23,6 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_ICONS= yes
.include <bsd.port.pre.mk>
diff --git a/misc/bibletime/Makefile b/misc/bibletime/Makefile
index bcb963195bf2..7d786e563608 100644
--- a/misc/bibletime/Makefile
+++ b/misc/bibletime/Makefile
@@ -23,7 +23,6 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_ICONS= yes
.include <bsd.port.pre.mk>
diff --git a/misc/clpbar/Makefile b/misc/clpbar/Makefile
index 09f8fe1d5189..0bd41fe8da2e 100644
--- a/misc/clpbar/Makefile
+++ b/misc/clpbar/Makefile
@@ -18,7 +18,6 @@ COMMENT= Command Line Progress Bar
WRKSRC= ${WRKDIR}/bar-${PORTVERSION}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS+= CFLAGS+="${CFLAGS}"
MAN1= bar.1
diff --git a/misc/dejagnu/Makefile b/misc/dejagnu/Makefile
index ac0a4809f020..f01609262cf6 100644
--- a/misc/dejagnu/Makefile
+++ b/misc/dejagnu/Makefile
@@ -19,7 +19,6 @@ RUN_DEPENDS= expect:${PORTSDIR}/lang/expect
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= runtest.1
diff --git a/misc/diction/Makefile b/misc/diction/Makefile
index 52c6a752bcee..b25c847ae761 100644
--- a/misc/diction/Makefile
+++ b/misc/diction/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= mva@sysfault.org
COMMENT= GNU diction and style
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_FILES= bin/diction bin/style share/diction/C share/diction/de \
share/diction/en share/diction/en_GB share/diction/nl
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index fd2016a9d620..026279af5f95 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -17,7 +17,6 @@ COMMENT= A utility for saying hello to the world and reading email
USE_PERL5_BUILD= YES
GNU_CONFIGURE= YES
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= hello.1
INFO= hello
diff --git a/misc/iselect/Makefile b/misc/iselect/Makefile
index 3fc05fad1ba8..32250557777a 100644
--- a/misc/iselect/Makefile
+++ b/misc/iselect/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive Selection Tool
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= iselect.1
diff --git a/misc/kcd-devel/Makefile b/misc/kcd-devel/Makefile
index 830763abc45e..6aaca57efb9b 100644
--- a/misc/kcd-devel/Makefile
+++ b/misc/kcd-devel/Makefile
@@ -19,8 +19,7 @@ COMMENT= Change directory in full-screen visual mode
USE_GETTEXT= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
- --sysconfdir=${PREFIX}/etc
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
diff --git a/misc/kcd/Makefile b/misc/kcd/Makefile
index ca7a43a563ff..f6668d0b0d01 100644
--- a/misc/kcd/Makefile
+++ b/misc/kcd/Makefile
@@ -18,8 +18,7 @@ COMMENT= Change directory in full-screen visual mode
USE_GETTEXT= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
- --sysconfdir=${PREFIX}/etc
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
diff --git a/misc/latex-mk/Makefile b/misc/latex-mk/Makefile
index 9e02fc59d823..9b67bc332eb9 100644
--- a/misc/latex-mk/Makefile
+++ b/misc/latex-mk/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INFO= latex-mk
diff --git a/misc/lifelines/Makefile b/misc/lifelines/Makefile
index 8ded9c9e8596..7075b8d33c02 100644
--- a/misc/lifelines/Makefile
+++ b/misc/lifelines/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= matt@gsicomp.on.ca
COMMENT= An advanced genealogical system
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_ICONV= yes
USE_BZIP2= yes
USE_BISON= build
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index d465525cc2f4..754ef56171e5 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -19,7 +19,6 @@ CONFLICTS= e2fsprogs-libuuid-[0-9]*
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-shared --enable-static --with-cxx
MAN1= uuid-config.1 uuid.1
diff --git a/misc/patchutils/Makefile b/misc/patchutils/Makefile
index ce8959a1bf81..00265bbde96b 100644
--- a/misc/patchutils/Makefile
+++ b/misc/patchutils/Makefile
@@ -17,7 +17,6 @@ COMMENT= A small collection of programs that operate on patch files
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= combinediff.1 dehtmldiff.1 editdiff.1 espdiff.1 filterdiff.1 \
fixcvsdiff.1 flipdiff.1 grepdiff.1 interdiff.1 lsdiff.1 recountdiff.1 \
diff --git a/misc/skyutils/Makefile b/misc/skyutils/Makefile
index 2caeb2edcf54..04e885e7e3c9 100644
--- a/misc/skyutils/Makefile
+++ b/misc/skyutils/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A library required by smssend (same author)
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_AUTOTOOLS= autoconf:262 libtool:15
USE_LDCONFIG= yes
diff --git a/misc/smssend/Makefile b/misc/smssend/Makefile
index e7e51cda1811..07521ca4d142 100644
--- a/misc/smssend/Makefile
+++ b/misc/smssend/Makefile
@@ -22,7 +22,6 @@ MAN1= smssend.1 smssend.scripting.1 email2smssend.1
MANLANG= "" fr
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
post-install:
${STRIP_CMD} ${PREFIX}/bin/smssend
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 91f077ff9495..c33a9b33fa79 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -20,7 +20,6 @@ USE_GNOME= pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:110 autoconf:262
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --without-conf --without-clucene --with-zlib --without-icu
USE_LDCONFIG= yes
SUB_FILES= pkg-message
diff --git a/misc/sword15/Makefile b/misc/sword15/Makefile
index 91f077ff9495..c33a9b33fa79 100644
--- a/misc/sword15/Makefile
+++ b/misc/sword15/Makefile
@@ -20,7 +20,6 @@ USE_GNOME= pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:110 autoconf:262
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --without-conf --without-clucene --with-zlib --without-icu
USE_LDCONFIG= yes
SUB_FILES= pkg-message
diff --git a/misc/talkfilters/Makefile b/misc/talkfilters/Makefile
index 583795682323..8e3222176b9b 100644
--- a/misc/talkfilters/Makefile
+++ b/misc/talkfilters/Makefile
@@ -18,7 +18,6 @@ CONFLICTS= jive* chef* filters-*
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= talkfilters.1 wrap.1
MLINKS= talkfilters.1 austro.1 \
diff --git a/misc/uf-view/Makefile b/misc/uf-view/Makefile
index dc679da344ea..09889e621cb8 100644
--- a/misc/uf-view/Makefile
+++ b/misc/uf-view/Makefile
@@ -19,7 +19,6 @@ USE_GNOME= gnomeprefix gnomehack gnomehier gnomevfs2 gnomedesktop
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/misc/wmwork/Makefile b/misc/wmwork/Makefile
index 5af4134f3e39..21332839dc7e 100644
--- a/misc/wmwork/Makefile
+++ b/misc/wmwork/Makefile
@@ -19,7 +19,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USE_XORG= xpm
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= wmwork.1
diff --git a/misc/xbiso/Makefile b/misc/xbiso/Makefile
index 1bf225a8589e..9a1f6d420259 100644
--- a/misc/xbiso/Makefile
+++ b/misc/xbiso/Makefile
@@ -18,7 +18,6 @@ COMMENT= XBox xdvdfs iso extraction utility
LIB_DEPENDS= ftp.3:${PORTSDIR}/ftp/ftplib
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/misc/xdelta/Makefile b/misc/xdelta/Makefile
index 4f6ad62fdd3f..934c30bb8bb3 100644
--- a/misc/xdelta/Makefile
+++ b/misc/xdelta/Makefile
@@ -17,7 +17,6 @@ USE_AUTOTOOLS= libtool:15
USE_GNOME= glib12
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= xdelta.1
diff --git a/misc/xfce4-artwork/Makefile b/misc/xfce4-artwork/Makefile
index d8c7eb4d5418..079bf9b319a1 100644
--- a/misc/xfce4-artwork/Makefile
+++ b/misc/xfce4-artwork/Makefile
@@ -18,6 +18,5 @@ COMMENT= Additional artwork for the XFce4 desktop environment
RUN_DEPENDS= xfdesktop:${PORTSDIR}/x11-wm/xfce4-desktop
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>