aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-06-13 22:40:40 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-06-13 22:40:40 +0000
commit68361e92520d328731cce77bfd5ad013ca066505 (patch)
tree4bf5fbaa1b024ad45d7db97be263c017af4c3907 /misc
parenta3b75e88c6bfcf06573cd92daab0b47e6c5608f7 (diff)
downloadports-68361e92520d328731cce77bfd5ad013ca066505.tar.gz
ports-68361e92520d328731cce77bfd5ad013ca066505.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/rabbit/Makefile4
-rw-r--r--misc/rabbit/distinfo4
-rw-r--r--misc/rabbit/files/patch-lib-rabbit-element-container-element.rb31
-rw-r--r--misc/rabbit/pkg-plist3
4 files changed, 37 insertions, 5 deletions
diff --git a/misc/rabbit/Makefile b/misc/rabbit/Makefile
index fcc6cdb92602..85c4ba917c9d 100644
--- a/misc/rabbit/Makefile
+++ b/misc/rabbit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rabbit
-PORTVERSION= 1.0.6
-PORTREVISION= 1
+PORTVERSION= 1.0.7
CATEGORIES= misc ruby
MASTER_SITES= http://rabbit-shockers.org/download/ \
LOCAL
@@ -69,7 +68,6 @@ RUN_DEPENDS+= rubygem-twitter_oauth>=0:${PORTSDIR}/security/rubygem-twitter_oaut
post-patch:
${RM} ${WRKSRC}/bin/rabwii
- ${RMDIR} ${WRKSRC}/lib/rt
${RUBY} -i -pe 'sub %r|((\s*)require "rack")|, %Q|\\2require "rubygems"\n\\1|' ${WRKSRC}/bin/rabbirack
${RUBY} -i -pe 'sub %r|(require "hikidoc")|, %Q|require "rubygems"\n\\1|' ${WRKSRC}/lib/rabbit/parser/wiki.rb
${RUBY} -i -pe "sub %r|((\s*)require 'twitter_oauth')|, %Q|\\\2require 'rubygems'\n\\\1|" ${WRKSRC}/lib/rabbit/twitter.rb
diff --git a/misc/rabbit/distinfo b/misc/rabbit/distinfo
index a8fbe2abdd05..c64e9dded3eb 100644
--- a/misc/rabbit/distinfo
+++ b/misc/rabbit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rabbit-1.0.6.tar.gz) = 2413dd3679c4782204f45f19e98ed2f3d8e063a1e79f9d40fd36f56355382576
-SIZE (rabbit-1.0.6.tar.gz) = 5886935
+SHA256 (rabbit-1.0.7.tar.gz) = ebd16a1ab7c9ae9e444abe2a29c0bbe7646f6544a55e31e2df069884cdb70c56
+SIZE (rabbit-1.0.7.tar.gz) = 5897132
diff --git a/misc/rabbit/files/patch-lib-rabbit-element-container-element.rb b/misc/rabbit/files/patch-lib-rabbit-element-container-element.rb
new file mode 100644
index 000000000000..f05a5c650055
--- /dev/null
+++ b/misc/rabbit/files/patch-lib-rabbit-element-container-element.rb
@@ -0,0 +1,31 @@
+--- lib/rabbit/element/container-element.rb.orig 2012-05-29 22:51:14.000000000 +0900
++++ lib/rabbit/element/container-element.rb 2012-06-14 07:05:17.000000000 +0900
+@@ -119,18 +119,22 @@
+ prev_is_inline = false
+ @elements.each do |element|
+ element.compile(canvas, x, y, w, h)
+- compile_horizontal(canvas, x, y, w, h)
++ compile_horizontal_element(element, canvas, x, y, w, h)
+ x, y, w, h = element.draw(true)
+ end
+ end
+
+ def compile_horizontal(canvas, x, y, w, h)
+ @elements.each do |element|
+- if do_horizontal_centering? or element.do_horizontal_centering?
+- element.do_horizontal_centering(canvas, x, y, w, h)
+- else
+- element.reset_horizontal_centering(canvas, x, y, w, h)
+- end
++ compile_horizontal_element(element, canvas, x, y, w, h)
++ end
++ end
++
++ def compile_horizontal_element(element, canvas, x, y, w, h)
++ if do_horizontal_centering? or element.do_horizontal_centering?
++ element.do_horizontal_centering(canvas, x, y, w, h)
++ else
++ element.reset_horizontal_centering(canvas, x, y, w, h)
+ end
+ end
+
diff --git a/misc/rabbit/pkg-plist b/misc/rabbit/pkg-plist
index 2eea694e1c47..13797ce76387 100644
--- a/misc/rabbit/pkg-plist
+++ b/misc/rabbit/pkg-plist
@@ -268,6 +268,8 @@ bin/rabrick
%%RUBY_SITELIBDIR%%/rabbit/theme/edge-info-toolkit/property.rb
%%RUBY_SITELIBDIR%%/rabbit/theme/emphasize-keyword/emphasize-keyword.rb
%%RUBY_SITELIBDIR%%/rabbit/theme/emphasize-keyword/property.rb
+%%RUBY_SITELIBDIR%%/rabbit/theme/enishi-green/enishi-green.rb
+%%RUBY_SITELIBDIR%%/rabbit/theme/enishi-green/property.rb
%%RUBY_SITELIBDIR%%/rabbit/theme/entry.rb
%%RUBY_SITELIBDIR%%/rabbit/theme/footer-comment/footer-comment.rb
%%RUBY_SITELIBDIR%%/rabbit/theme/footer-comment/property.rb
@@ -475,6 +477,7 @@ bin/rabrick
@dirrm %%RUBY_SITELIBDIR%%/rabbit/theme/green-circle
@dirrm %%RUBY_SITELIBDIR%%/rabbit/theme/footer-logo
@dirrm %%RUBY_SITELIBDIR%%/rabbit/theme/footer-comment
+@dirrm %%RUBY_SITELIBDIR%%/rabbit/theme/enishi-green
@dirrm %%RUBY_SITELIBDIR%%/rabbit/theme/emphasize-keyword
@dirrm %%RUBY_SITELIBDIR%%/rabbit/theme/edge-info-toolkit
@dirrm %%RUBY_SITELIBDIR%%/rabbit/theme/default-title-text