aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-06-02 20:28:41 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-06-02 20:28:41 +0000
commit392aa128b51ff968e6db11f38b7ba6f6d0dedd33 (patch)
tree539bd22aa3ba684b6facf9ee9560d8d0cdb7c812 /misc
parenta210c68356ff0dded5c7b63ac4b2d501473a84e2 (diff)
downloadports-392aa128b51ff968e6db11f38b7ba6f6d0dedd33.tar.gz
ports-392aa128b51ff968e6db11f38b7ba6f6d0dedd33.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/demoniac/Makefile2
-rw-r--r--misc/misterproper/Makefile2
-rw-r--r--misc/pybliographer/Makefile11
3 files changed, 6 insertions, 9 deletions
diff --git a/misc/demoniac/Makefile b/misc/demoniac/Makefile
index e71ecd33f385..cb071ec2fdbd 100644
--- a/misc/demoniac/Makefile
+++ b/misc/demoniac/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
USE_REINPLACE= yes
USE_GL= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
LDFLAGS="${PTHREAD_LIBS}"
diff --git a/misc/misterproper/Makefile b/misc/misterproper/Makefile
index cc6327e7715b..954c11a86170 100644
--- a/misc/misterproper/Makefile
+++ b/misc/misterproper/Makefile
@@ -19,7 +19,7 @@ COMMENT= A GNOME application designed to manage cyclic tasks
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomelibs gnomeprefix gnometarget
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/misc/pybliographer/Makefile b/misc/pybliographer/Makefile
index 8ed3d9f26251..7bb83a0493d2 100644
--- a/misc/pybliographer/Makefile
+++ b/misc/pybliographer/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-1.2/_gnomemodule.so:${PORTSDIR}/x11-toolki
USE_GNOME= glib12 gnomehack gnomeprefix
USE_PYTHON= yes
USE_X_PREFIX= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
@@ -33,12 +33,9 @@ CONFIGURE_ARGS= --with-recode-prefix="${LOCALBASE}"
.include <bsd.port.pre.mk>
pre-patch:
- @${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|glib-config|glib12-config|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|\$$(datadir)/gnome/|$$(datadir)/|g ; \
- s|\$$(datadir)/locale|$$(prefix)/share/locale|g'
+ @${REINPLACE_CMD} -e 's|glib-config|${GLIB_CONFIG}|g ; \
+ s|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
.if ${PYTHON_REL} >= 230
@${REINPLACE_CMD} 's|@DEFS@||g' ${WRKSRC}/compiled/Makefile.pre.in
.endif