aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-12-31 16:48:37 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-12-31 16:48:37 +0000
commitd12cf74b0bf11446375f9cd66936508b14814d20 (patch)
tree289798702f4c2c5976c5790c5d9e66922aca6d33 /misc
parentd079a78cfba51cf2a4b64daabc974e1ba4c9d83e (diff)
downloadports-d12cf74b0bf11446375f9cd66936508b14814d20.tar.gz
ports-d12cf74b0bf11446375f9cd66936508b14814d20.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Array-Compare/Makefile22
-rw-r--r--misc/p5-Array-Compare/distinfo1
-rw-r--r--misc/p5-Array-Compare/pkg-comment1
-rw-r--r--misc/p5-Array-Compare/pkg-descr16
-rw-r--r--misc/p5-Array-Compare/pkg-plist8
6 files changed, 49 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 273ddbd1e2ca..1adb904a1cd3 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -140,6 +140,7 @@
SUBDIR += numchar
SUBDIR += nwrite
SUBDIR += orville-write
+ SUBDIR += p5-Array-Compare
SUBDIR += p5-Array-PrintCols
SUBDIR += p5-Business-CreditCard
SUBDIR += p5-Business-ISBN
diff --git a/misc/p5-Array-Compare/Makefile b/misc/p5-Array-Compare/Makefile
new file mode 100644
index 000000000000..eb32d4d17493
--- /dev/null
+++ b/misc/p5-Array-Compare/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Array-Compare
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Array-Compare
+PORTVERSION= 1.03
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Array
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= Array::Compare.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Array-Compare/distinfo b/misc/p5-Array-Compare/distinfo
new file mode 100644
index 000000000000..a08960065228
--- /dev/null
+++ b/misc/p5-Array-Compare/distinfo
@@ -0,0 +1 @@
+MD5 (Array-Compare-1.03.tar.gz) = 2a40c847a70344737c6e297565033c18
diff --git a/misc/p5-Array-Compare/pkg-comment b/misc/p5-Array-Compare/pkg-comment
new file mode 100644
index 000000000000..45d722a109dc
--- /dev/null
+++ b/misc/p5-Array-Compare/pkg-comment
@@ -0,0 +1 @@
+Perl extension for comparing arrays
diff --git a/misc/p5-Array-Compare/pkg-descr b/misc/p5-Array-Compare/pkg-descr
new file mode 100644
index 000000000000..20a7da7122b4
--- /dev/null
+++ b/misc/p5-Array-Compare/pkg-descr
@@ -0,0 +1,16 @@
+Array::Compare is a Perl module which allows you to compare two arrays.
+
+It has a number of features which allow you to control the way that
+the arrays are compared:
+
+* white space in array elements can be significant or ignored.
+
+* particular columns in the arrays can be ignored.
+
+Additionally you can get a simple true/false return value or the number
+of columns which differ or an array containing the indexes of the
+differing columns.
+
+WWW: http://search.cpan.org/search?dist=Array-Compare
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/misc/p5-Array-Compare/pkg-plist b/misc/p5-Array-Compare/pkg-plist
new file mode 100644
index 000000000000..2c169362457b
--- /dev/null
+++ b/misc/p5-Array-Compare/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Array/Compare.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Array/Compare/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/auto/Array/Compare/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Array/Compare
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Array 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Array/Compare
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Array 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Array 2>/dev/null || true