aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-08-11 02:37:27 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-08-11 02:37:27 +0000
commite03f7375b5abf9f5034665db4ac8f31b6b8dafa8 (patch)
treedcf453b095368f90b2a391418141ed3d6ce21dbc /misc
parent0b492338342594036c88b5612722cf6677173bc3 (diff)
downloadports-e03f7375b5abf9f5034665db4ac8f31b6b8dafa8.tar.gz
ports-e03f7375b5abf9f5034665db4ac8f31b6b8dafa8.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/vifm/Makefile38
-rw-r--r--misc/vifm/distinfo1
-rw-r--r--misc/vifm/pkg-comment1
-rw-r--r--misc/vifm/pkg-descr13
-rw-r--r--misc/vifm/pkg-plist7
6 files changed, 61 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index aaf2f3fdf45f..f45bb20e1caf 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -295,6 +295,7 @@
SUBDIR += vbidecode
SUBDIR += vera
SUBDIR += videotext
+ SUBDIR += vifm
SUBDIR += viz
SUBDIR += whichman
SUBDIR += wmScoreBoard
diff --git a/misc/vifm/Makefile b/misc/vifm/Makefile
new file mode 100644
index 000000000000..8d6c08d1b75f
--- /dev/null
+++ b/misc/vifm/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: vifm
+# Date created: 09 August 2002
+# Whom: Stefan Walter <swalter@lettermax.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vifm
+PORTVERSION= 0.1
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= vifm
+
+MAINTAINER= swalter@lettermax.de
+
+.if defined(WITH_VIFM_SCREEN)
+RUN_DEPENDS= screen:${PORTSDIR}/misc/screen
+.else
+pre-everything:
+ @${ECHO_CMD} "You can define WITH_VIFM_SCREEN to add screen as a dependency."
+.endif
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+.if defined(WITH_VIFM_SCREEN)
+pre-build:
+ @${REINPLACE_CMD} -e "s/cfg.use_screen = 0/cfg.use_screen = 1/" \
+ ${BUILD_WRKSRC}/src/config.c
+ @${REINPLACE_CMD} -e "s/USE_SCREEN=0/USE_SCREEN=1/" \
+ ${BUILD_WRKSRC}/src/vifmrc0.1
+.endif
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/vifm
+
+.include <bsd.port.mk>
diff --git a/misc/vifm/distinfo b/misc/vifm/distinfo
new file mode 100644
index 000000000000..d216376cd230
--- /dev/null
+++ b/misc/vifm/distinfo
@@ -0,0 +1 @@
+MD5 (vifm-0.1.tar.gz) = ce8d8c8a1f94d3735c4a3bdef45520ce
diff --git a/misc/vifm/pkg-comment b/misc/vifm/pkg-comment
new file mode 100644
index 000000000000..753663f06fdb
--- /dev/null
+++ b/misc/vifm/pkg-comment
@@ -0,0 +1 @@
+Ncurses based file manager with vi like keybindings
diff --git a/misc/vifm/pkg-descr b/misc/vifm/pkg-descr
new file mode 100644
index 000000000000..e99da1aec85b
--- /dev/null
+++ b/misc/vifm/pkg-descr
@@ -0,0 +1,13 @@
+"Vifm is a ncurses based file manager with vi like keybindings. If you
+use vi, vifm gives you complete keyboard control over your files without
+having to learn a new set of commands."
+
+Features:
+ - two file list windows
+ - bookmarks
+ - user-defined association of file types/extensions with multiple
+ applications per extension
+ - visual mode for selecting files
+ - user-defined commands
+
+WWW: http://vifm.sourceforge.net/
diff --git a/misc/vifm/pkg-plist b/misc/vifm/pkg-plist
new file mode 100644
index 000000000000..b4831235ff4b
--- /dev/null
+++ b/misc/vifm/pkg-plist
@@ -0,0 +1,7 @@
+bin/pauseme
+bin/vifm
+share/vifm/vifm-0.1.help.txt
+share/vifm/vifm.txt
+share/vifm/vifm.vim
+share/vifm/vifmrc0.1
+@dirrm share/vifm