aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-15 00:56:24 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-15 00:56:24 +0000
commit147fdee482ca1a335dcd09608f3b820a1dad2b40 (patch)
tree6adf22ccd743df57b19e1e180d4cc1e16851afeb /misc
parente0f58ab25d1ad411ed70fe4c114cfbd5bb341348 (diff)
downloadports-147fdee482ca1a335dcd09608f3b820a1dad2b40.tar.gz
ports-147fdee482ca1a335dcd09608f3b820a1dad2b40.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/chmlib/Makefile2
-rw-r--r--misc/compat3x/Makefile2
-rw-r--r--misc/compat4x/Makefile2
-rw-r--r--misc/compat5x/Makefile2
-rw-r--r--misc/gctpc/Makefile2
-rw-r--r--misc/gtl/Makefile2
-rw-r--r--misc/projectionlib/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/misc/chmlib/Makefile b/misc/chmlib/Makefile
index 968e86ddb90a..4fbc40b18e6f 100644
--- a/misc/chmlib/Makefile
+++ b/misc/chmlib/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-io64 --disable-pread --exec-prefix=${PREFIX}
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS}," ${WRKSRC}/configure
diff --git a/misc/compat3x/Makefile b/misc/compat3x/Makefile
index 750445a7bb68..018e29726120 100644
--- a/misc/compat3x/Makefile
+++ b/misc/compat3x/Makefile
@@ -27,7 +27,7 @@ NO_MTREE= yes
TARGET_DIR= ${PREFIX}/lib/compat
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/compat
.include <bsd.port.pre.mk>
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index 8132d0a52d21..eeab0fa2f4ea 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -21,7 +21,7 @@ COMMENT= A convenience package to install the compat4x libraries
WRKSRC= ${WRKDIR}/usr/lib/compat
NO_BUILD= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/compat
TARGET_DIR= ${PREFIX}/lib/compat
TARGET32_DIR= ${PREFIX}/lib32/compat
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index f7e65b0161c5..c9a6ce2c3a40 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -26,7 +26,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
NO_BUILD= yes
ONLY_FOR_ARCHS= alpha amd64 i386 sparc64
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/compat
TARGET_DIR= ${PREFIX}/lib/compat
TARGET32_DIR= ${PREFIX}/lib32/compat
diff --git a/misc/gctpc/Makefile b/misc/gctpc/Makefile
index 0efaed06f9ca..37ab18b43673 100644
--- a/misc/gctpc/Makefile
+++ b/misc/gctpc/Makefile
@@ -21,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/source
USE_GMAKE= yes
ALL_TARGET= libgctpc.so.1
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/libgctpc.a ${PREFIX}/lib
diff --git a/misc/gtl/Makefile b/misc/gtl/Makefile
index 22f40be528b1..932c4f3f60f5 100644
--- a/misc/gtl/Makefile
+++ b/misc/gtl/Makefile
@@ -18,7 +18,7 @@ COMMENT= C++ STL-based support for graphs and graph algorithms
RESTRICTED= License forbids redistribution (source or binary)
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= lthack
USE_GCC= 3.3 # Won't build with 3.4
diff --git a/misc/projectionlib/Makefile b/misc/projectionlib/Makefile
index e74d199ff8b5..d9cb097c2cc5 100644
--- a/misc/projectionlib/Makefile
+++ b/misc/projectionlib/Makefile
@@ -21,7 +21,7 @@ EXTRACT_CMD= unzip -a
WRKSRC= ${WRKDIR}/dlgv32/ProjectionLib
USE_ZIP= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAKEFILE= ${FILESDIR}/Makefile
post-install: