aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-01-07 17:46:18 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-01-07 17:46:18 +0000
commit42ae21c9adf61658778e514d0770adb1d03ee4fb (patch)
treef281c07b38800d641ac3fc51271171b3cd7473ac /misc
parente7a6b123500cce87d1f0fd93ef81534ba5c8d898 (diff)
downloadports-42ae21c9adf61658778e514d0770adb1d03ee4fb.tar.gz
ports-42ae21c9adf61658778e514d0770adb1d03ee4fb.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/sword/Makefile16
-rw-r--r--misc/sword/distinfo6
-rw-r--r--misc/sword/files/patch-configure13
-rw-r--r--misc/sword/files/patch-configure.ac13
-rw-r--r--misc/sword/files/pkg-message.in2
-rw-r--r--misc/sword/pkg-plist15
6 files changed, 24 insertions, 41 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index b8ec46ac99b2..3adbfa1ddd24 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sword
-PORTVERSION= 1.6.0
+PORTVERSION= 1.6.1
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v1.6/ \
http://crosswire.org/ftpmirror/pub/sword/source/v1.6/ \
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= tabthorpe
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= A project framework for manipulating Bible texts
-CONFLICTS= sword-1.5*
+BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
MAKE_JOBS_SAFE= yes
@@ -35,18 +35,18 @@ CONFIGURE_ARGS+= --without-curl
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-curl
+run-autotools:: run-autotools-aclocal
+
pre-everything::
@${ECHO_CMD} "Define WITHOUT_CURL to disable remote fetch (curl) support in the installmanager"
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|1.10.2|1.10.1|g' ${WRKSRC}/aclocal.m4
- @${REINPLACE_CMD} -e 's|2.63|2.62|g' ${WRKSRC}/aclocal.m4
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.am
- @@${REINPLACE_CMD} -e 's|:=|=|' ${WRKSRC}/Makefile.am \
- ${WRKSRC}/Makefile.in ${WRKSRC}/lib/Makefile.am \
- ${WRKSRC}/lib/Makefile.in
+ ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|:=|=|' ${WRKSRC}/Makefile.am \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/lib/Makefile.am \
+ ${WRKSRC}/lib/Makefile.in
post-install:
@${MKDIR} ${PREFIX}/share/sword/mods.d
diff --git a/misc/sword/distinfo b/misc/sword/distinfo
index 8a74cc90c66c..8c9fb2f9d04b 100644
--- a/misc/sword/distinfo
+++ b/misc/sword/distinfo
@@ -1,3 +1,3 @@
-MD5 (sword-1.6.0.tar.gz) = 292ca38b2427168b19d629b48a428dde
-SHA256 (sword-1.6.0.tar.gz) = 8f1348c98015c656414f89ffa235afb3b1860cce2b242a81baeb16fde7678f4a
-SIZE (sword-1.6.0.tar.gz) = 1769084
+MD5 (sword-1.6.1.tar.gz) = 347e72f73313ff3ba700368db76a5d50
+SHA256 (sword-1.6.1.tar.gz) = 8b9c5e5cae97dbcb3d980d23c29a27c28c7281f6c9ad422eb6c9c1550b827bd8
+SIZE (sword-1.6.1.tar.gz) = 1893837
diff --git a/misc/sword/files/patch-configure b/misc/sword/files/patch-configure
deleted file mode 100644
index 8ff7c16b76b2..000000000000
--- a/misc/sword/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig Sun May 29 00:59:43 2005
-+++ configure Mon Jul 10 14:10:06 2006
-@@ -20481,8 +20481,8 @@
- echo "curl found - remote install options available"
- CURL_AM_CFLAGS=`$CURL_CONFIG --cflags`
- CURL_LIBS=`$CURL_CONFIG --libs`
-- AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE"
-- AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE"
-+ AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
-+ AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
- fi
- fi
-
diff --git a/misc/sword/files/patch-configure.ac b/misc/sword/files/patch-configure.ac
deleted file mode 100644
index f461d8952bcf..000000000000
--- a/misc/sword/files/patch-configure.ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.ac.orig Mon Jul 10 18:22:50 2006
-+++ configure.ac Mon Jul 10 18:23:13 2006
-@@ -187,8 +187,8 @@
- echo "curl found - remote install options available"
- CURL_AM_CFLAGS=`$CURL_CONFIG --cflags`
- CURL_LIBS=`$CURL_CONFIG --libs`
-- AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE"
-- AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE"
-+ AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
-+ AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
- fi
- fi
-
diff --git a/misc/sword/files/pkg-message.in b/misc/sword/files/pkg-message.in
index db3c756d6416..3023b1dfda7c 100644
--- a/misc/sword/files/pkg-message.in
+++ b/misc/sword/files/pkg-message.in
@@ -13,4 +13,4 @@ to risk detection, you should *not* try this.
and unpack them in %%PREFIX%%/share/sword.
You probably want to install a bible-application that uses sword,
-like bibletime or gnomesword.
+like bibletime or xiphos.
diff --git a/misc/sword/pkg-plist b/misc/sword/pkg-plist
index 3d3545997602..a1c80443599e 100644
--- a/misc/sword/pkg-plist
+++ b/misc/sword/pkg-plist
@@ -20,6 +20,16 @@ include/sword/Greek2Greek.h
include/sword/GreekChars.h
include/sword/canon.h
include/sword/canon_abbrevs.h
+include/sword/canon_german.h
+include/sword/canon_kjva.h
+include/sword/canon_leningrad.h
+include/sword/canon_luther.h
+include/sword/canon_mt.h
+include/sword/canon_nrsv.h
+include/sword/canon_nrsva.h
+include/sword/canon_null.h
+include/sword/canon_synodal.h
+include/sword/canon_vulg.h
include/sword/cipherfil.h
include/sword/curlftpt.h
include/sword/curlhttpt.h
@@ -86,7 +96,6 @@ include/sword/rawstr.h
include/sword/rawstr4.h
include/sword/rawtext.h
include/sword/rawverse.h
-include/sword/regex.h
include/sword/roman.h
include/sword/rtfhtml.h
include/sword/sapphire.h
@@ -166,10 +175,11 @@ include/sword/zld.h
include/sword/zstr.h
include/sword/ztext.h
include/sword/zverse.h
-lib/libsword-1.6.0.so
+lib/libsword-1.6.1.so
lib/libsword.a
lib/libsword.la
lib/libsword.so
+share/sword/locales.d/locales.conf
libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/abbr.conf
%%DATADIR%%/locales.d/af-utf8.conf
@@ -188,7 +198,6 @@ libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/de.conf
%%DATADIR%%/locales.d/de_abbrev-utf8.conf
%%DATADIR%%/locales.d/de_abbrev.conf
-%%DATADIR%%/locales.d/en_GB.conf
%%DATADIR%%/locales.d/es-utf8.conf
%%DATADIR%%/locales.d/es.conf
%%DATADIR%%/locales.d/et-utf8.conf