aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-06 03:42:27 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-06 03:42:27 +0000
commit0c446614bd1bd8f89185d7ed63ebb16013c559c0 (patch)
tree0341807b24ba0038d453127bde0bdacb15eaf21a /misc
parent71a6c2ecf63abe6eda6f31a6223f6fc8b4ffe7e7 (diff)
downloadports-0c446614bd1bd8f89185d7ed63ebb16013c559c0.tar.gz
ports-0c446614bd1bd8f89185d7ed63ebb16013c559c0.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-Geocoder-US/Makefile35
-rw-r--r--misc/p5-Geo-Coder-Geocoder-US/distinfo2
-rw-r--r--misc/p5-Geo-Coder-Geocoder-US/pkg-descr5
-rw-r--r--misc/p5-Geo-Coder-Geocoder-US/pkg-plist9
5 files changed, 52 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 7043ade93b54..870117b5e97b 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -402,6 +402,7 @@
SUBDIR += p5-File-Sort
SUBDIR += p5-Geo-Cache
SUBDIR += p5-Geo-Coder-Bing
+ SUBDIR += p5-Geo-Coder-Geocoder-US
SUBDIR += p5-Geo-Coder-Google
SUBDIR += p5-Geo-Coder-Googlev3
SUBDIR += p5-Geo-Coder-Many
diff --git a/misc/p5-Geo-Coder-Geocoder-US/Makefile b/misc/p5-Geo-Coder-Geocoder-US/Makefile
new file mode 100644
index 000000000000..81c5eb010f5a
--- /dev/null
+++ b/misc/p5-Geo-Coder-Geocoder-US/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Geo-Coder-Geocoder-US
+# Date created: 2011-12-06
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-Geocoder-US
+PORTVERSION= 0.002
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:WYANT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode a location using http://geocoder.us/
+
+BUILD_DEPENDS= p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::Geocoder::US.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-Geocoder-US/distinfo b/misc/p5-Geo-Coder-Geocoder-US/distinfo
new file mode 100644
index 000000000000..324bb1fb1670
--- /dev/null
+++ b/misc/p5-Geo-Coder-Geocoder-US/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-Geocoder-US-0.002.tar.gz) = 758b3c6bcb7b436770db322e0018349a91662d94bf621d65f167abbbe3c9e3df
+SIZE (Geo-Coder-Geocoder-US-0.002.tar.gz) = 20684
diff --git a/misc/p5-Geo-Coder-Geocoder-US/pkg-descr b/misc/p5-Geo-Coder-Geocoder-US/pkg-descr
new file mode 100644
index 000000000000..ffbf453ff8d9
--- /dev/null
+++ b/misc/p5-Geo-Coder-Geocoder-US/pkg-descr
@@ -0,0 +1,5 @@
+Geo::Coder::Geocoder::US geocodes addresses by looking them up on the
+http://geocoder.us/ website. Because this site throttles access, this class does
+to, to one request every 15 seconds.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-Geocoder-US/
diff --git a/misc/p5-Geo-Coder-Geocoder-US/pkg-plist b/misc/p5-Geo-Coder-Geocoder-US/pkg-plist
new file mode 100644
index 000000000000..60586bce825b
--- /dev/null
+++ b/misc/p5-Geo-Coder-Geocoder-US/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Geo/Coder/Geocoder/US.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Geocoder/US/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Geocoder/US
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Geocoder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder/Geocoder
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo