aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /misc
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/ftree/Makefile13
-rw-r--r--misc/linux-edonkey-tool-list/Makefile13
-rw-r--r--misc/linux-edonkey-tool-recovermet/Makefile11
-rw-r--r--misc/linux-opengroupware/Makefile9
-rw-r--r--misc/opencyc/Makefile6
5 files changed, 14 insertions, 38 deletions
diff --git a/misc/ftree/Makefile b/misc/ftree/Makefile
index d4f217e13dff..f42fadae39cd 100644
--- a/misc/ftree/Makefile
+++ b/misc/ftree/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ftree
PORTVERSION= 1.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc linux
MASTER_SITES= http://www.vjet.demon.co.uk/ftree/ \
http://www.unknown.nu/ports/
@@ -17,23 +17,18 @@ EXTRACT_SUFX= .tgz
MAINTAINER= user@unknown.nu
COMMENT= An X11 genealogy program
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
-USE_X_PREFIX= yes
-
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_CDROM= Non-commercial use only
RESTRICTED= Non-commercial use only
WRKSRC= ${WRKDIR}/usr
MAN1= ftree.1
-STRIP= # empty: do not strip linux binary!
-
-do-patch:
-do-configure:
do-build:
${BRANDELF} -t Linux ${WRKSRC}/bin/ftree
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/ftree ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/share/man/man1/ftree.1 ${PREFIX}/man/man1
diff --git a/misc/linux-edonkey-tool-list/Makefile b/misc/linux-edonkey-tool-list/Makefile
index 3f3de502a2e8..e94d56c354a4 100644
--- a/misc/linux-edonkey-tool-list/Makefile
+++ b/misc/linux-edonkey-tool-list/Makefile
@@ -20,19 +20,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Creates a web page with ed2k:// links to all your shared files
ONLY_FOR_ARCHS= i386
-USE_LINUX?= yes
+USE_LINUX= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/edonkey-tool-list
-STRIP=
-
-STRIP_CMD= ${LINUXBASE}/usr/bin/strip
-
-.if exists(/usr/bin/brandelf)
-BRANDELF?= /usr/bin/brandelf
-.else
-BRANDELF?= brandelf
-.endif
BINARY_NAME= ${PORTNAME}${PKGNAMESUFFIX}
@@ -45,9 +36,7 @@ do-install:
.include <bsd.port.pre.mk>
pre-install:
-.if exists(${STRIP_CMD})
@${STRIP_CMD} ${WRKSRC}/${BINARY_NAME}
-.endif
@${BRANDELF} -t Linux ${WRKSRC}/${BINARY_NAME}
.include <bsd.port.post.mk>
diff --git a/misc/linux-edonkey-tool-recovermet/Makefile b/misc/linux-edonkey-tool-recovermet/Makefile
index 35befd2aae5a..06eb58419530 100644
--- a/misc/linux-edonkey-tool-recovermet/Makefile
+++ b/misc/linux-edonkey-tool-recovermet/Makefile
@@ -20,19 +20,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tool that tries to re-create x.part.met files compromised due to crash
ONLY_FOR_ARCHS= i386
-USE_LINUX?= yes
+USE_LINUX= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/edonkey-tool-recovermet
-STRIP=
-
-STRIP_CMD= ${LINUXBASE}/usr/bin/strip
-
-.if exists(/usr/bin/brandelf)
-BRANDELF?= /usr/bin/brandelf
-.else
-BRANDELF?= brandelf
-.endif
BINARY_NAME= ${PORTNAME}${PKGNAMESUFFIX}
diff --git a/misc/linux-opengroupware/Makefile b/misc/linux-opengroupware/Makefile
index 9a0914c8731e..7745b417dec5 100644
--- a/misc/linux-opengroupware/Makefile
+++ b/misc/linux-opengroupware/Makefile
@@ -6,7 +6,7 @@
PORTNAME= opengroupware
PORTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= misc www linux
MASTER_SITES= http://download.opengroupware.org/packages/freebsd/linux-opengroupware/RPMS/:ogo \
http://download.opengroupware.org/packages/freebsd/linux-opengroupware/NGOBJWEB/:ngo \
@@ -22,11 +22,12 @@ MAINTAINER= frank@opengroupware.org
COMMENT= Groupware package including mail, calendar, palm sync and much more
EXTRACT_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
-INSTALL_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2 \
- ${LOCALBASE}/bin/psql:${PORTSDIR}/databases/postgresql7 \
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2 \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2 \
${LOCALBASE}/bin/gmake:${PORTSDIR}/devel/gmake
+USE_PGSQL= yes
+
#BEGINSET1
SET1= opengroupware-core-4.2-ogo107.i386.rpm:ogo \
@@ -105,7 +106,7 @@ SET3= postgresql-libs-7.2.4-5.80.i386.rpm \
NGOBJWEB_ADAPTOR= opengroupware.org-mod_ngobjweb-200407092000.tar.gz
PATCHDIR?= ${MASTERDIR}/files
-USE_LINUX?= yes
+USE_LINUX= yes
USE_GMAKE= yes
MAKEFILE= ${WRKSRC}/opengroupware.org-mod_ngobjweb/GNUmakefile
BUILD_WRKSRC?= ${WRKSRC}/opengroupware.org-mod_ngobjweb
diff --git a/misc/opencyc/Makefile b/misc/opencyc/Makefile
index adaac7516ee6..6318e9302045 100644
--- a/misc/opencyc/Makefile
+++ b/misc/opencyc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opencyc
PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc linux
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,8 +16,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= alexs@snark.rinet.ru
COMMENT= General knowledge base and commonsense reasoning engine
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_BUILD= yes
PLIST_SUB= PORTVERSION="${PORTVERSION}"