aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
commit3726f942547e374490d375baf83216d7644a7162 (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /misc
parent1de291090d9121f4d238a639b441f64372c239c1 (diff)
downloadports-3726f942547e374490d375baf83216d7644a7162.tar.gz
ports-3726f942547e374490d375baf83216d7644a7162.zip
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Notes
Notes: svn path=/head/; revision=505321
Diffstat (limited to 'misc')
-rw-r--r--misc/cryptoballot/Makefile2
-rw-r--r--misc/exercism/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/misc/cryptoballot/Makefile b/misc/cryptoballot/Makefile
index 6ea459da7442..9390aa1fbb39 100644
--- a/misc/cryptoballot/Makefile
+++ b/misc/cryptoballot/Makefile
@@ -9,7 +9,7 @@ COMMENT= Cryptographically secure online voting
LICENSE= AGPLv3
-BUILD_DEPENDS= go:lang/go
+USES= go
USE_GITHUB= yes
GH_TAGNAME= 3753e1b
diff --git a/misc/exercism/Makefile b/misc/exercism/Makefile
index f2dcc3fdd311..b24a32347f81 100644
--- a/misc/exercism/Makefile
+++ b/misc/exercism/Makefile
@@ -11,7 +11,7 @@ COMMENT= CLI client for exercism.io
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
+USES= go
USE_GITHUB= yes