aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-16 18:41:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-16 18:41:01 +0000
commit0a2f6f7c3b03e9c11ba3b316c2a26e230924e317 (patch)
tree83bae08308002e05af780f2b5d27386179640619 /misc
parent0a38eed238cb9bafcd1962b8c4f9cab711fdc198 (diff)
downloadports-0a2f6f7c3b03e9c11ba3b316c2a26e230924e317.tar.gz
ports-0a2f6f7c3b03e9c11ba3b316c2a26e230924e317.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/owrep/Makefile18
-rw-r--r--misc/owrep/distinfo3
-rw-r--r--misc/owrep/files/patch-Makefile41
-rw-r--r--misc/owrep/pkg-descr4
-rw-r--r--misc/owrep/pkg-plist4
6 files changed, 71 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 40df048b8a3d..f0b258d0e75d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -286,6 +286,7 @@
SUBDIR += osinfo-db
SUBDIR += ossp-uuid
SUBDIR += otter
+ SUBDIR += owrep
SUBDIR += p5-Acme-ButFirst
SUBDIR += p5-Array-Compare
SUBDIR += p5-Array-Diff
diff --git a/misc/owrep/Makefile b/misc/owrep/Makefile
new file mode 100644
index 000000000000..23044aea3bc0
--- /dev/null
+++ b/misc/owrep/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= owrep
+DISTVERSION= 1.1
+CATEGORIES= misc
+MASTER_SITES= http://www.ml1.org.uk/distfiles/ \
+ http://www.ancientgeek.org.uk/distfiles/
+
+MAINTAINER= bob@eager.cx
+COMMENT= Weather reporting program based on openweathermap.org
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libexpat.so:textproc/expat2
+
+USES= localbase:ldflags zip
+
+.include <bsd.port.mk>
diff --git a/misc/owrep/distinfo b/misc/owrep/distinfo
new file mode 100644
index 000000000000..4f9660503591
--- /dev/null
+++ b/misc/owrep/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1508972794
+SHA256 (owrep-1.1.zip) = 53e3ac6951b59619d817230cbf5f514961911ad625bfec4922094189963dfc0a
+SIZE (owrep-1.1.zip) = 21700
diff --git a/misc/owrep/files/patch-Makefile b/misc/owrep/files/patch-Makefile
new file mode 100644
index 000000000000..e2c27b749347
--- /dev/null
+++ b/misc/owrep/files/patch-Makefile
@@ -0,0 +1,41 @@
+--- Makefile.orig 2017-05-30 23:54:30 UTC
++++ Makefile
+@@ -5,10 +5,10 @@
+ #
+ CC?= clang
+ #
+-INSTALL_TO = /usr/local/bin
+-INSTALL_MAN1= /usr/local/man/man1
+-INSTALL_MAN5= /usr/local/man/man5
+-INSTALL_ETC= /usr/local/etc
++INSTALL_TO = $(DESTDIR)/$(PREFIX)/bin
++INSTALL_MAN1= $(DESTDIR)/$(PREFIX)/man/man1
++INSTALL_MAN5= $(DESTDIR)/$(PREFIX)/man/man5
++INSTALL_ETC= $(DESTDIR)/$(PREFIX)/etc
+ #
+ PRODUCT = owrep
+ #
+@@ -38,7 +38,7 @@ CFLAGS+= -O2 $(COMFLAGS) -I /usr/local/i
+ all: $(PRODUCT)
+ #
+ $(PRODUCT): $(OBJ)
+- $(CC) -o $(.TARGET) -L /usr/local/lib $(LIBS) $(.ALLSRC)
++ $(CC) -o $(.TARGET) $(LDFLAGS) $(LIBS) $(.ALLSRC)
+ #
+ depend:
+ mkdep $(CFLAGS) $(SRC)
+@@ -46,10 +46,10 @@ depend:
+ install: $(PRODUCT)
+ gzip -f -k $(MAN1)
+ gzip -f -k $(MAN5)
+- install -s -g wheel -o root $(PRODUCT) $(INSTALL_TO)
+- install -g wheel -o root $(MAN1).gz $(INSTALL_MAN1)
+- install -g wheel -o root $(MAN5).gz $(INSTALL_MAN5)
+- install -g wheel -o root $(CONF) $(INSTALL_ETC)
++ install -s $(PRODUCT) $(INSTALL_TO)
++ install $(MAN1).gz $(INSTALL_MAN1)
++ install $(MAN5).gz $(INSTALL_MAN5)
++ install $(CONF) $(INSTALL_ETC)
+ rm -f $(MAN1).gz $(MAN5).gz
+ #
+ distfile:
diff --git a/misc/owrep/pkg-descr b/misc/owrep/pkg-descr
new file mode 100644
index 000000000000..9ce862cb9bf7
--- /dev/null
+++ b/misc/owrep/pkg-descr
@@ -0,0 +1,4 @@
+This is a basic weather reporting program. It uses data from
+openweathermap.org, and uses a worldwide database.
+
+WWW: http://www.tavi.co.uk
diff --git a/misc/owrep/pkg-plist b/misc/owrep/pkg-plist
new file mode 100644
index 000000000000..aed172378732
--- /dev/null
+++ b/misc/owrep/pkg-plist
@@ -0,0 +1,4 @@
+bin/owrep
+%%ETCDIR%%.conf.sample
+man/man1/owrep.1.gz
+man/man5/owrep.conf.5.gz