aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-17 12:58:11 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-17 12:58:11 +0000
commit16a085054eb507823629fac03b4e0ced18b1b484 (patch)
tree1da5d65f5f3f5ec47945827e4f406473049a4e25 /misc
parent9c2dfc108b3479173c5d8d83ee3bace003568e45 (diff)
downloadports-16a085054eb507823629fac03b4e0ced18b1b484.tar.gz
ports-16a085054eb507823629fac03b4e0ced18b1b484.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/pipebench/Makefile27
-rw-r--r--misc/pipebench/distinfo1
-rw-r--r--misc/pipebench/pkg-comment1
-rw-r--r--misc/pipebench/pkg-descr8
-rw-r--r--misc/pipebench/pkg-plist1
6 files changed, 39 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 8fa4a17465b6..0fa2fd3a353b 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -258,6 +258,7 @@
SUBDIR += peq
SUBDIR += pg
SUBDIR += pinfo
+ SUBDIR += pipebench
SUBDIR += pl-sms
SUBDIR += porteasy
SUBDIR += portell
diff --git a/misc/pipebench/Makefile b/misc/pipebench/Makefile
new file mode 100644
index 000000000000..8b713acf79b9
--- /dev/null
+++ b/misc/pipebench/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: pipebench
+# Date created: Jan 14, 2003
+# Whom: mich@freebsdcluster.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pipebench
+PORTVERSION= 0.20
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/
+
+MAINTAINER= mich@freebsdcluster.org
+
+USE_REINPLACE= yes
+
+post-patch:
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|g" \
+ -e "s|^CFLAGS|#CFLAGS|g" ${WRKSRC}/Makefile
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pipebench ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pipebench.1 ${PREFIX}/man/man1
+
+MAN1= pipebench.1
+.include <bsd.port.mk>
diff --git a/misc/pipebench/distinfo b/misc/pipebench/distinfo
new file mode 100644
index 000000000000..d2ecfcf85b62
--- /dev/null
+++ b/misc/pipebench/distinfo
@@ -0,0 +1 @@
+MD5 (pipebench-0.20.tar.gz) = 87093497c36ab29190777bf2c7f381a3
diff --git a/misc/pipebench/pkg-comment b/misc/pipebench/pkg-comment
new file mode 100644
index 000000000000..ed3fb8697ccb
--- /dev/null
+++ b/misc/pipebench/pkg-comment
@@ -0,0 +1 @@
+Pipebench shows current throughput/amount of data through a pipe
diff --git a/misc/pipebench/pkg-descr b/misc/pipebench/pkg-descr
new file mode 100644
index 000000000000..6b1453945bbe
--- /dev/null
+++ b/misc/pipebench/pkg-descr
@@ -0,0 +1,8 @@
+Pipebench shows the current throughput and amount of data going through a
+pipe. It can be used to show the progress of a large md5sum process:
+cat bigfile | pipebench | md5sum.
+
+WWW: http://www.habets.pp.se/synscan/programs.php?prog=pipebench
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/misc/pipebench/pkg-plist b/misc/pipebench/pkg-plist
new file mode 100644
index 000000000000..5140f6dec434
--- /dev/null
+++ b/misc/pipebench/pkg-plist
@@ -0,0 +1 @@
+bin/pipebench