aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2009-09-28 18:01:54 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2009-09-28 18:01:54 +0000
commitbf08a4e7c1bf73aa212f038f1f373e11a126d94f (patch)
tree9a4e06289b29439be8593902aeec6158e710584a /misc
parent5f0ce9c9c5eba7f8172367cef0a60e1ec39019aa (diff)
downloadports-bf08a4e7c1bf73aa212f038f1f373e11a126d94f.tar.gz
ports-bf08a4e7c1bf73aa212f038f1f373e11a126d94f.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/xiphos/Makefile14
-rw-r--r--misc/xiphos/files/patch-src__gecko__gecko-utils.cpp13
2 files changed, 21 insertions, 6 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index 72051a9256d2..200b96275c63 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xiphos
PORTVERSION= 3.1.1
+PORTREVISION= 1
CATEGORIES= misc gnome
MASTER_SITES= SF/gnomesword/Xiphos/${PORTVERSION}
@@ -27,22 +28,23 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --disable-maintainer-mode --enable-paratab
-OPTIONS= XULRUNNER "Build with xulrunner (default)" off \
+OPTIONS= LIBXUL "Build with libxul (default)" off \
GTKHTML "Build with gtkhtml" off
.include <bsd.port.pre.mk>
-.if defined(WITH_XULRUNNER) && defined(WITH_GTKHTML)
-IGNORE= choose only one of XULRUNNER or GTKHTML
+.if defined(WITH_LIBXUL) && defined(WITH_GTKHTML)
+IGNORE= choose only one of LIBXUL or GTKHTML
.endif
-.if defined(WITH_GTKHTML) || defined(WITHOUT_XULRUNNER)
+.if defined(WITH_GTKHTML) || defined(WITHOUT_LIBXUL)
CONFIGURE_ARGS+= --enable-gtkhtml --disable-gecko
.endif
-.if !defined(WITHOUT_XULRUNNER) || !defined(WITH_GTKHTML)
-USE_GECKO= xulrunner
+.if !defined(WITHOUT_LIBXUL) || !defined(WITH_GTKHTML)
+USE_GECKO= libxul
CONFIGURE_ARGS+= --with-gecko=${GECKO} --disable-gtkhtml
+GTKHTML_CFLAGS+="-DXPCOM_GLUE"
.endif
.include <bsd.port.post.mk>
diff --git a/misc/xiphos/files/patch-src__gecko__gecko-utils.cpp b/misc/xiphos/files/patch-src__gecko__gecko-utils.cpp
new file mode 100644
index 000000000000..31e4f3216306
--- /dev/null
+++ b/misc/xiphos/files/patch-src__gecko__gecko-utils.cpp
@@ -0,0 +1,13 @@
+--- ./src/gecko/gecko-utils.cpp.orig 2009-08-09 18:52:26.000000000 -0400
++++ ./src/gecko/gecko-utils.cpp 2009-09-28 13:36:48.000000000 -0400
+@@ -38,10 +38,6 @@
+ # undef NS_EXPORT_
+ #endif
+
+-#ifdef HAVE_GECKO_1_9
+-#include <gtkmozembed_glue.cpp>
+-#endif
+-
+ #include <gtkmozembed.h>
+ #include <gtkmozembed_internal.h>
+ #include <nsCOMPtr.h>