aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-01-15 13:40:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-01-15 13:40:28 +0000
commitc4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8 (patch)
tree98f96307b5a32cecd5d4e2104c22673c560b9789 /misc
parent56b2cbf1c5abcce2be96f0aa252e4df4d8d99dd2 (diff)
downloadports-c4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8.tar.gz
ports-c4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/countrycodes/Makefile12
-rw-r--r--misc/gopod/Makefile15
-rw-r--r--misc/ree/Makefile12
3 files changed, 18 insertions, 21 deletions
diff --git a/misc/countrycodes/Makefile b/misc/countrycodes/Makefile
index 743e272a6c34..1bc3bb76fe05 100644
--- a/misc/countrycodes/Makefile
+++ b/misc/countrycodes/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: countrycodes
-# Date created: 6 Jul 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= countrycodes
PORTVERSION= 1.0.5
@@ -27,8 +23,12 @@ MAN1= iso3166.1
MAKE_ARGS= prefix="${PREFIX}" CC="${CC}" CCOPTS="${CFLAGS}" WARNINGS=""
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/misc/gopod/Makefile b/misc/gopod/Makefile
index 3e4003c4cc17..08e6bd40bf7b 100644
--- a/misc/gopod/Makefile
+++ b/misc/gopod/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gopod
-# Date created: 4 April 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= gopod
PORTVERSION= 1.4
@@ -19,6 +15,7 @@ COMMENT?= Utility to cap/uncap an iPod
HAS_CONFIGURE= yes
USE_GMAKE= yes
+USE_DOS2UNIX= yes
MAKE_JOBS_SAFE= yes
MAKE_ARGS+= CC="${CC}"
@@ -32,9 +29,9 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/console-version
PORTDOCS= README_EN README_FR
-post-extract:
- @${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|h)" -print0 | \
- ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
post-patch:
.if ${PKGNAMEPREFIX} == "gtk-"
@@ -59,7 +56,7 @@ do-install:
${PREFIX}/bin/${UNIQUENAME}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/misc/ree/Makefile b/misc/ree/Makefile
index 131e26dae3ac..b5cab5ccf45f 100644
--- a/misc/ree/Makefile
+++ b/misc/ree/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ree
-# Date created: 7 Jul 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= ree
PORTVERSION= 1.3
@@ -21,6 +17,10 @@ MAKE_JOBS_SAFE= yes
ONLY_FOR_ARCHS= i386 amd64
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-build:
.for f in ${PORTNAME} fontdump
${CC} ${CFLAGS} ${WRKSRC}/${f}.c -o ${WRKSRC}/${f}
@@ -30,7 +30,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/rom-${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/fontdump ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
.endif