aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
commit4a4ec28d37b64039d4eff0f34ad66b543767d758 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /misc
parenta5d24d4bb4a43375b4bbb7f8bc673f8c557f06b4 (diff)
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/dahdi-kmod/Makefile2
-rw-r--r--misc/dahdi-kmod26/Makefile2
-rw-r--r--misc/freebsd-doc-en/Makefile4
-rw-r--r--misc/gnome2-reference/Makefile10
-rw-r--r--misc/zoneinfo/Makefile4
5 files changed, 10 insertions, 12 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index fbd854ef1109..fbd6c586ad8d 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -57,7 +57,7 @@ PLIST_SUB+= X86="@comment "
.endif
.for _f in ${FIRMWARES}
-${_f}_NAME?= dahdi-fw-${_f:L:S/_/-/g}
+${_f}_NAME?= dahdi-fw-${_f:tl:S/_/-/g}
${_f}_DIR?= ${${_f}_NAME}.bin
${_f}_DISTFILE= ${${_f}_NAME}-${${_f}_VERSION}.tar.gz
DISTFILES+= ${${_f}_DISTFILE}:firmware
diff --git a/misc/dahdi-kmod26/Makefile b/misc/dahdi-kmod26/Makefile
index d35cfe8f66fe..de8f2345a2c6 100644
--- a/misc/dahdi-kmod26/Makefile
+++ b/misc/dahdi-kmod26/Makefile
@@ -59,7 +59,7 @@ PLIST_SUB+= X86="@comment "
.endif
.for _f in ${FIRMWARES}
-${_f}_NAME?= dahdi-fw-${_f:L:S/_/-/g}
+${_f}_NAME?= dahdi-fw-${_f:tl:S/_/-/g}
${_f}_DIR?= ${${_f}_NAME}.bin
${_f}_DISTFILE= ${${_f}_NAME}-${${_f}_VERSION}.tar.gz
DISTFILES+= ${${_f}_DISTFILE}:firmware
diff --git a/misc/freebsd-doc-en/Makefile b/misc/freebsd-doc-en/Makefile
index 5326e3d3aeae..c797f367d746 100644
--- a/misc/freebsd-doc-en/Makefile
+++ b/misc/freebsd-doc-en/Makefile
@@ -50,8 +50,8 @@ OPTIONS_SET+= ${AVAILABLEFORMATS}
.for O in ${AVAILABLEFORMATS}
.if ${PORT_OPTIONS:M${O}}
-DOCFORMAT+= ${O:L:S,_,-,}
-PLIST_FORMATS+= ${O:L:S,_,-,}
+DOCFORMAT+= ${O:tl:S,_,-,}
+PLIST_FORMATS+= ${O:tl:S,_,-,}
.endif
.endfor
diff --git a/misc/gnome2-reference/Makefile b/misc/gnome2-reference/Makefile
index c4884d2dedc9..aec4b2dd84dd 100644
--- a/misc/gnome2-reference/Makefile
+++ b/misc/gnome2-reference/Makefile
@@ -53,21 +53,19 @@ NO_BUILD= yes
NO_INSTALL= yes
NO_MTREE= yes
-.MAKE.FreeBSD_UL= yes
-
REF_LIST_INC= ${.CURDIR}/Makefile.inc
.include "${REF_LIST_INC}"
.for ref in ${_PORT_REF_LIST:C/^([^:]+).*/\1/}
-OPTIONS_DEFINE+= ${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//:S/-/_/:U}
-OPTIONS_DEFAULT+= ${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//:S/-/_/:U}
-${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//:S/-/_/:U}_DESC= Install ${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//} programing reference
+OPTIONS_DEFINE+= ${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//:S/-/_/:tu}
+OPTIONS_DEFAULT+= ${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//:S/-/_/:tu}
+${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//:S/-/_/:tu}_DESC= Install ${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//} programing reference
.endfor
.include <bsd.port.options.mk>
.for ref in ${_PORT_REF_LIST}
-.if ${PORT_OPTIONS:M${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//:S/-/_/:U:C/^([^:]+).*/\1/}}
+.if ${PORT_OPTIONS:M${ref:C|^[^/]+/([^/]+).*|\1|:S/-reference//:S/-/_/:tu:C/^([^:]+).*/\1/}}
RUN_DEPENDS+= ${ref:C|^[^:]+:([^:]+).*|\1|:C|^[^/]+/([^/]+).*|\1|}>0:${PORTSDIR}/${ref:C/^([^:]+).*/\1/}
.endif
.endfor
diff --git a/misc/zoneinfo/Makefile b/misc/zoneinfo/Makefile
index 72d5f6e8e635..b966cd108936 100644
--- a/misc/zoneinfo/Makefile
+++ b/misc/zoneinfo/Makefile
@@ -38,8 +38,8 @@ MISSING= ax bl bq cw gg im je me mf rs ss sx
.ifndef NOMISSING
.for M in ${MISSING}
-HAS_${M:U}!= ${GREP} -c ^${M:U} /usr/share/misc/iso3166 || ${TRUE}
-.if ${HAS_${M:U}} == "0"
+HAS_${M:tu}!= ${GREP} -c ^${M:tu} /usr/share/misc/iso3166 || ${TRUE}
+.if ${HAS_${M:tu}} == "0"
EXTRA_PATCHES+= ${FILESDIR}/patchremove-${M}
.endif
.endfor