aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-03-24 19:49:22 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-03-24 19:49:22 +0000
commit94468f8ffa6f6eee0a774a934c4b671e798f7c8c (patch)
treec07cd1d5997f0a74fb75b8b915457ac274d518b3 /misc
parent253a3191eab7cad702bfe10efe440ff757aedc6e (diff)
downloadports-94468f8ffa6f6eee0a774a934c4b671e798f7c8c.tar.gz
ports-94468f8ffa6f6eee0a774a934c4b671e798f7c8c.zip
Sort variables
No functional changes intended.
Notes
Notes: svn path=/head/; revision=529060
Diffstat (limited to 'misc')
-rw-r--r--misc/xosd/Makefile27
1 files changed, 15 insertions, 12 deletions
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index 4aaefd11a758..c3dece4d3a4e 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -13,31 +13,34 @@ COMMENT= X11 on-screen-display program and library
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake pkgconfig libtool xorg
+USES= gmake libtool pkgconfig xorg
USE_CSTD= gnu89
-USE_XORG= x11 xext xt sm ice xinerama
USE_LDCONFIG= yes
+USE_XORG= ice sm x11 xext xinerama xt
GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG='${GTK_CONFIG}' GLIB_CONFIG='${GLIB_CONFIG}'
-CONFIGURE_ARGS= --disable-beep_media_player_plugin --disable-new-plugin
-PATCH_STRIP= -p1
+CONFIGURE_ARGS= --disable-beep_media_player_plugin \
+ --disable-new-plugin
+CONFIGURE_ENV= GLIB_CONFIG='${GLIB_CONFIG}' \
+ GTK_CONFIG='${GTK_CONFIG}'
INSTALL_TARGET= install-strip
+PATCH_STRIP= -p1
PORTDOCS= AUTHORS ChangeLog TODO
-OPTIONS_DEFINE= MSEC XFT DOCS
+OPTIONS_DEFINE= DOCS MSEC XFT
+OPTIONS_SUB= yes
+
MSEC_DESC= Use milliseconds timeout (breaks compatibility!)
XFT_DESC= Unofficial Xft support
-OPTIONS_SUB= yes
-
MSEC_EXTRA_PATCHES= ${FILESDIR}/extra-patch-msec-timeout
-MSEC_VARS= DELAY_UNITS=milliseconds
-MSEC_VARS_OFF= DELAY_UNITS=seconds
+MSEC_VARS= DELAY_UNITS=milliseconds
+MSEC_VARS_OFF= DELAY_UNITS=seconds
-XFT_EXTRA_PATCHES= ${FILESDIR}/extra-patch-xft
XFT_USES= gnome
-XFT_USE= GNOME=pango XORG=xft
+XFT_USE= GNOME=pango \
+ XORG=xft
+XFT_EXTRA_PATCHES= ${FILESDIR}/extra-patch-xft
post-patch:
@${REINPLACE_CMD} -e 's,^\(CFLAGS =\)\(.*\)$$,\1 -I..\2,' \