aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2012-09-14 05:04:30 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2012-09-14 05:04:30 +0000
commitb5d8d1e99e8e083ed005a76c14f2c99b09961efe (patch)
tree59ccf386cd4139fe2ee7811bbe096b5824b7ae00 /misc
parent1739d306a948b26d59fc94850cfdd7f50c9ccda4 (diff)
downloadports-b5d8d1e99e8e083ed005a76c14f2c99b09961efe.tar.gz
ports-b5d8d1e99e8e083ed005a76c14f2c99b09961efe.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/lv/Makefile2
-rw-r--r--misc/lv/files/patch-src_lv.c49
2 files changed, 1 insertions, 50 deletions
diff --git a/misc/lv/Makefile b/misc/lv/Makefile
index ea44b43a140f..f92f4e1679a4 100644
--- a/misc/lv/Makefile
+++ b/misc/lv/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lv
PORTVERSION= 4.51
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
MASTER_SITES= http://www.ff.iij4u.or.jp/~nrt/freeware/
DISTNAME= lv451
diff --git a/misc/lv/files/patch-src_lv.c b/misc/lv/files/patch-src_lv.c
deleted file mode 100644
index 5922497d86ef..000000000000
--- a/misc/lv/files/patch-src_lv.c
+++ /dev/null
@@ -1,49 +0,0 @@
---- lv.c.orig 2004-01-05 16:30:15.000000000 +0900
-+++ lv.c 2012-08-23 16:49:46.728726453 +0900
-@@ -2,6 +2,7 @@
- * lv.c
- *
- * All rights reserved. Copyright (C) 1996 by NARITA Tomio.
-+ * Copyright (C) Oct 27, 2011 Koichiro IWAO. All rights reserved.
- * $Id: lv.c,v 1.10 2004/01/05 07:30:15 nrt Exp $
- */
- /*
-@@ -89,16 +90,35 @@
- grep_mode = FALSE;
- }
-
-+private boolean_t isDirectory(byte **file) {
-+ struct stat buf;
-+ stat((unsigned char *)file, &buf);
-+ if (S_ISDIR(buf.st_mode)) {
-+ fprintf(stderr, "%s is a directory\n", file);
-+ return TRUE;
-+ } else {
-+ return FALSE;
-+ }
-+}
-+
- private boolean_t LvOpen( conf_t *conf )
- {
-+ boolean_t flagIsDirectory = FALSE;
-+
- if( NULL != conf->file ){
-+ if( TRUE == isDirectory( *conf->file ) ){
-+ flagIsDirectory = TRUE;
-+ }
- if( NULL == (conf->st = StreamOpen( *conf->file )) ){
- while( NULL != *(++conf->file) ){
-- if( NULL != (conf->st = StreamOpen( *conf->file )) )
-- return TRUE;
-+ if( NULL != (conf->st = StreamOpen( *conf->file )) ){
-+ if( TRUE == isDirectory( *conf->file ) ){
-+ flagIsDirectory = TRUE;
-+ }
-+ }
- }
-- return FALSE;
- }
-+ return (TRUE == flagIsDirectory ? FALSE : TRUE);
- } else {
- conf->st = StreamReconnectStdin();
- }