aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-04-02 22:30:28 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-04-02 22:30:28 +0000
commitde831e2067fab8cc7f77b4c06194bb493518c187 (patch)
tree6e5b1cfb052ad4cd5268a6131bd8d30b1dd911ce /misc
parent75c4ea5e7bbe260a2cbc03a8f09d227d838d4674 (diff)
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/mc/Makefile27
-rw-r--r--misc/mc/distinfo6
-rw-r--r--misc/mc/files/mc.desktop10
-rw-r--r--misc/mc/files/patch-lib__tty__key.c18
-rw-r--r--misc/mc/files/patch-lib__tty__tty-ncurses.c26
-rw-r--r--misc/mc/files/pkg-message.in14
-rw-r--r--misc/mc/pkg-plist20
7 files changed, 69 insertions, 52 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index b7099326766f..228edfa1cef7 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -2,10 +2,14 @@
# $FreeBSD$
PORTNAME= mc
-PORTVERSION= 4.8.11
-PORTREVISION= 0
+PORTVERSION= 4.8.12
CATEGORIES= misc shells
-MASTER_SITES= http://ftp.osuosl.org/pub/midnightcommander/
+MASTER_SITES= http://ftp.midnight-commander.org/ \
+ http://ftp.osuosl.org/pub/midnightcommander/ \
+ SF/nemysisfreebsdp/misc/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Midnight Commander, a free Norton Commander Clone
@@ -16,9 +20,11 @@ LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
CONFLICTS= mc-light-4*
-USE_XZ= yes
-USES= gmake perl5 pkgconfig
+USES= gmake shebangfix perl5 pkgconfig tar:xz
+SHEBANG_FILES= misc/mcedit.menu configure configure.ac
USE_GNOME= glib20
+USE_PYTHON= yes
+USE_RUBY= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ZIP=${UNZIP_CMD} UNZIP=${UNZIP_CMD}
USE_AUTOTOOLS= libtool
@@ -53,6 +59,8 @@ SUBSHELL_CONFIGURE_WITH= subshell
X11_CONFIGURE_ENABLE= x
+SUB_FILES= pkg-message
+
PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
@@ -60,7 +68,7 @@ DOC_FILES1= AUTHORS NEWS README
DOCSRCDIR2= ${WRKSRC}/doc
DOCSDIR2= ${DOCSDIR}/doc
-DOC_FILES2= FAQ HACKING MAINTAINERS *.txt TODO
+DOC_FILES2= FAQ HACKING MAINTAINERS *.txt
.include <bsd.port.options.mk>
@@ -82,9 +90,16 @@ CONFIGURE_ARGS+=--with-screen=ncurses
.endif
post-patch:
+ ${REINPLACE_CMD} -e 's|missing-parameter-type|unused-variable|; \
+ s|but-set-variable|variable|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|SUBDIRS = intl|SUBDIRS =|' ${WRKSRC}/Makefile.in
post-install:
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}
diff --git a/misc/mc/distinfo b/misc/mc/distinfo
index f88a975f0b64..e2b96e38ba3a 100644
--- a/misc/mc/distinfo
+++ b/misc/mc/distinfo
@@ -1,2 +1,4 @@
-SHA256 (mc-4.8.11.tar.xz) = 1877ea844f9d71e133b9e03ca3bebcd7b10b9ba5b419b8d268e255816fe1993a
-SIZE (mc-4.8.11.tar.xz) = 2211144
+SHA256 (mc-4.8.12.tar.xz) = 5f2fd570a798dc0cc06374adffef8ca403588c4e73dfdf908e9a4311718153fe
+SIZE (mc-4.8.12.tar.xz) = 2237892
+SHA256 (mc.png) = 6bd935ea11c45da5c11e60542e30b4a05396d75b81401f28b3a68a82cafbf8fe
+SIZE (mc.png) = 6466
diff --git a/misc/mc/files/mc.desktop b/misc/mc/files/mc.desktop
new file mode 100644
index 000000000000..dd31547a0b4d
--- /dev/null
+++ b/misc/mc/files/mc.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Midnight Commander
+GenericName=Midnight Commander
+Comment=Midnight Commander, a free Norton Commander Clone
+Icon=mc
+Exec=mc
+Categories=System;Utility;Core;FileTools;FileManager;
+Terminal=true
diff --git a/misc/mc/files/patch-lib__tty__key.c b/misc/mc/files/patch-lib__tty__key.c
deleted file mode 100644
index 6aac84cef778..000000000000
--- a/misc/mc/files/patch-lib__tty__key.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./lib/tty/key.c.orig 2013-11-29 19:27:07.000000000 +0100
-+++ ./lib/tty/key.c 2013-12-07 10:51:45.000000000 +0100
-@@ -1946,6 +1946,7 @@
- tty_get_event (struct Gpm_Event *event, gboolean redo_event, gboolean block)
- {
- int c;
-+ static int flag = 0; /* Return value from select */
- #ifdef HAVE_LIBGPM
- static struct Gpm_Event ev; /* Mouse event */
- #endif
-@@ -1978,7 +1979,6 @@
- while (pending_keys == NULL)
- {
- int nfd;
-- static int flag = 0; /* Return value from select */
- fd_set select_set;
-
- FD_ZERO (&select_set);
diff --git a/misc/mc/files/patch-lib__tty__tty-ncurses.c b/misc/mc/files/patch-lib__tty__tty-ncurses.c
deleted file mode 100644
index d3a4d579069f..000000000000
--- a/misc/mc/files/patch-lib__tty__tty-ncurses.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./lib/tty/tty-ncurses.c.orig 2013-11-29 19:27:07.000000000 +0100
-+++ ./lib/tty/tty-ncurses.c 2013-12-07 10:50:19.000000000 +0100
-@@ -49,6 +49,7 @@
- #include "tty-internal.h" /* mc_tty_normalize_from_utf8() */
- #include "tty.h"
- #include "color-internal.h"
-+#include "key.h"
- #include "mouse.h"
- #include "win.h"
-
-@@ -530,6 +531,7 @@
- if (mc_global.utf8_display || c > 255)
- {
- int res;
-+ unsigned char str[UTF8_CHAR_LEN + 1];
-
- res = g_unichar_to_utf8 (c, (char *) str);
- if (res == 0)
-@@ -540,7 +542,6 @@
- }
- else
- {
-- unsigned char str[UTF8_CHAR_LEN + 1];
- const char *s;
-
- str[res] = '\0';
diff --git a/misc/mc/files/pkg-message.in b/misc/mc/files/pkg-message.in
new file mode 100644
index 000000000000..7291b69c0237
--- /dev/null
+++ b/misc/mc/files/pkg-message.in
@@ -0,0 +1,14 @@
+===============================================================================
+
+Midnight Commander has been installed.
+
+If you have problems, please reinstall Midnight Commander
+
+cd /usr/ports/misc/mc && make deinstall clean reinstall
+
+For Screen it is best to use the default Option SLANG, with NCURSES
+you can have worse graphics.
+
+Have fun!
+
+===============================================================================
diff --git a/misc/mc/pkg-plist b/misc/mc/pkg-plist
index badb97cf422d..d025eb2dda98 100644
--- a/misc/mc/pkg-plist
+++ b/misc/mc/pkg-plist
@@ -86,6 +86,7 @@ man/man1/mcview.1.gz
%%NLS%%man/pl/man1/mc.1.gz
%%NLS%%man/ru/man1/mc.1.gz
%%NLS%%man/sr/man1/mc.1.gz
+share/applications/mc.desktop
%%NLS%%share/locale/az/LC_MESSAGES/mc.mo
%%NLS%%share/locale/be/LC_MESSAGES/mc.mo
%%NLS%%share/locale/bg/LC_MESSAGES/mc.mo
@@ -95,12 +96,14 @@ man/man1/mcview.1.gz
%%NLS%%share/locale/de/LC_MESSAGES/mc.mo
%%NLS%%share/locale/de_CH/LC_MESSAGES/mc.mo
%%NLS%%share/locale/el/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/mc.mo
%%NLS%%share/locale/eo/LC_MESSAGES/mc.mo
%%NLS%%share/locale/es/LC_MESSAGES/mc.mo
%%NLS%%share/locale/et/LC_MESSAGES/mc.mo
%%NLS%%share/locale/eu/LC_MESSAGES/mc.mo
%%NLS%%share/locale/fa/LC_MESSAGES/mc.mo
%%NLS%%share/locale/fi/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/mc.mo
%%NLS%%share/locale/fr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/gl/LC_MESSAGES/mc.mo
%%NLS%%share/locale/hr/LC_MESSAGES/mc.mo
@@ -159,6 +162,7 @@ man/man1/mcview.1.gz
%%NLS%%%%DATADIR%%/hints/mc.hint.de
%%NLS%%%%DATADIR%%/hints/mc.hint.de_CH
%%NLS%%%%DATADIR%%/hints/mc.hint.el
+%%NLS%%%%DATADIR%%/hints/mc.hint.en_GB
%%NLS%%%%DATADIR%%/hints/mc.hint.eo
%%NLS%%%%DATADIR%%/hints/mc.hint.es
%%NLS%%%%DATADIR%%/hints/mc.hint.et
@@ -172,6 +176,7 @@ man/man1/mcview.1.gz
%%NLS%%%%DATADIR%%/hints/mc.hint.ia
%%NLS%%%%DATADIR%%/hints/mc.hint.id
%%NLS%%%%DATADIR%%/hints/mc.hint.it
+%%NLS%%%%DATADIR%%/hints/mc.hint.it_IT
%%NLS%%%%DATADIR%%/hints/mc.hint.ja
%%NLS%%%%DATADIR%%/hints/mc.hint.ka
%%NLS%%%%DATADIR%%/hints/mc.hint.kk
@@ -289,6 +294,7 @@ man/man1/mcview.1.gz
%%EDITOR%%%%DATADIR%%/syntax/xml.syntax
%%EDITOR%%%%DATADIR%%/syntax/yum-repo.syntax
%%EDITOR%%%%DATADIR%%/syntax/yxx.syntax
+share/pixmaps/mc.png
%%EDITOR%%@dirrm %%DATADIR%%/syntax
@dirrm %%DATADIR%%/skins
@dirrm %%DATADIR%%/hints
@@ -304,8 +310,22 @@ man/man1/mcview.1.gz
%%NLS%%@dirrmtry share/locale/kk
%%NLS%%@dirrmtry share/locale/ia/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ia
+%%NLS%%@dirrmtry share/locale/fi_FI/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fi_FI
%%NLS%%@dirrmtry share/locale/de_CH/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/de_CH
+%%NLS%%@dirrmtry man/sr/man1
+%%NLS%%@dirrmtry man/sr
+%%NLS%%@dirrmtry man/ru/man1
+%%NLS%%@dirrmtry man/ru
+%%NLS%%@dirrmtry man/pl/man1
+%%NLS%%@dirrmtry man/pl
+%%NLS%%@dirrmtry man/it/man1
+%%NLS%%@dirrmtry man/it
+%%NLS%%@dirrmtry man/hu/man1
+%%NLS%%@dirrmtry man/hu
+%%NLS%%@dirrmtry man/es/man1
+%%NLS%%@dirrmtry man/es
@dirrm libexec/mc/fish
@dirrm libexec/mc/extfs.d
@dirrm libexec/mc/ext.d