aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-10-13 23:15:50 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-10-13 23:15:50 +0000
commitecda38b0a51979110b18b1bcd5f03f5b6a55e13a (patch)
tree6e4bc973485641dceb988b7456b64a08077dafe0 /misc
parent28bc26a55d939847edf4effb4c33cf5f20d879f0 (diff)
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/qt4-doc/Makefile8
-rw-r--r--misc/qt4-doc/pkg-plist3
-rw-r--r--misc/qt4-l10n/Makefile5
-rw-r--r--misc/qt4-qtconfig/Makefile6
-rw-r--r--misc/qt4-qtdemo/Makefile10
5 files changed, 14 insertions, 18 deletions
diff --git a/misc/qt4-doc/Makefile b/misc/qt4-doc/Makefile
index 6c1898724114..fddae4486db0 100644
--- a/misc/qt4-doc/Makefile
+++ b/misc/qt4-doc/Makefile
@@ -17,10 +17,10 @@ EXTRACT_AFTER_ARGS= '${DISTNAME}/doc'
DOCSDIR= ${PREFIX}/share/doc/qt4
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DOCSDIR} && \
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${DOCSDIR} && \
- ${COPYTREE_SHARE} qch ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR} && \
+ cd ${WRKSRC}/doc && \
+ ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR} && \
+ ${COPYTREE_SHARE} qch ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/misc/qt4-doc/pkg-plist b/misc/qt4-doc/pkg-plist
index 019444ff3693..c1be84253418 100644
--- a/misc/qt4-doc/pkg-plist
+++ b/misc/qt4-doc/pkg-plist
@@ -3078,7 +3078,6 @@
%%DOCSDIR%%/html/images/qvbox-m.png
%%DOCSDIR%%/html/images/qvboxlayout-with-5-children.png
%%DOCSDIR%%/html/images/qwebview-diagram.png
-%%DOCSDIR%%/html/images/qwebview-url.png
%%DOCSDIR%%/html/images/qwindowsstyle.png
%%DOCSDIR%%/html/images/qwindowsxpstyle.png
%%DOCSDIR%%/html/images/qwsserver_keyboardfilter.png
@@ -7364,7 +7363,6 @@
%%DOCSDIR%%/html/stylesheet.html
%%DOCSDIR%%/html/supported-platforms.html
%%DOCSDIR%%/html/symbian-platform-security-requirements.html
-%%DOCSDIR%%/html/symbian-support.html
%%DOCSDIR%%/html/symbian-with-qt-introduction.html
%%DOCSDIR%%/html/symbianexceptionsafety.html
%%DOCSDIR%%/html/technology-apis.html
@@ -8148,7 +8146,6 @@
%%DOCSDIR%%/qch/qt.qch
@dirrm %%DOCSDIR%%/qch
@dirrm %%DOCSDIR%%/html/style
-@exec mkdir -p %D/%%DOCSDIR%%/html/scripts
@dirrm %%DOCSDIR%%/html/scripts
@dirrm %%DOCSDIR%%/html/images/used-in-examples/widgets/tooltips/images
@dirrm %%DOCSDIR%%/html/images/used-in-examples/widgets/tooltips
diff --git a/misc/qt4-l10n/Makefile b/misc/qt4-l10n/Makefile
index 09caefbbfd19..a82904352075 100644
--- a/misc/qt4-l10n/Makefile
+++ b/misc/qt4-l10n/Makefile
@@ -14,12 +14,11 @@ QT_NONSTANDARD= yes
EXTRACT_AFTER_ARGS+= --include '${DISTNAME}/translations'
-NO_STAGE= yes
do-build:
${LOCALBASE}/bin/lrelease-qt4 ${WRKSRC}/translations/*.ts
do-install:
- ${MKDIR} ${PREFIX}/share/qt4/translations
- ${INSTALL_DATA} ${WRKSRC}/translations/*.qm ${PREFIX}/share/qt4/translations
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/qt4/translations
+ ${INSTALL_DATA} ${WRKSRC}/translations/*.qm ${STAGEDIR}${PREFIX}/share/qt4/translations
.include <bsd.port.mk>
diff --git a/misc/qt4-qtconfig/Makefile b/misc/qt4-qtconfig/Makefile
index 93cdea1532db..4ea5aaf38021 100644
--- a/misc/qt4-qtconfig/Makefile
+++ b/misc/qt4-qtconfig/Makefile
@@ -14,6 +14,7 @@ OPTIONS_DEFAULT=PHONON
PHONON_DESC= Multimedia via Phonon (implies GStreamer)
+USES= pkgconfig
USE_QT4= qmake_build moc_build rcc_build uic_build \
dbus gui xml
QT_NONSTANDARD= yes
@@ -41,7 +42,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHONON}
@@ -54,7 +54,7 @@ CONFIGURE_ARGS+=-no-phonon -no-gstreamer
BUILD_WRKSRC= ${WRKSRC}/tools/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
pre-configure:
${REINPLACE_CMD} -e 's|^TARGET.*|TARGET=qtconfig-qt4|g' \
@@ -68,6 +68,6 @@ pre-configure:
post-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/images/appicon.png \
- ${PREFIX}/share/pixmaps/qtconfig-qt4.png
+ ${STAGEDIR}${PREFIX}/share/pixmaps/qtconfig-qt4.png
.include <bsd.port.mk>
diff --git a/misc/qt4-qtdemo/Makefile b/misc/qt4-qtdemo/Makefile
index 4b1776a43d28..d01306741f05 100644
--- a/misc/qt4-qtdemo/Makefile
+++ b/misc/qt4-qtdemo/Makefile
@@ -9,6 +9,7 @@ PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt demonstration and example programs
+USES= pkgconfig
USE_QT4= qmake_build moc_build rcc_build uic_build corelib designer \
gui network opengl sql svg qtestlib xml imageformats_run dbus \
script webkit phonon help assistant_run phonon-gst scripttools \
@@ -40,9 +41,8 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/demos
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e '/app +=/s|"assistant"|"assistant-qt4"|' \
${BUILD_WRKSRC}/${PORTNAME}/menumanager.cpp \
@@ -57,10 +57,10 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
post-build:
- cd ${WRKSRC}/examples && ${SETENV} MAKEOBJDIR=. ${MAKE}
+ cd ${WRKSRC}/examples && ${SETENV} MAKEOBJDIR=. ${MAKE} ${_MAKE_JOBS}
post-install:
- cd ${WRKSRC}/examples && ${SETENV} MAKEOBJDIR=. ${MAKE} install
- ${FIND} -E ${PREFIX}/share/examples/qt4/examples/declarative/cppextensions -regex ".*\.(moc|obj|pch|rcc)" -type d | ${XARGS} ${RM} -r
+ cd ${WRKSRC}/examples && ${SETENV} MAKEOBJDIR=. ${MAKE} ${MAKE_ARGS} install
+ ${FIND} -E ${STAGEDIR}${PREFIX}/share/examples/qt4/examples/declarative/cppextensions -regex ".*\.(moc|obj|pch|rcc)" -type d | ${XARGS} ${RM} -r
.include <bsd.port.mk>