aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-06-17 04:51:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-06-17 04:51:49 +0000
commit82c67b1071bebecf46ddf03e406c5715414d4317 (patch)
tree876b27313fff2290318913786cb357ddd1ee7bef /misc
parent8e695f380e80203eb7cff574adb3a4061c0fdd13 (diff)
downloadports-82c67b1071bebecf46ddf03e406c5715414d4317.tar.gz
ports-82c67b1071bebecf46ddf03e406c5715414d4317.zip
New port: misc/ezc3d: C3D (biomechanics data format) reader/writer for C++
Notes
Notes: svn path=/head/; revision=539403
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ezc3d/Makefile19
-rw-r--r--misc/ezc3d/distinfo3
-rw-r--r--misc/ezc3d/pkg-descr10
-rw-r--r--misc/ezc3d/pkg-plist25
5 files changed, 58 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index bc209668cd1a..8f6ea5fe078d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -92,6 +92,7 @@
SUBDIR += excel-writer
SUBDIR += exercism
SUBDIR += explosions
+ SUBDIR += ezc3d
SUBDIR += felis
SUBDIR += figlet
SUBDIR += figlet-fonts
diff --git a/misc/ezc3d/Makefile b/misc/ezc3d/Makefile
new file mode 100644
index 000000000000..711f1e17d49f
--- /dev/null
+++ b/misc/ezc3d/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= ezc3d
+DISTVERSIONPREFIX= Release_
+DISTVERSION= 1.3.3
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C3D (biomechanics data format) reader/writer for C++
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake compiler:c++11-lang
+USE_GITHUB= yes
+GH_ACCOUNT= pyomeca
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/misc/ezc3d/distinfo b/misc/ezc3d/distinfo
new file mode 100644
index 000000000000..150727107f98
--- /dev/null
+++ b/misc/ezc3d/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1592369224
+SHA256 (pyomeca-ezc3d-Release_1.3.3_GH0.tar.gz) = 15e3381a8622811da9ac7ae44207a8cbf45261c588ba09d9fdabbdb6e4e9032c
+SIZE (pyomeca-ezc3d-Release_1.3.3_GH0.tar.gz) = 602957
diff --git a/misc/ezc3d/pkg-descr b/misc/ezc3d/pkg-descr
new file mode 100644
index 000000000000..5f49399f4156
--- /dev/null
+++ b/misc/ezc3d/pkg-descr
@@ -0,0 +1,10 @@
+EZC3D is an easy to use reader, modifier and writer for C3D format files. It is
+written en C++ with proper binders for Python and MATLAB scripting langages.
+
+C3D (http://c3d.org) is a format specifically designed to store biomechanics
+data. Hence many biomechanics softwares can produce C3D files in order to share
+data. However, there is a lack in the biomechanics community of an easy to use,
+free and open source library to read, modify and write them as needed when it
+gets to the data analysis.
+
+WWW: https://github.com/pyomeca/ezc3d
diff --git a/misc/ezc3d/pkg-plist b/misc/ezc3d/pkg-plist
new file mode 100644
index 000000000000..4ac982100492
--- /dev/null
+++ b/misc/ezc3d/pkg-plist
@@ -0,0 +1,25 @@
+include/ezc3d/Analogs.h
+include/ezc3d/Channel.h
+include/ezc3d/Data.h
+include/ezc3d/Frame.h
+include/ezc3d/Group.h
+include/ezc3d/Header.h
+include/ezc3d/Parameter.h
+include/ezc3d/Parameters.h
+include/ezc3d/Point.h
+include/ezc3d/Points.h
+include/ezc3d/Subframe.h
+include/ezc3d/ezc3d.h
+include/ezc3d/ezc3dConfig.h
+include/ezc3d/ezc3d_all.h
+include/ezc3d/math/Matrix.h
+include/ezc3d/math/Matrix33.h
+include/ezc3d/math/Matrix66.h
+include/ezc3d/math/Vector3d.h
+include/ezc3d/math/Vector6d.h
+include/ezc3d/math/ezc3dMath.h
+include/ezc3d/modules/ForcePlatforms.h
+lib/ezc3d/cmake/ezc3dConfig.cmake
+lib/ezc3d/cmake/ezc3dTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/ezc3d/cmake/ezc3dTargets.cmake
+lib/ezc3d/libezc3d.so