aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-03-14 15:59:37 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-03-14 15:59:37 +0000
commitb6d190fad968b13ffa7fd070e1c1b9a4c9a69465 (patch)
tree1aab2d73d9ea7977bb7ae30529f614b25872357e /misc
parent33a39ca39c96bbc2c7fa9c06c81d26f64e43af11 (diff)
downloadports-b6d190fad968b13ffa7fd070e1c1b9a4c9a69465.tar.gz
ports-b6d190fad968b13ffa7fd070e1c1b9a4c9a69465.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/krecipes-kde4/Makefile48
-rw-r--r--misc/krecipes-kde4/distinfo5
-rw-r--r--misc/krecipes-kde4/files/patch-src__CMakeLists.txt12
-rw-r--r--misc/krecipes-kde4/files/patch-src__dialogs__similarcategoriesdialog.cpp10
-rw-r--r--misc/krecipes-kde4/pkg-descr3
-rw-r--r--misc/krecipes-kde4/pkg-plist266
6 files changed, 182 insertions, 162 deletions
diff --git a/misc/krecipes-kde4/Makefile b/misc/krecipes-kde4/Makefile
index b6d14adb487f..3af991f6032f 100644
--- a/misc/krecipes-kde4/Makefile
+++ b/misc/krecipes-kde4/Makefile
@@ -6,48 +6,54 @@
#
PORTNAME= krecipes
-PORTVERSION= 0.9.1
-PORTREVISION= 5
+DISTVERSION= 2.0-beta2
CATEGORIES= misc kde
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
-MAINTAINER= hank@millerfarm.com
-COMMENT= Recipe database for cooks
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= Recipe database for KDE4
-USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool
+LIB_DEPENDS= qimageblitz.4:${PORTSDIR}/x11/qimageblitz
+
+LATEST_LINK= ${PORTNAME}-kde4
+
+USE_CMAKE= yes
+USE_GETTEXT= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build uic_build
+USE_KDE4= automoc4 kdeprefix kdelibs sharedmime
+MAKE_JOBS_SAFE= yes
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS= SQLITE "Support for SQLite backend" on \
MYSQL "Support for MySQL backend" off \
POSTGRESQL "Support for PostgreSQL backend" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_SQLITE)
-CONFIGURE_ARGS+= --without-sqlite
+CMAKE_ARGS+= -DWITH_Sqlite:BOOL=OFF
.else
USE_SQLITE= yes
+QT_COMPONENTS+= sql-sqlite3_run
.endif
.if defined(WITH_MYSQL)
-RUN_DEPENDS+= ${LOCALBASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin
-.else
-CONFIGURE_ARGS+= --without-mysql
+USE_MYSQL= yes
+QT_COMPONENTS+= sql-mysql_run
.endif
.if defined(WITH_POSTGRESQL)
-RUN_DEPENDS+= ${LOCALBASE}/lib/plugins/sqldrivers/libqsqlpsql.so:${PORTSDIR}/databases/qt-pgsql-plugin
-.else
-CONFIGURE_ARGS+= --without-postgresql
+USE_PGSQL= yes
+QT_COMPONENTS+= sql-pgsql_run
.endif
-post-extract:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-
pre-configure:
+
.if defined(WITHOUT_SQLITE) && !defined(WITH_MYSQL) && !defined(WITH_POSTGRESQL)
- @${ECHO} "You must have at least one database backend"
- @exit 1
+IGNORE= at least one database backend must be selected, run 'make config' and select a database
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/krecipes-kde4/distinfo b/misc/krecipes-kde4/distinfo
index b294e7046c8a..91e6e3aa7110 100644
--- a/misc/krecipes-kde4/distinfo
+++ b/misc/krecipes-kde4/distinfo
@@ -1,3 +1,2 @@
-MD5 (krecipes-0.9.1.tar.gz) = 7414fd5210561801ba04ee3dad6561d9
-SHA256 (krecipes-0.9.1.tar.gz) = 6efdb751f26ab2460d84c39be25042d0bea013becf8c6b1a5ae2a5c46998a0f3
-SIZE (krecipes-0.9.1.tar.gz) = 7791658
+SHA256 (krecipes-2.0-beta2.tar.gz) = 11800d57c5b6151b0bc1a9a48e750ec4be546342b7cebdd099f912604d85c596
+SIZE (krecipes-2.0-beta2.tar.gz) = 6939714
diff --git a/misc/krecipes-kde4/files/patch-src__CMakeLists.txt b/misc/krecipes-kde4/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..e1a69899593d
--- /dev/null
+++ b/misc/krecipes-kde4/files/patch-src__CMakeLists.txt
@@ -0,0 +1,12 @@
+--- ./src/CMakeLists.txt.orig 2010-11-01 15:45:20.000000000 -0400
++++ ./src/CMakeLists.txt 2011-02-15 21:12:42.000000000 -0500
+@@ -2,8 +2,7 @@
+ include(FindLibXslt)
+ include(FindQImageBlitz)
+
+-find_package(Sqlite2)
+-find_package(Sqlite)
++macro_optional_find_package(Sqlite)
+ find_package(QImageBlitz)
+ include_directories( ${KDE4_INCLUDES} ${KDE4_INCLUDE_DIR} ${QT_INCLUDES}
+ ${LIBXML2_INCLUDE_DIR} ${LIBXSLT_INCLUDE_DIR} ${QIMAGEBLITZ_INCLUDES}
diff --git a/misc/krecipes-kde4/files/patch-src__dialogs__similarcategoriesdialog.cpp b/misc/krecipes-kde4/files/patch-src__dialogs__similarcategoriesdialog.cpp
new file mode 100644
index 000000000000..81a62321c30c
--- /dev/null
+++ b/misc/krecipes-kde4/files/patch-src__dialogs__similarcategoriesdialog.cpp
@@ -0,0 +1,10 @@
+--- ./src/dialogs/similarcategoriesdialog.cpp.orig 2011-02-15 21:13:12.000000000 -0500
++++ ./src/dialogs/similarcategoriesdialog.cpp 2011-02-15 21:13:27.000000000 -0500
+@@ -202,7 +202,6 @@
+ /*****************************************************/
+
+ #include <stdlib.h>
+-#include <malloc.h>
+ #include <string.h>
+ int levenshtein_distance(const char *s,const char*t);
+ int minimum(int a,int b,int c);
diff --git a/misc/krecipes-kde4/pkg-descr b/misc/krecipes-kde4/pkg-descr
index a511adb347a0..8547de056919 100644
--- a/misc/krecipes-kde4/pkg-descr
+++ b/misc/krecipes-kde4/pkg-descr
@@ -3,6 +3,3 @@ recipe based on available ingredients, and plan your menu/diet in advance.
Uses your choice of SQLite, MySQL, or PostgreSQL as a database backend.
WWW: http://krecipes.sourceforge.net/
-
-- Hank
-hank@millerfarm.com
diff --git a/misc/krecipes-kde4/pkg-plist b/misc/krecipes-kde4/pkg-plist
index c7743eab6f70..9d9f31a13927 100644
--- a/misc/krecipes-kde4/pkg-plist
+++ b/misc/krecipes-kde4/pkg-plist
@@ -1,42 +1,34 @@
bin/krecipes
-share/applnk/Utilities/krecipes.desktop
+share/applications/kde4/krecipes.desktop
share/apps/krecipes/data/abbrev.txt
-share/apps/krecipes/data/data.sql
+share/apps/krecipes/data/data-en_US.sql
+share/apps/krecipes/data/ingredient-data-en_US.txt
+share/apps/krecipes/data/prep-data-en_US.txt
+share/apps/krecipes/data/property-data-en_US.txt
share/apps/krecipes/data/samples-cs_CZ.kreml
share/apps/krecipes/data/samples-en_US.kreml
-share/apps/krecipes/icons/crystalsvg/128x128/mimetypes/krecipes_file.png
-share/apps/krecipes/icons/crystalsvg/16x16/actions/categories.png
-share/apps/krecipes/icons/crystalsvg/16x16/actions/diet.png
-share/apps/krecipes/icons/crystalsvg/16x16/actions/ingredients.png
-share/apps/krecipes/icons/crystalsvg/16x16/actions/properties.png
-share/apps/krecipes/icons/crystalsvg/16x16/actions/trolley.png
-share/apps/krecipes/icons/crystalsvg/16x16/actions/units.png
-share/apps/krecipes/icons/crystalsvg/16x16/mimetypes/krecipes_file.png
-share/apps/krecipes/icons/crystalsvg/22x22/actions/categories.png
-share/apps/krecipes/icons/crystalsvg/22x22/actions/diet.png
-share/apps/krecipes/icons/crystalsvg/22x22/actions/ingredients.png
-share/apps/krecipes/icons/crystalsvg/22x22/actions/properties.png
-share/apps/krecipes/icons/crystalsvg/22x22/actions/trolley.png
-share/apps/krecipes/icons/crystalsvg/22x22/actions/units.png
-share/apps/krecipes/icons/crystalsvg/32x32/actions/categories.png
-share/apps/krecipes/icons/crystalsvg/32x32/actions/diet.png
-share/apps/krecipes/icons/crystalsvg/32x32/actions/ingredients.png
-share/apps/krecipes/icons/crystalsvg/32x32/actions/krectip.png
-share/apps/krecipes/icons/crystalsvg/32x32/actions/properties.png
-share/apps/krecipes/icons/crystalsvg/32x32/actions/trolley.png
-share/apps/krecipes/icons/crystalsvg/32x32/actions/units.png
-share/apps/krecipes/icons/crystalsvg/32x32/mimetypes/krecipes_file.png
-share/apps/krecipes/icons/crystalsvg/48x48/actions/categories.png
-share/apps/krecipes/icons/crystalsvg/48x48/actions/diet.png
-share/apps/krecipes/icons/crystalsvg/48x48/actions/ingredients.png
-share/apps/krecipes/icons/crystalsvg/48x48/actions/properties.png
-share/apps/krecipes/icons/crystalsvg/48x48/actions/trolley.png
-share/apps/krecipes/icons/crystalsvg/48x48/actions/units.png
-share/apps/krecipes/icons/crystalsvg/64x64/mimetypes/krecipes_file.png
+share/apps/krecipes/data/unit-data-en_US.txt
+share/apps/krecipes/data/weight.txt
share/apps/krecipes/krecipesui.rc
-share/apps/krecipes/layouts/default.klo
-share/apps/krecipes/layouts/default_print.klo
-share/apps/krecipes/layouts/one_column.klo
+share/apps/krecipes/layouts/Book.css
+share/apps/krecipes/layouts/Book.png
+share/apps/krecipes/layouts/Book.xsl
+share/apps/krecipes/layouts/Default.css
+share/apps/krecipes/layouts/Default.png
+share/apps/krecipes/layouts/Default.xsl
+share/apps/krecipes/layouts/None.klo
+share/apps/krecipes/layouts/Simple_Green.css
+share/apps/krecipes/layouts/Simple_Green.png
+share/apps/krecipes/layouts/Simple_Green.xsl
+share/apps/krecipes/layouts/Simple_Orange.css
+share/apps/krecipes/layouts/Simple_Orange.png
+share/apps/krecipes/layouts/Simple_Orange.xsl
+share/apps/krecipes/layouts/Two_Column.css
+share/apps/krecipes/layouts/Two_Column.png
+share/apps/krecipes/layouts/Two_Column.xsl
+share/apps/krecipes/layouts/box_bottom.gif
+share/apps/krecipes/layouts/box_top.gif
+share/apps/krecipes/layouts/paper.gif
share/apps/krecipes/pics/dbpermissions.png
share/apps/krecipes/pics/menubg.png
share/apps/krecipes/pics/network.png
@@ -48,40 +40,38 @@ share/apps/krecipes/pics/rating4.png
share/apps/krecipes/pics/rating5.png
share/apps/krecipes/pics/recipes.png
share/apps/krecipes/pics/save.png
-share/apps/krecipes/pics/star_half.png
-share/apps/krecipes/pics/star_off.png
-share/apps/krecipes/pics/star_on.png
share/apps/krecipes/pics/startlogo.png
share/apps/krecipes/pics/wizard.png
-share/doc/HTML/da/krecipes/common
-share/doc/HTML/da/krecipes/index.cache.bz2
-share/doc/HTML/da/krecipes/index.docbook
-share/doc/HTML/en/krecipes/1leftarrow.png
-share/doc/HTML/en/krecipes/1rightarrow.png
-share/doc/HTML/en/krecipes/2leftarrow.png
-share/doc/HTML/en/krecipes/2rightarrow.png
+share/doc/HTML/en/krecipes/addunit.png
share/doc/HTML/en/krecipes/adv-cat-search.png
share/doc/HTML/en/krecipes/adv-recipe-found.png
share/doc/HTML/en/krecipes/adv-search-parts.png
share/doc/HTML/en/krecipes/adv-srch-multi.png
+share/doc/HTML/en/krecipes/arrow-left-double.png
+share/doc/HTML/en/krecipes/arrow-left.png
+share/doc/HTML/en/krecipes/arrow-right-double.png
+share/doc/HTML/en/krecipes/arrow-right.png
share/doc/HTML/en/krecipes/authors-adding.png
-share/doc/HTML/en/krecipes/back.png
share/doc/HTML/en/krecipes/categories.png
-share/doc/HTML/en/krecipes/clear_left.png
+share/doc/HTML/en/krecipes/clear_right.png
share/doc/HTML/en/krecipes/common
-share/doc/HTML/en/krecipes/computer3.png
share/doc/HTML/en/krecipes/config-email.png
share/doc/HTML/en/krecipes/configure-shortcuts-adv.png
share/doc/HTML/en/krecipes/configure-shortcuts-basic.png
share/doc/HTML/en/krecipes/configure-shortcuts.png
share/doc/HTML/en/krecipes/configure-toolbars.png
share/doc/HTML/en/krecipes/diet-help.png
-share/doc/HTML/en/krecipes/down.png
-share/doc/HTML/en/krecipes/editpaste.png
+share/doc/HTML/en/krecipes/document-new.png
+share/doc/HTML/en/krecipes/document-print.png
+share/doc/HTML/en/krecipes/edit-clear.png
+share/doc/HTML/en/krecipes/edit-paste.png
+share/doc/HTML/en/krecipes/edit-property-information.png
share/doc/HTML/en/krecipes/enter-recipe-tabs.png
-share/doc/HTML/en/krecipes/filenew.png
+share/doc/HTML/en/krecipes/face-smile.png
share/doc/HTML/en/krecipes/formatting.png
-share/doc/HTML/en/krecipes/forward.png
+share/doc/HTML/en/krecipes/go-down.png
+share/doc/HTML/en/krecipes/go-next.png
+share/doc/HTML/en/krecipes/go-previous.png
share/doc/HTML/en/krecipes/import-other-sql.png
share/doc/HTML/en/krecipes/import-recipe-screen.png
share/doc/HTML/en/krecipes/import-settings.png
@@ -91,77 +81,47 @@ share/doc/HTML/en/krecipes/index.docbook
share/doc/HTML/en/krecipes/ingredient-match.png
share/doc/HTML/en/krecipes/ingredients.png
share/doc/HTML/en/krecipes/krecipes-main.png
-share/doc/HTML/en/krecipes/krectip.png
-share/doc/HTML/en/krecipes/locationbar_erase.png
+share/doc/HTML/en/krecipes/list-add.png
+share/doc/HTML/en/krecipes/list-remove.png
+share/doc/HTML/en/krecipes/mass-convert.png
+share/doc/HTML/en/krecipes/measure-convert.png
share/doc/HTML/en/krecipes/menu.png
-share/doc/HTML/en/krecipes/no.png
share/doc/HTML/en/krecipes/page-setup.png
share/doc/HTML/en/krecipes/parser.png
share/doc/HTML/en/krecipes/performance.png
share/doc/HTML/en/krecipes/prep-method.png
+share/doc/HTML/en/krecipes/print-preview.png
share/doc/HTML/en/krecipes/properties.png
+share/doc/HTML/en/krecipes/property_details.png
share/doc/HTML/en/krecipes/ratings.png
share/doc/HTML/en/krecipes/recipe-description-tab.png
share/doc/HTML/en/krecipes/recipe-ingredients-tab.png
share/doc/HTML/en/krecipes/recipe-instructions-tab.png
+share/doc/HTML/en/krecipes/recipe-ratings-tab.png
share/doc/HTML/en/krecipes/restore-msg.png
share/doc/HTML/en/krecipes/server-settings.png
share/doc/HTML/en/krecipes/shop-list.png
-share/doc/HTML/en/krecipes/smiley.png
share/doc/HTML/en/krecipes/submit-bug.png
-share/doc/HTML/en/krecipes/unit-conversions.png
+share/doc/HTML/en/krecipes/system-help.png
share/doc/HTML/en/krecipes/units.png
share/doc/HTML/en/krecipes/up.png
-share/doc/HTML/es/krecipes/adv-cat-search.png
-share/doc/HTML/es/krecipes/adv-search-parts.png
-share/doc/HTML/es/krecipes/adv-srch-multi.png
-share/doc/HTML/es/krecipes/authors-adding.png
-share/doc/HTML/es/krecipes/back.png
-share/doc/HTML/es/krecipes/categories.png
-share/doc/HTML/es/krecipes/clear_left.png
-share/doc/HTML/es/krecipes/configure-shortcuts-adv.png
-share/doc/HTML/es/krecipes/configure-shortcuts-basic.png
-share/doc/HTML/es/krecipes/configure-shortcuts.png
-share/doc/HTML/es/krecipes/configure-toolbars.png
-share/doc/HTML/es/krecipes/diet-help.png
-share/doc/HTML/es/krecipes/down.png
-share/doc/HTML/es/krecipes/enter-recipe-tabs.png
-share/doc/HTML/es/krecipes/filenew.png
-share/doc/HTML/es/krecipes/formatting.png
-share/doc/HTML/es/krecipes/forward.png
-share/doc/HTML/es/krecipes/import-other-sql.png
-share/doc/HTML/es/krecipes/import-recipe-screen.png
-share/doc/HTML/es/krecipes/import-settings.png
-share/doc/HTML/es/krecipes/import-sqlite.png
-share/doc/HTML/es/krecipes/ingredient-match.png
-share/doc/HTML/es/krecipes/ingredients.png
-share/doc/HTML/es/krecipes/krecipes-main.png
-share/doc/HTML/es/krecipes/krectip.png
-share/doc/HTML/es/krecipes/locationbar_erase.png
-share/doc/HTML/es/krecipes/menu.png
-share/doc/HTML/es/krecipes/no.png
-share/doc/HTML/es/krecipes/page-setup.png
-share/doc/HTML/es/krecipes/performance.png
-share/doc/HTML/es/krecipes/prep-method.png
-share/doc/HTML/es/krecipes/properties.png
-share/doc/HTML/es/krecipes/recipe-description-tab.png
-share/doc/HTML/es/krecipes/recipe-ingredients-tab.png
-share/doc/HTML/es/krecipes/recipe-instructions-tab.png
-share/doc/HTML/es/krecipes/server-settings.png
-share/doc/HTML/es/krecipes/shop-list.png
-share/doc/HTML/es/krecipes/unit-conversions.png
-share/doc/HTML/es/krecipes/units.png
-share/doc/HTML/es/krecipes/up.png
-share/doc/HTML/et/krecipes/common
-share/doc/HTML/et/krecipes/index.cache.bz2
-share/doc/HTML/et/krecipes/index.docbook
+share/doc/HTML/en/krecipes/volume-convert.png
+share/doc/HTML/en/krecipes/wildcard-table.png
share/doc/HTML/pt/krecipes/common
share/doc/HTML/pt/krecipes/index.cache.bz2
share/doc/HTML/pt/krecipes/index.docbook
+share/doc/HTML/pt_BR/krecipes/common
+share/doc/HTML/pt_BR/krecipes/index.cache.bz2
+share/doc/HTML/pt_BR/krecipes/index.docbook
+share/doc/HTML/sv/krecipes/addunit.png
+share/doc/HTML/sv/krecipes/adv-cat-search.png
share/doc/HTML/sv/krecipes/adv-recipe-found.png
+share/doc/HTML/sv/krecipes/adv-search-parts.png
+share/doc/HTML/sv/krecipes/adv-srch-multi.png
share/doc/HTML/sv/krecipes/authors-adding.png
share/doc/HTML/sv/krecipes/categories.png
share/doc/HTML/sv/krecipes/common
+share/doc/HTML/sv/krecipes/config-email.png
share/doc/HTML/sv/krecipes/configure-shortcuts-adv.png
share/doc/HTML/sv/krecipes/configure-shortcuts-basic.png
share/doc/HTML/sv/krecipes/configure-shortcuts.png
@@ -178,85 +138,121 @@ share/doc/HTML/sv/krecipes/index.docbook
share/doc/HTML/sv/krecipes/ingredient-match.png
share/doc/HTML/sv/krecipes/ingredients.png
share/doc/HTML/sv/krecipes/krecipes-main.png
+share/doc/HTML/sv/krecipes/mass-convert.png
+share/doc/HTML/sv/krecipes/measure-convert.png
share/doc/HTML/sv/krecipes/menu.png
share/doc/HTML/sv/krecipes/page-setup.png
+share/doc/HTML/sv/krecipes/parser.png
+share/doc/HTML/sv/krecipes/performance.png
share/doc/HTML/sv/krecipes/prep-method.png
+share/doc/HTML/sv/krecipes/print-preview.png
share/doc/HTML/sv/krecipes/properties.png
+share/doc/HTML/sv/krecipes/property_details.png
+share/doc/HTML/sv/krecipes/ratings.png
share/doc/HTML/sv/krecipes/recipe-description-tab.png
share/doc/HTML/sv/krecipes/recipe-ingredients-tab.png
share/doc/HTML/sv/krecipes/recipe-instructions-tab.png
+share/doc/HTML/sv/krecipes/restore-msg.png
share/doc/HTML/sv/krecipes/server-settings.png
share/doc/HTML/sv/krecipes/shop-list.png
+share/doc/HTML/sv/krecipes/submit-bug.png
share/doc/HTML/sv/krecipes/unit-conversions.png
share/doc/HTML/sv/krecipes/units.png
-share/icons/crystalsvg/128x128/mimetypes/krecipes_file.png
-share/icons/crystalsvg/16x16/mimetypes/krecipes_file.png
-share/icons/crystalsvg/32x32/mimetypes/krecipes_file.png
-share/icons/crystalsvg/64x64/mimetypes/krecipes_file.png
+share/doc/HTML/sv/krecipes/volume-convert.png
+share/doc/HTML/uk/krecipes/common
+share/doc/HTML/uk/krecipes/index.cache.bz2
+share/doc/HTML/uk/krecipes/index.docbook
share/icons/hicolor/128x128/apps/krecipes.png
share/icons/hicolor/16x16/apps/krecipes.png
share/icons/hicolor/22x22/apps/krecipes.png
share/icons/hicolor/32x32/apps/krecipes.png
share/icons/hicolor/48x48/apps/krecipes.png
share/icons/hicolor/64x64/apps/krecipes.png
-share/locale/az/LC_MESSAGES/krecipes.mo
+share/icons/oxygen/128x128/mimetypes/application-x-krecipes-backup.png
+share/icons/oxygen/128x128/mimetypes/application-x-krecipes-recipes.png
+share/icons/oxygen/16x16/actions/add_ingredient.png
+share/icons/oxygen/16x16/actions/authors.png
+share/icons/oxygen/16x16/actions/categories.png
+share/icons/oxygen/16x16/actions/diet.png
+share/icons/oxygen/16x16/actions/ingredients.png
+share/icons/oxygen/16x16/actions/methods.png
+share/icons/oxygen/16x16/actions/properties.png
+share/icons/oxygen/16x16/actions/units.png
+share/icons/oxygen/16x16/mimetypes/application-x-krecipes-backup.png
+share/icons/oxygen/16x16/mimetypes/application-x-krecipes-recipes.png
+share/icons/oxygen/22x22/actions/add_ingredient.png
+share/icons/oxygen/22x22/actions/authors.png
+share/icons/oxygen/22x22/actions/diet.png
+share/icons/oxygen/22x22/actions/ingredients.png
+share/icons/oxygen/22x22/actions/methods.png
+share/icons/oxygen/22x22/actions/properties.png
+share/icons/oxygen/22x22/actions/units.png
+share/icons/oxygen/32x32/actions/add_ingredient.png
+share/icons/oxygen/32x32/actions/authors.png
+share/icons/oxygen/32x32/actions/diet.png
+share/icons/oxygen/32x32/actions/ingredients.png
+share/icons/oxygen/32x32/actions/methods.png
+share/icons/oxygen/32x32/actions/properties.png
+share/icons/oxygen/32x32/actions/units.png
+share/icons/oxygen/32x32/mimetypes/application-x-krecipes-backup.png
+share/icons/oxygen/32x32/mimetypes/application-x-krecipes-recipes.png
+share/icons/oxygen/48x48/actions/add_ingredient.png
+share/icons/oxygen/48x48/actions/authors.png
+share/icons/oxygen/48x48/actions/diet.png
+share/icons/oxygen/48x48/actions/ingredients.png
+share/icons/oxygen/48x48/actions/methods.png
+share/icons/oxygen/48x48/actions/properties.png
+share/icons/oxygen/48x48/actions/units.png
+share/icons/oxygen/64x64/mimetypes/application-x-krecipes-backup.png
+share/icons/oxygen/64x64/mimetypes/application-x-krecipes-recipes.png
share/locale/bg/LC_MESSAGES/krecipes.mo
-share/locale/br/LC_MESSAGES/krecipes.mo
share/locale/ca/LC_MESSAGES/krecipes.mo
+share/locale/ca@valencia/LC_MESSAGES/krecipes.mo
share/locale/cs/LC_MESSAGES/krecipes.mo
-share/locale/cy/LC_MESSAGES/krecipes.mo
share/locale/da/LC_MESSAGES/krecipes.mo
share/locale/de/LC_MESSAGES/krecipes.mo
share/locale/el/LC_MESSAGES/krecipes.mo
share/locale/en_GB/LC_MESSAGES/krecipes.mo
+share/locale/eo/LC_MESSAGES/krecipes.mo
share/locale/es/LC_MESSAGES/krecipes.mo
share/locale/et/LC_MESSAGES/krecipes.mo
-share/locale/fi/LC_MESSAGES/krecipes.mo
share/locale/fr/LC_MESSAGES/krecipes.mo
share/locale/ga/LC_MESSAGES/krecipes.mo
+share/locale/gl/LC_MESSAGES/krecipes.mo
+share/locale/hi/LC_MESSAGES/krecipes.mo
+share/locale/hne/LC_MESSAGES/krecipes.mo
+share/locale/hr/LC_MESSAGES/krecipes.mo
+share/locale/hu/LC_MESSAGES/krecipes.mo
share/locale/is/LC_MESSAGES/krecipes.mo
share/locale/it/LC_MESSAGES/krecipes.mo
+share/locale/ja/LC_MESSAGES/krecipes.mo
share/locale/lt/LC_MESSAGES/krecipes.mo
-share/locale/mt/LC_MESSAGES/krecipes.mo
+share/locale/mai/LC_MESSAGES/krecipes.mo
share/locale/nb/LC_MESSAGES/krecipes.mo
+share/locale/nds/LC_MESSAGES/krecipes.mo
share/locale/nl/LC_MESSAGES/krecipes.mo
+share/locale/nn/LC_MESSAGES/krecipes.mo
share/locale/pl/LC_MESSAGES/krecipes.mo
share/locale/pt/LC_MESSAGES/krecipes.mo
share/locale/pt_BR/LC_MESSAGES/krecipes.mo
share/locale/ro/LC_MESSAGES/krecipes.mo
-share/locale/ru/LC_MESSAGES/krecipes.mo
-share/locale/rw/LC_MESSAGES/krecipes.mo
-share/locale/sl/LC_MESSAGES/krecipes.mo
-share/locale/sr/LC_MESSAGES/krecipes.mo
-share/locale/sr@Latn/LC_MESSAGES/krecipes.mo
+share/locale/sk/LC_MESSAGES/krecipes.mo
share/locale/sv/LC_MESSAGES/krecipes.mo
-share/locale/ta/LC_MESSAGES/krecipes.mo
share/locale/tr/LC_MESSAGES/krecipes.mo
-share/mimelnk/application/x-krecipes-backup.desktop
-share/mimelnk/application/x-krecipes-recipes.desktop
+share/locale/uk/LC_MESSAGES/krecipes.mo
+share/locale/zh_TW/LC_MESSAGES/krecipes.mo
+share/mime/application/x-krecipes-backup.xml
+share/mime/application/x-krecipes-recipes-compressed.xml
+share/mime/application/x-krecipes-recipes.xml
+share/mime/packages/krecipes-mime.xml
+@dirrm share/doc/HTML/uk/krecipes
@dirrm share/doc/HTML/sv/krecipes
+@dirrm share/doc/HTML/pt_BR/krecipes
@dirrm share/doc/HTML/pt/krecipes
-@dirrm share/doc/HTML/et/krecipes
-@dirrm share/doc/HTML/es/krecipes
@dirrm share/doc/HTML/en/krecipes
-@dirrm share/doc/HTML/da/krecipes
@dirrm share/apps/krecipes/pics
@dirrm share/apps/krecipes/layouts
-@dirrm share/apps/krecipes/icons/crystalsvg/64x64/mimetypes
-@dirrm share/apps/krecipes/icons/crystalsvg/64x64
-@dirrm share/apps/krecipes/icons/crystalsvg/48x48/actions
-@dirrm share/apps/krecipes/icons/crystalsvg/48x48
-@dirrm share/apps/krecipes/icons/crystalsvg/32x32/mimetypes
-@dirrm share/apps/krecipes/icons/crystalsvg/32x32/actions
-@dirrm share/apps/krecipes/icons/crystalsvg/32x32
-@dirrm share/apps/krecipes/icons/crystalsvg/22x22/actions
-@dirrm share/apps/krecipes/icons/crystalsvg/22x22
-@dirrm share/apps/krecipes/icons/crystalsvg/16x16/mimetypes
-@dirrm share/apps/krecipes/icons/crystalsvg/16x16/actions
-@dirrm share/apps/krecipes/icons/crystalsvg/16x16
-@dirrm share/apps/krecipes/icons/crystalsvg/128x128/mimetypes
-@dirrm share/apps/krecipes/icons/crystalsvg/128x128
-@dirrm share/apps/krecipes/icons/crystalsvg
-@dirrm share/apps/krecipes/icons
@dirrm share/apps/krecipes/data
@dirrm share/apps/krecipes
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true