aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-12 10:44:23 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-12 10:44:23 +0000
commitc790284a9bf1e97b323c0b0914b01ff65b494428 (patch)
tree05ec82d24409354bff593f19fc65c16ba1f47cd4 /misc
parent53cd54af9fabe8edb22d50cab6864f40e41662f5 (diff)
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/rfc/Makefile40
-rw-r--r--misc/rfc/distinfo3
-rw-r--r--misc/rfc/pkg-descr6
4 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d72fb3cee82b..12996287e756 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -422,6 +422,7 @@
SUBDIR += raspberrypi-userland
SUBDIR += raspbsd-led
SUBDIR += ree
+ SUBDIR += rfc
SUBDIR += ringtonetools
SUBDIR += rname
SUBDIR += rpl
diff --git a/misc/rfc/Makefile b/misc/rfc/Makefile
new file mode 100644
index 000000000000..8d8e059d413a
--- /dev/null
+++ b/misc/rfc/Makefile
@@ -0,0 +1,40 @@
+# Created by: Chris D. Faulhaber <jedgar@fxp.org>
+# $FreeBSD$
+
+PORTNAME= rfc
+PORTVERSION= 3.2.3
+PORTREVISION= 4
+CATEGORIES= misc
+MASTER_SITES= https://BSDforge.com/projects/source/misc/rfc/
+
+MAINTAINER= portmaster@BSDforge.com
+COMMENT= Perl script to search for RFC's
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= w3m:www/w3m
+
+USES= perl5 shebangfix
+USE_PERL5= run
+
+SHEBANG_FILES= ${PORTNAME}-${PORTVERSION}
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/rfc man/man1/rfc.1.gz
+
+do-configure:
+ @${REINPLACE_CMD} -e 's|/usr/local/etc/rfc|${PREFIX}/etc/rfc| ; \
+ s|/usr/local/etc/nmap|${PREFIX}/share/misc/nmap| ; \
+ s|400k|1024k| ; \
+ s|http://ftp.isi.edu/in-notes|http://www.ietf.org/rfc| ; \
+ s|http://www.iana|ftp://ftp.iana|' \
+ ${WRKSRC}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}-${PORTVERSION} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/rfc/distinfo b/misc/rfc/distinfo
new file mode 100644
index 000000000000..bedb316255fb
--- /dev/null
+++ b/misc/rfc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588792454
+SHA256 (rfc-3.2.3.tar.gz) = 894ca3d84bbe354748a4808e60f3d35879637b0fb5a6f9e47a1ece3314231950
+SIZE (rfc-3.2.3.tar.gz) = 10469
diff --git a/misc/rfc/pkg-descr b/misc/rfc/pkg-descr
new file mode 100644
index 000000000000..d834af4ca072
--- /dev/null
+++ b/misc/rfc/pkg-descr
@@ -0,0 +1,6 @@
+Perl script to search for RFC's by an RFC number,
+keyword, or your own regexp. The results can be
+send to a browser to viewing, emailed, or just
+viewed.
+
+WWW: http://www.dewn.com/rfc/