aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-07-09 18:22:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-07-09 18:22:22 +0000
commite5bd2f9bab49a1a462a8b29b7b312ca02320a1ae (patch)
treeefe4cbaf36783c8ba87854b5183deaabb89ff1c2 /misc
parent1342f647150a4342a65a79ee02e04c1fe052459e (diff)
downloadports-e5bd2f9bab49a1a462a8b29b7b312ca02320a1ae.tar.gz
ports-e5bd2f9bab49a1a462a8b29b7b312ca02320a1ae.zip
MFH: r541755
misc/lf: Fix the keyboard problem Fix suggested by the GH user flw-cn in https://github.com/gokcehan/lf/issues/392 Reported in: https://forums.freebsd.org/threads/terminal-file-manager-misc-lf-not-operational.75804/ Approved by: ports-secteam (joenum)
Notes
Notes: svn path=/branches/2020Q3/; revision=541804
Diffstat (limited to 'misc')
-rw-r--r--misc/lf/Makefile1
-rw-r--r--misc/lf/files/patch-vendor_github.com_doronbehar_termbox-go_api.go14
2 files changed, 15 insertions, 0 deletions
diff --git a/misc/lf/Makefile b/misc/lf/Makefile
index 148bf5fd0f22..4a69fcf0ff52 100644
--- a/misc/lf/Makefile
+++ b/misc/lf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lf
DISTVERSIONPREFIX= r
DISTVERSION= 14
+PORTREVISION= 1
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
diff --git a/misc/lf/files/patch-vendor_github.com_doronbehar_termbox-go_api.go b/misc/lf/files/patch-vendor_github.com_doronbehar_termbox-go_api.go
new file mode 100644
index 000000000000..ce36cf221058
--- /dev/null
+++ b/misc/lf/files/patch-vendor_github.com_doronbehar_termbox-go_api.go
@@ -0,0 +1,14 @@
+Same as https://github.com/nsf/termbox-go/commit/58d4fcbc
+Suggested in https://github.com/gokcehan/lf/issues/392#issuecomment-656045163
+
+--- vendor/github.com/doronbehar/termbox-go/api.go.orig 2020-07-09 15:15:27 UTC
++++ vendor/github.com/doronbehar/termbox-go/api.go
+@@ -24,7 +24,7 @@ import "time"
+ func Init() error {
+ var err error
+
+- if runtime.GOOS == "openbsd" {
++ if runtime.GOOS == "openbsd" || runtime.GOOS == "freebsd" {
+ out, err = os.OpenFile("/dev/tty", os.O_RDWR, 0)
+ if err != nil {
+ return err