aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-29 20:41:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-29 20:41:50 +0000
commitf38ecd957060cf32a045644c8af72c174a8c1c58 (patch)
treeda7173f75a88da60b013990c33c78dca8e63d9f2 /misc
parent6176bc3b8ffcccade9732c171db8cd91b22c52b2 (diff)
downloadports-f38ecd957060cf32a045644c8af72c174a8c1c58.tar.gz
ports-f38ecd957060cf32a045644c8af72c174a8c1c58.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/pspresent/Makefile30
-rw-r--r--misc/pspresent/distinfo3
-rw-r--r--misc/pspresent/pkg-descr5
4 files changed, 39 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index e346fe8ae57c..cddab5c52dae 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -388,6 +388,7 @@
SUBDIR += proj4
SUBDIR += projectionlib
SUBDIR += proxyper
+ SUBDIR += pspresent
SUBDIR += py-distutils
SUBDIR += py-osd
SUBDIR += py-pexpect
diff --git a/misc/pspresent/Makefile b/misc/pspresent/Makefile
new file mode 100644
index 000000000000..09941cd67a93
--- /dev/null
+++ b/misc/pspresent/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pspresent
+# Date created: 25 Jul 2007
+# Whom: Timothy Bourke <timbob@bigpond.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pspresent
+PORTVERSION= 1.3
+CATEGORIES= misc
+MASTER_SITES= http://www.cse.unsw.edu.au/~matthewc/pspresent/
+
+MAINTAINER= timbob@bigpond.com
+COMMENT= Full-screen slide shows of postscript files
+
+USE_GHOSTSCRIPT_RUN= yes
+USE_XORG= x11 xext xinerama
+ALL_TARGET= pspresent
+PLIST_FILES= bin/pspresent
+
+MAN1= pspresent.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|$${X11BASE}|' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/pspresent ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/pspresent.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/pspresent/distinfo b/misc/pspresent/distinfo
new file mode 100644
index 000000000000..25b41b01a0fe
--- /dev/null
+++ b/misc/pspresent/distinfo
@@ -0,0 +1,3 @@
+MD5 (pspresent-1.3.tar.gz) = 775025aa81ac4b86cd7067f17e312589
+SHA256 (pspresent-1.3.tar.gz) = 94f2b6fa437929c9add2b8f4554a204d49132170c1d167c4389c7de26f5a6f80
+SIZE (pspresent-1.3.tar.gz) = 14357
diff --git a/misc/pspresent/pkg-descr b/misc/pspresent/pkg-descr
new file mode 100644
index 000000000000..a1623b7b4aa9
--- /dev/null
+++ b/misc/pspresent/pkg-descr
@@ -0,0 +1,5 @@
+pspresent is a presentation tool to display full-screen PostScript
+presentations. It provides simple navigation, and double-buffers for
+seamless transitions.
+
+WWW: http://www.cse.unsw.edu.au/~matthewc/pspresent