aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2007-10-13 11:47:41 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2007-10-13 11:47:41 +0000
commitd6e28ed1cad0aff4f43bb42bf284c0954489c521 (patch)
treeddc2daeeecc0d559b1f310a2a8d0680732acc7ee /misc
parentec0efcad9224b268e3864928fb26bb67cc419709 (diff)
downloadports-d6e28ed1cad0aff4f43bb42bf284c0954489c521.tar.gz
ports-d6e28ed1cad0aff4f43bb42bf284c0954489c521.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/amanda-server/Makefile7
-rw-r--r--misc/amanda25-server/Makefile7
-rw-r--r--misc/amanda26-server/Makefile7
-rw-r--r--misc/amanda32-server/Makefile7
4 files changed, 24 insertions, 4 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 38124cbc07e1..6b6de0f49912 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -115,7 +115,8 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
- MTX "enable the use of mtx changer scripts" off
+ MTX "enable the use of mtx changer scripts" off \
+ AESPIPE "enable encryption. Needed by amcrypt" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
@@ -137,6 +138,10 @@ BUILD_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
.endif
+.if defined (WITH_AESPIPE)
+RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
+.endif
+
.if defined (AMANDA_TAPE)
CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
.endif
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index 38124cbc07e1..6b6de0f49912 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -115,7 +115,8 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
- MTX "enable the use of mtx changer scripts" off
+ MTX "enable the use of mtx changer scripts" off \
+ AESPIPE "enable encryption. Needed by amcrypt" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
@@ -137,6 +138,10 @@ BUILD_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
.endif
+.if defined (WITH_AESPIPE)
+RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
+.endif
+
.if defined (AMANDA_TAPE)
CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
.endif
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index 38124cbc07e1..6b6de0f49912 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -115,7 +115,8 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
- MTX "enable the use of mtx changer scripts" off
+ MTX "enable the use of mtx changer scripts" off \
+ AESPIPE "enable encryption. Needed by amcrypt" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
@@ -137,6 +138,10 @@ BUILD_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
.endif
+.if defined (WITH_AESPIPE)
+RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
+.endif
+
.if defined (AMANDA_TAPE)
CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
.endif
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 38124cbc07e1..6b6de0f49912 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -115,7 +115,8 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
- MTX "enable the use of mtx changer scripts" off
+ MTX "enable the use of mtx changer scripts" off \
+ AESPIPE "enable encryption. Needed by amcrypt" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
@@ -137,6 +138,10 @@ BUILD_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
.endif
+.if defined (WITH_AESPIPE)
+RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
+.endif
+
.if defined (AMANDA_TAPE)
CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
.endif