aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-01 15:13:16 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-01 15:13:16 +0000
commitdce33b0828964d37245eb2893dd7d61979852875 (patch)
tree0c9f46b4407faf170f5ae019d614e17cdb73c7ee /misc
parent28d58c396d75dd473cc79aa10bc894667d4f9624 (diff)
downloadports-dce33b0828964d37245eb2893dd7d61979852875.tar.gz
ports-dce33b0828964d37245eb2893dd7d61979852875.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/biblereader/Makefile3
-rw-r--r--misc/bidwatcher/Makefile6
-rw-r--r--misc/cheatah/Makefile3
-rw-r--r--misc/demoniac/Makefile3
-rw-r--r--misc/gkrellm-reminder/Makefile4
-rw-r--r--misc/gkrellmaflag/Makefile4
-rw-r--r--misc/gkrellmbgchg/Makefile3
-rw-r--r--misc/gkrellmbgchg2/Makefile3
-rw-r--r--misc/gkrellmlaunch/Makefile4
-rw-r--r--misc/gkrellmlaunch2/Makefile4
-rw-r--r--misc/gkrellscore/Makefile4
-rw-r--r--misc/gkrellshoot/Makefile3
-rw-r--r--misc/gkrellweather/Makefile4
-rw-r--r--misc/gman/Makefile3
-rw-r--r--misc/gplbp/Makefile3
-rw-r--r--misc/grdb/Makefile7
-rw-r--r--misc/gretl/Makefile7
-rw-r--r--misc/grun/Makefile3
-rw-r--r--misc/gtkfind/Makefile3
-rw-r--r--misc/gtktalog/Makefile3
-rw-r--r--misc/snowflake/Makefile3
-rw-r--r--misc/wmpal/Makefile3
-rw-r--r--misc/xosd/Makefile3
23 files changed, 52 insertions, 34 deletions
diff --git a/misc/biblereader/Makefile b/misc/biblereader/Makefile
index 31eb621fbfca..d2afa0db7d7d 100644
--- a/misc/biblereader/Makefile
+++ b/misc/biblereader/Makefile
@@ -23,7 +23,8 @@ DISTFILES+= easton.tar.gz strongs.tar.gz torrey.tar.gz
MAINTAINER= patseal@hyperhost.net
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
PLIST= ${WRKDIR}/PLIST
DATAFILES= ${WRKDIR}/kjv/kjv
diff --git a/misc/bidwatcher/Makefile b/misc/bidwatcher/Makefile
index d782e83d3fc4..9b37aad9208e 100644
--- a/misc/bidwatcher/Makefile
+++ b/misc/bidwatcher/Makefile
@@ -12,11 +12,13 @@ CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= bidwatcher-1.3.4-fix
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAINTAINER= mph@FreeBSD.org
-USE_GTK= YES
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= YES
.include <bsd.port.mk>
diff --git a/misc/cheatah/Makefile b/misc/cheatah/Makefile
index c9c98de9d45d..f589e0fda137 100644
--- a/misc/cheatah/Makefile
+++ b/misc/cheatah/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/sword/mods.d:${PORTSDIR}/misc/sword-modules
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
MAINDIR= ${.CURDIR}/../sword
PORTVERSION!= ${PORTVERSION}
diff --git a/misc/demoniac/Makefile b/misc/demoniac/Makefile
index 099b42479737..6c6f362e9d6b 100644
--- a/misc/demoniac/Makefile
+++ b/misc/demoniac/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
USE_REINPLACE= yes
USE_MESA= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
diff --git a/misc/gkrellm-reminder/Makefile b/misc/gkrellm-reminder/Makefile
index af87294d99bb..30de94dd90de 100644
--- a/misc/gkrellm-reminder/Makefile
+++ b/misc/gkrellm-reminder/Makefile
@@ -17,8 +17,8 @@ BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
do-install:
@${INSTALL_DATA} ${WRKSRC}/reminder.so \
diff --git a/misc/gkrellmaflag/Makefile b/misc/gkrellmaflag/Makefile
index 70c373855949..4a78b58c0cdc 100644
--- a/misc/gkrellmaflag/Makefile
+++ b/misc/gkrellmaflag/Makefile
@@ -19,8 +19,8 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
ALL_TARGET= ${PORTNAME}_anim.so
diff --git a/misc/gkrellmbgchg/Makefile b/misc/gkrellmbgchg/Makefile
index 3a2a2f00ce8d..6ee4a45ff118 100644
--- a/misc/gkrellmbgchg/Makefile
+++ b/misc/gkrellmbgchg/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
WRKSRC= ${WRKDIR}/gkrellmbgchg-${PORTVERSION}
USE_X_PREFIX= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
.include <bsd.port.mk>
diff --git a/misc/gkrellmbgchg2/Makefile b/misc/gkrellmbgchg2/Makefile
index 3a2a2f00ce8d..6ee4a45ff118 100644
--- a/misc/gkrellmbgchg2/Makefile
+++ b/misc/gkrellmbgchg2/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
WRKSRC= ${WRKDIR}/gkrellmbgchg-${PORTVERSION}
USE_X_PREFIX= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
.include <bsd.port.mk>
diff --git a/misc/gkrellmlaunch/Makefile b/misc/gkrellmlaunch/Makefile
index 5f92611fe247..ab971526b407 100644
--- a/misc/gkrellmlaunch/Makefile
+++ b/misc/gkrellmlaunch/Makefile
@@ -17,8 +17,8 @@ BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
ALL_TARGET= ${PORTNAME}.so
do-install:
diff --git a/misc/gkrellmlaunch2/Makefile b/misc/gkrellmlaunch2/Makefile
index 5f92611fe247..ab971526b407 100644
--- a/misc/gkrellmlaunch2/Makefile
+++ b/misc/gkrellmlaunch2/Makefile
@@ -17,8 +17,8 @@ BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
ALL_TARGET= ${PORTNAME}.so
do-install:
diff --git a/misc/gkrellscore/Makefile b/misc/gkrellscore/Makefile
index 392b611c623d..16b5d6473e23 100644
--- a/misc/gkrellscore/Makefile
+++ b/misc/gkrellscore/Makefile
@@ -19,8 +19,8 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm \
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
USE_GMAKE= yes
pre-patch:
diff --git a/misc/gkrellshoot/Makefile b/misc/gkrellshoot/Makefile
index 3e6ecab3c5cd..993bfe659e09 100644
--- a/misc/gkrellshoot/Makefile
+++ b/misc/gkrellshoot/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm \
WRKSRC= ${WRKDIR}/gkrellShoot-${PORTVERSION}
USE_X_PREFIX= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
.include <bsd.port.mk>
diff --git a/misc/gkrellweather/Makefile b/misc/gkrellweather/Makefile
index ea409f08fec9..6f7118386a24 100644
--- a/misc/gkrellweather/Makefile
+++ b/misc/gkrellweather/Makefile
@@ -19,8 +19,8 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm \
${X11BASE}/bin/GrabWeather:${PORTSDIR}/misc/wmweather
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
ALL_TARGET= ${PORTNAME}.so
diff --git a/misc/gman/Makefile b/misc/gman/Makefile
index a43712413b29..e1245df30f9a 100644
--- a/misc/gman/Makefile
+++ b/misc/gman/Makefile
@@ -16,7 +16,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= ghostview:${PORTSDIR}/print/ghostview
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
MAN1= gman.1x
diff --git a/misc/gplbp/Makefile b/misc/gplbp/Makefile
index fb1b0c84fe19..8c3f0d8c8b56 100644
--- a/misc/gplbp/Makefile
+++ b/misc/gplbp/Makefile
@@ -14,7 +14,8 @@ MAINTAINER= jedgar@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/misc/grdb/Makefile b/misc/grdb/Makefile
index 4366ff436163..96b251f7949f 100644
--- a/misc/grdb/Makefile
+++ b/misc/grdb/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= stijn@win.tue.nl
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
WANT_GNOME= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -24,8 +24,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME+= gtk12
+PKGNAMESUFFIX= -gtk
.else
CONFIGURE_ARGS= --disable-gnome
.endif
diff --git a/misc/gretl/Makefile b/misc/gretl/Makefile
index f70d9a82954a..d808364c0468 100644
--- a/misc/gretl/Makefile
+++ b/misc/gretl/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
WANT_GNOME= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
@@ -37,8 +37,9 @@ MAN1= gretl.1 gretl-config.1
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME+= gtk12
+PKGNAMESUFFIX= gtk
.else
CONFIGURE_ARGS+= --without-gnome
.endif
diff --git a/misc/grun/Makefile b/misc/grun/Makefile
index a4ec7823fb66..16761a5fb83f 100644
--- a/misc/grun/Makefile
+++ b/misc/grun/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://www.brettnacher.org/users/dominik/FreeBSD/
MAINTAINER= domi@saargate.de
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
MAN1= grun.1x
diff --git a/misc/gtkfind/Makefile b/misc/gtkfind/Makefile
index e029ad68107d..ef6d80aa249b 100644
--- a/misc/gtkfind/Makefile
+++ b/misc/gtkfind/Makefile
@@ -19,7 +19,8 @@ BROKEN= "Missing dependency on xterm"
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
MAN1= gtkfind.1 mktmp.1
diff --git a/misc/gtktalog/Makefile b/misc/gtktalog/Makefile
index 9b7071939bdb..1abe91627024 100644
--- a/misc/gtktalog/Makefile
+++ b/misc/gtktalog/Makefile
@@ -12,7 +12,8 @@ MASTER_SITES= http://freesoftware.fsf.org/download/gtktalog/gtktalog/sources/
MAINTAINER= rael@vectorstar.net
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
GNU_CONFIGURE= yes
MAN1= gtktalog.1
diff --git a/misc/snowflake/Makefile b/misc/snowflake/Makefile
index e329d32c77d0..fd0ad73f26b4 100644
--- a/misc/snowflake/Makefile
+++ b/misc/snowflake/Makefile
@@ -14,7 +14,8 @@ DISTNAME= ${PORTNAME}
MAINTAINER= nakai@FreeBSD.org
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/snowflake ${PREFIX}/bin
diff --git a/misc/wmpal/Makefile b/misc/wmpal/Makefile
index 4b5893fe0db9..47f5e35fb31e 100644
--- a/misc/wmpal/Makefile
+++ b/misc/wmpal/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= dockapp.1:${PORTSDIR}/x11-wm/libdockapp
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${X11BASE}/lib"
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index 9875d4ed6ff3..93b2b72a7ec0 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
USE_AUTOMAKE_VER= 15
AUTOMAKE_ARGS= --add-missing