aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorDaniel Baker <dbaker@FreeBSD.org>1999-12-26 22:52:33 +0000
committerDaniel Baker <dbaker@FreeBSD.org>1999-12-26 22:52:33 +0000
commit412d33cbd66716e8bf04d351deb40ecb16922750 (patch)
tree0f60bfc6dcfcded72c4b59ff78edbf24bc8f4f27 /misc
parent0b31b1b4fd55d55a06d261745d9681b05d5b9233 (diff)
downloadports-412d33cbd66716e8bf04d351deb40ecb16922750.tar.gz
ports-412d33cbd66716e8bf04d351deb40ecb16922750.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/dnetc/Makefile91
-rw-r--r--misc/dnetc/distinfo1
-rw-r--r--misc/dnetc/files/INFO22
-rw-r--r--misc/dnetc/files/dnetc.ini2
-rw-r--r--misc/dnetc/files/dnetc.sh27
-rw-r--r--misc/dnetc/pkg-comment1
-rw-r--r--misc/dnetc/pkg-descr23
-rw-r--r--misc/dnetc/pkg-plist6
8 files changed, 173 insertions, 0 deletions
diff --git a/misc/dnetc/Makefile b/misc/dnetc/Makefile
new file mode 100644
index 000000000000..c32ce536475d
--- /dev/null
+++ b/misc/dnetc/Makefile
@@ -0,0 +1,91 @@
+# New ports collection makefile for: dnetc
+# Version required: 450
+# Date created: 26 Dec 1999
+# Whom: dbaker
+#
+# $FreeBSD$
+#
+
+DISTNAME= dnetc
+PKGNAME= dnetc-2.8002.450
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.distributed.net/pub/dcti/v2.8004/ \
+ http://http.distributed.net/pub/dcti/v2.8004/
+DISTFILES= dnetc450-freebsd-x86-elf.tar.gz
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386
+
+.if ${OSVERSION} < 220000
+BROKEN= "No version is built for your system."
+.elif ${OSVERSION} < 300000
+BROKEN= "No version is currently available for your system. Please try again later."
+.endif
+
+.if exists(/usr/local/distributed.net/rc5des)
+BROKEN= "RC5DES/DNETC conflict: Please deinstall all rc5des ports/packages"
+.endif
+
+MAINTAINER= dbaker@distributed.net
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+BINDIR= ${PREFIX}/distributed.net
+LIBDIR= ${PREFIX}/etc/rc.d/
+WRKSRC= ${WRKDIR}
+
+CLIENTUID= nobody
+CLIENTGID= daemon
+
+SBINMODE= 7700
+BINMODE= 700
+
+MAN1= dnetc.1
+
+do-configure:
+ if [ ! -f ${PREFIX}/dnetc.ini ]; then \
+ ${INSTALL} -c -m 644 ${FILESDIR}/dnetc.ini ${WRKSRC}; \
+ fi
+
+do-install:
+ if [ ! -d ${BINDIR} ]; then \
+ ${MKDIR} ${BINDIR}; \
+ fi
+
+ ${INSTALL} -c -m ${SBINMODE} -o ${CLIENTUID} -g ${CLIENTGID} ${WRKSRC}/dnetc ${BINDIR}
+
+ ${SED} s#CHANGETHIS#${BINDIR}# < ${FILESDIR}/dnetc.sh > ${WRKSRC}/dnetc.sh.pathnames
+ ${INSTALL} -c -m ${BINMODE} -o ${BINOWN} -g ${BINGRP} ${WRKSRC}/dnetc.sh.pathnames ${LIBDIR}/dnetc.sh
+
+ ${INSTALL} -c -m 644 -o ${CLIENTUID} -g ${CLIENTGID} ${FILESDIR}/INFO ${BINDIR}
+
+ ${CHOWN} ${CLIENTUID}:${CLIENTGID} ${BINDIR}
+ ${CHMOD} 775 ${BINDIR}
+
+ if [ ! -f ${BINDIR}/dnetc.sh ]; then \
+ ${LN} -s ${LIBDIR}/dnetc.sh ${BINDIR}/dnetc.sh; \
+ fi
+
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+
+.if !exists(${BINDIR}/dnetc.ini)
+ @echo ""
+ @echo ""
+ @echo ""
+ @echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ @echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ @echo "! REMEMBER REMEMBER REMEMBER REMEMBER REMEMBER REMEMBER REMEMBER REMEMBER !"
+ @echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ @echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ @echo " Don't forget to run '${BINDIR}/dnetc -config' "
+ @echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ @echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ @echo ""
+ @echo ""
+ @echo ""
+ ${INSTALL} -c -m 644 -o ${CLIENTUID} -g ${CLIENTGID} ${WRKDIR}/dnetc.ini ${BINDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/dnetc/distinfo b/misc/dnetc/distinfo
new file mode 100644
index 000000000000..5038405d8a5c
--- /dev/null
+++ b/misc/dnetc/distinfo
@@ -0,0 +1 @@
+MD5 (dnetc450-freebsd-x86-elf.tar.gz) = 5d09891d143f1e07f0bba0da47ade4a8
diff --git a/misc/dnetc/files/INFO b/misc/dnetc/files/INFO
new file mode 100644
index 000000000000..710531c5da85
--- /dev/null
+++ b/misc/dnetc/files/INFO
@@ -0,0 +1,22 @@
+This is the distributed.net's rc5/des/csc/ogr distributed
+computing client.
+
+Please look at the dnetc man page for more information.
+
+As a "loosely knit" group of computer users from all
+over the world, we take up challenges which require
+a lot of computing power. We solve these by distributing
+the cpu power needed over the computers of our members. That's
+why we're called "distributed.net." Read more about
+it at www.distributed.net.
+
+For your statistics, check out:
+ http://stats.distributed.net/
+
+For general help with the client or distributed.net, mail:
+ help@distributed.net
+
+For specific information regarding this port/package, mail:
+ dbaker@distributed.net or dbaker@cuckoo.com
+
+http://www.distributed.net/cgi-bin/dnet-finger.cgi?user=dbaker
diff --git a/misc/dnetc/files/dnetc.ini b/misc/dnetc/files/dnetc.ini
new file mode 100644
index 000000000000..d34c41e88b2e
--- /dev/null
+++ b/misc/dnetc/files/dnetc.ini
@@ -0,0 +1,2 @@
+[parameters]
+id=
diff --git a/misc/dnetc/files/dnetc.sh b/misc/dnetc/files/dnetc.sh
new file mode 100644
index 000000000000..e94c2bf0230d
--- /dev/null
+++ b/misc/dnetc/files/dnetc.sh
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+dir="CHANGETHIS"
+
+if [ ! -d $dir ]; then
+ logger -i "dnetc client directory doesn't exist. ($dir)."
+ exit
+fi
+
+if [ ! -f $dir/dnetc ]; then
+ logger -i "dnetc client doesn't exist. ($dir/rc5des)."
+ exit
+fi
+
+if [ ! -f $dir/dnetc.ini ]; then
+ logger -i "dnetc client config file doesn't exist. ($dir/rc5des.ini)."
+ exit
+fi
+
+email=`grep "^id=" $dir/dnetc.ini|cut -d"=" -f2`
+
+if [ $email = "rc5@distributed.net" ]; then
+ logger -i "dnetc client running with default email address. ($email)"
+fi
+
+echo -n " dnetc"
+su -m nobody -c "$dir/dnetc -quiet" 2>/dev/null >/dev/null &
diff --git a/misc/dnetc/pkg-comment b/misc/dnetc/pkg-comment
new file mode 100644
index 000000000000..a6404a6cbf18
--- /dev/null
+++ b/misc/dnetc/pkg-comment
@@ -0,0 +1 @@
+Distributed.net rc5des brute force client
diff --git a/misc/dnetc/pkg-descr b/misc/dnetc/pkg-descr
new file mode 100644
index 000000000000..d0623cffa4ab
--- /dev/null
+++ b/misc/dnetc/pkg-descr
@@ -0,0 +1,23 @@
+This is the distributed.net's rc5 and des brute force
+cracking client.
+
+As a "loosely knit" group of computer users from all
+over the world, we take up challenges which require
+a lot of computing power. We solve these by distributing
+the cpu power needed over the computers of our members. That's
+why we're called "distributed.net." Read more about
+it at www.distributed.net.
+
+For your statistics, check out:
+ http://stats.distributed.net/
+
+For general help with the client or distributed.net, mail:
+ help@distributed.net
+
+For specific information regarding this port/package, mail:
+ dbaker@distributed.net or dbaker@cuckoo.com
+
+
+http://www.distributed.net/cgi-bin/dnet-finger.cgi?user=dbaker
+
+WWW: http://www.distributed.net/
diff --git a/misc/dnetc/pkg-plist b/misc/dnetc/pkg-plist
new file mode 100644
index 000000000000..76ba35dc1215
--- /dev/null
+++ b/misc/dnetc/pkg-plist
@@ -0,0 +1,6 @@
+distributed.net/dnetc
+distributed.net/dnetc.ini
+distributed.net/dnetc.sh
+distributed.net/INFO
+etc/rc.d/dnetc.sh
+man/man1/dnetc.1.gz