aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-07 14:32:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-07 14:32:00 +0000
commit4c8a37671a54dcd9e6b1d8bab5ffc0e426203215 (patch)
tree506a63740d63bf549a23b304e35d6472abc58ec0 /misc
parent4084389efbadc8ef48d8f88ee6b3a725f534c985 (diff)
downloadports-4c8a37671a54dcd9e6b1d8bab5ffc0e426203215.tar.gz
ports-4c8a37671a54dcd9e6b1d8bab5ffc0e426203215.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/xd/Makefile8
-rw-r--r--misc/xd/files/patch-xd.c11
2 files changed, 14 insertions, 5 deletions
diff --git a/misc/xd/Makefile b/misc/xd/Makefile
index 24e429334bf6..5b10899501aa 100644
--- a/misc/xd/Makefile
+++ b/misc/xd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xd
-# Date created: 17 October 1997
-# Whom: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
-#
+# Created by: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
# $FreeBSD$
-#
PORTNAME= xd
PORTVERSION= 2.3
@@ -14,6 +10,8 @@ DISTNAME= xd-8087
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another dump utility
+LICENSE= BSD
+
MAKE_ARGS= CC="${CC}" BINDIR="${PREFIX}/bin" \
MANDIR="${MAN1PREFIX}/man/man"
diff --git a/misc/xd/files/patch-xd.c b/misc/xd/files/patch-xd.c
new file mode 100644
index 000000000000..05ae8b558fac
--- /dev/null
+++ b/misc/xd/files/patch-xd.c
@@ -0,0 +1,11 @@
+--- xd.c.orig 1996-08-27 02:23:22.000000000 +0900
++++ xd.c 2012-10-24 05:56:31.000000000 +0900
+@@ -392,7 +392,7 @@
+ *
+ */
+ #define ISFILE(str) (*(str) != '-' || *((str) + 1) == '\0')
+-void
++int
+ main(int argc, char *argv[])
+ {
+ int i, nf = 0, show_usage = FALSE, result;