aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-07 14:49:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-07 14:49:27 +0000
commitada926010422eddb5415b70c5459ef115c66fe11 (patch)
tree6dbe555152b7867d7e2cb6e34de07674f41b4a46 /misc
parentebc131d4cf022a55620fe003e2634f58852d052f (diff)
downloadports-ada926010422eddb5415b70c5459ef115c66fe11.tar.gz
ports-ada926010422eddb5415b70c5459ef115c66fe11.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/wmfirew/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/misc/wmfirew/Makefile b/misc/wmfirew/Makefile
index 8b363159b17b..6740d69c2e0f 100644
--- a/misc/wmfirew/Makefile
+++ b/misc/wmfirew/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmfirew
-# Date created: 16 May 2002
-# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
-#
+# Created by: Alexey Dokuchaev <danfe@regency.nsu.ru>
# $FreeBSD$
-#
PORTNAME= wmfirew
PORTVERSION= 0.20
@@ -19,7 +15,11 @@ WRKSRC= ${WRKDIR}/${PORTNAME}.app/${PORTNAME}
USE_GMAKE= yes
USE_XORG= xpm
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^void main|int main|' ${WRKSRC}/wmfirew.c
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin)
.include <bsd.port.mk>