aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-09 16:46:41 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-09 16:46:41 +0000
commitfcb18eda794449c8ebafc96e4c3ba23d97797ad3 (patch)
treecf2b2e2bd13e223cc7b97484cdbdeb01d8cf8b0a /misc
parentc9b0543b6db625bb8050c229b6230f8c7116ed11 (diff)
downloadports-fcb18eda794449c8ebafc96e4c3ba23d97797ad3.tar.gz
ports-fcb18eda794449c8ebafc96e4c3ba23d97797ad3.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/dphys-config/Makefile20
-rw-r--r--misc/dphys-config/pkg-plist2
2 files changed, 8 insertions, 14 deletions
diff --git a/misc/dphys-config/Makefile b/misc/dphys-config/Makefile
index 74c34dd0d138..1dee04047355 100644
--- a/misc/dphys-config/Makefile
+++ b/misc/dphys-config/Makefile
@@ -14,28 +14,22 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
NO_BUILD= yes
-MAN1= dphys-config.1
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/${PORTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
- ${MKDIR} ${EXAMPLESDIR}/site.example/local/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/dphys-config.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/site.example/local/sbin
.for f in dphys-config.example cron.d.example init.d.example
- ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${EXAMPLESDIR}
.endfor
${INSTALL_DATA} ${WRKSRC}/site.example/${PORTNAME}* \
- ${EXAMPLESDIR}/site.example/
+ ${STAGEDIR}${EXAMPLESDIR}/site.example/
${INSTALL_DATA} ${WRKSRC}/site.example/local/sbin/${PORTNAME}-* \
- ${EXAMPLESDIR}/site.example/local/sbin/
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.example ${PREFIX}/etc/${PORTNAME}.sample
-.if !exists(${PREFIX}/etc/${PORTNAME})
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.example ${PREFIX}/etc/${PORTNAME}
-.endif
+ ${STAGEDIR}${EXAMPLESDIR}/site.example/local/sbin/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.example ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.sample
.include <bsd.port.mk>
diff --git a/misc/dphys-config/pkg-plist b/misc/dphys-config/pkg-plist
index 671a40f917be..e2ba3c4fe023 100644
--- a/misc/dphys-config/pkg-plist
+++ b/misc/dphys-config/pkg-plist
@@ -1,8 +1,8 @@
-@comment $FreeBSD$
bin/dphys-config
@unexec if cmp -s %D/etc/dphys-config %D/etc/dphys-config.sample; then rm -f %D/etc/dphys-config; fi
etc/dphys-config.sample
@exec [ -f %B/dphys-config ] || cp %B/%f %B/dphys-config
+man/man1/dphys-config.1.gz
%%EXAMPLESDIR%%/cron.d.example
%%EXAMPLESDIR%%/dphys-config.example
%%EXAMPLESDIR%%/init.d.example