aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-10-09 18:19:05 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-10-09 18:19:05 +0000
commit50125fe3ca52ead93bafe0e3dcf895c8055904c4 (patch)
tree155528aa1c87baa8006c50b4c6e9c0771a34ce74 /misc
parentaba13900c1989935df405fbf1fe9488dbfd1de83 (diff)
downloadports-50125fe3ca52ead93bafe0e3dcf895c8055904c4.tar.gz
ports-50125fe3ca52ead93bafe0e3dcf895c8055904c4.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/ondir/Makefile18
-rw-r--r--misc/ondir/distinfo4
-rw-r--r--misc/ondir/pkg-descr2
3 files changed, 13 insertions, 11 deletions
diff --git a/misc/ondir/Makefile b/misc/ondir/Makefile
index 97be13145f66..741890ebf435 100644
--- a/misc/ondir/Makefile
+++ b/misc/ondir/Makefile
@@ -2,23 +2,25 @@
# $FreeBSD$
PORTNAME= ondir
-PORTVERSION= 0.2.3
+PORTVERSION= 0.2.4
CATEGORIES= misc
MASTER_SITES= http://swapoff.org/files/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Automatically executes scripts as you traverse directories
+LICENSE= GPLv2
+
ALL_TARGET= ${PORTNAME}
-MAKE_ARGS= PREFIX=${PREFIX} CONF=${PREFIX}/etc/ondirrc
-MAN1= ${PORTNAME}.1
-MANCOMPRESSED= no
+MAKE_ARGS= PREFIX="${PREFIX}" \
+ CC="${CC}" LD="${CC}" \
+ CFLAGS="${CFLAGS} -DVERSION=\\\"${PORTVERSION}\\\" -DGLOBAL_CONF=\\\"${PREFIX}/etc/ondirrc\\\"" \
+ LDFLAGS="${LDFLAGS}"
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
do-install:
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/misc/ondir/distinfo b/misc/ondir/distinfo
index 5c8aaff4e687..adb270460769 100644
--- a/misc/ondir/distinfo
+++ b/misc/ondir/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ondir-0.2.3.tar.gz) = 504a677e5b7c47c907f478d00f52c8ea629f2bf0d9134ac2a3bf0bbe64157ba3
-SIZE (ondir-0.2.3.tar.gz) = 17820
+SHA256 (ondir-0.2.4.tar.gz) = 52921cdcf02273e0d47cc6172df6a0d2c56980d724568276acb0591e0bda343a
+SIZE (ondir-0.2.4.tar.gz) = 52860
diff --git a/misc/ondir/pkg-descr b/misc/ondir/pkg-descr
index 87566bead0b6..0d0808f6f0bb 100644
--- a/misc/ondir/pkg-descr
+++ b/misc/ondir/pkg-descr
@@ -5,4 +5,4 @@ In addition to executing scripts in the directory you are entering or leaving,
ondir also executes scripts in directories that are traversed on the way to that
directory.
-WWW: http://swapoff.org/wiki/OnDir
+WWW: http://swapoff.org/ondir.html