aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2018-10-27 18:08:59 +0000
committerStefan Eßer <se@FreeBSD.org>2018-10-27 18:08:59 +0000
commit98320db02709103685d247164e76b0d21375c194 (patch)
tree0b9eb34f5ff1952954c670048b7fff3ef3a0ff74 /misc
parent95f40f80fb70bd4a77fff4439c99e29c7d1cbbd2 (diff)
downloadports-98320db02709103685d247164e76b0d21375c194.tar.gz
ports-98320db02709103685d247164e76b0d21375c194.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ctm/Makefile46
-rw-r--r--misc/ctm/distinfo3
-rw-r--r--misc/ctm/pkg-descr12
-rw-r--r--misc/ctm/pkg-plist10
5 files changed, 72 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 46f2aada919e..d3b41f8f7013 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -60,6 +60,7 @@
SUBDIR += cryptoballot
SUBDIR += cs
SUBDIR += cstream
+ SUBDIR += ctm
SUBDIR += dahdi
SUBDIR += dahdi-kmod
SUBDIR += dahdi-kmod26
diff --git a/misc/ctm/Makefile b/misc/ctm/Makefile
new file mode 100644
index 000000000000..7ab8d12e1076
--- /dev/null
+++ b/misc/ctm/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= ctm
+PORTVERSION= 2.0
+CATEGORIES= misc
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= Generate, receive and apply FreeBSD source updates per mail
+
+LICENSE= Beerware BSD2CLAUSE
+LICENSE_COMB= multi
+LICENSE_NAME_Beerware= Beerware
+LICENSE_TEXT_Beerware= "THE BEER-WARE LICENSE" (Revision 42): \
+ <phk@FreeBSD.org> wrote this file. As long as you retain this notice you \
+ can do whatever you want with this stuff. If we meet some day, and you think \
+ this stuff is worth it, you can buy me a beer in return. Poul-Henning Kamp
+LICENSE_PERMS_Beerware= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= tar:txz
+
+USE_GITHUB= yes
+GH_ACCOUNT= bsdimp
+GH_TAGNAME= ef289f3
+
+OPTIONS_DEFINE= DOCS
+MAKE_FLAGS= MK_MAN=no
+
+do-install:
+.for f in ctm ctm_dequeue ctm_rmail ctm_smail
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f}/${f} \
+ ${STAGEDIR}${PREFIX}/sbin
+.endfor
+.for f in ctm ctm_rmail
+ ${INSTALL_MAN} ${WRKSRC}/${f}/${f}.8 \
+ ${STAGEDIR}${MAN8PREFIX}/man/man8/
+.endfor
+.for f in ctm_dequeue ctm_smail
+ ${LN} ${STAGEDIR}${MAN8PREFIX}/man/man8/ctm_rmail.8 \
+ ${STAGEDIR}${MAN8PREFIX}/man/man8/${f}.8
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/ctm/ctm.5 \
+ ${STAGEDIR}${MAN5PREFIX}/man/man5/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/misc/ctm/distinfo b/misc/ctm/distinfo
new file mode 100644
index 000000000000..25997b4feb2f
--- /dev/null
+++ b/misc/ctm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540662310
+SHA256 (bsdimp-ctm-2.0-ef289f3_GH0.tar.gz) = 793d88b328699e41a68f214fbd581b5730f86631532728e01ad0a08cd8807bfb
+SIZE (bsdimp-ctm-2.0-ef289f3_GH0.tar.gz) = 40160
diff --git a/misc/ctm/pkg-descr b/misc/ctm/pkg-descr
new file mode 100644
index 000000000000..15e2fa9dcfc7
--- /dev/null
+++ b/misc/ctm/pkg-descr
@@ -0,0 +1,12 @@
+CTM was originally "CVS Through eMail", but has since changed scope to be
+much more general.
+
+CTM is now meant to be the definitive way to make and apply a delta between
+two versions of a directory tree.
+
+There are two parts to this, making the delta and applying it. These are two
+entirely different things. CTM concentrates the computation-burden on the
+generation of the deltas, as a delta very often is applied more times than
+it is made. Second CTM tries to make the minimal size delta.
+
+WWW: http://
diff --git a/misc/ctm/pkg-plist b/misc/ctm/pkg-plist
new file mode 100644
index 000000000000..da2c49cdc1ef
--- /dev/null
+++ b/misc/ctm/pkg-plist
@@ -0,0 +1,10 @@
+man/man5/ctm.5.gz
+man/man8/ctm.8.gz
+man/man8/ctm_dequeue.8.gz
+man/man8/ctm_rmail.8.gz
+man/man8/ctm_smail.8.gz
+sbin/ctm
+sbin/ctm_dequeue
+sbin/ctm_rmail
+sbin/ctm_smail
+%%PORTDOCS%%%%DOCSDIR%%/README