aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-06-22 09:24:56 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-06-22 09:24:56 +0000
commita6d5f8ab5e10cf5632c7096f28d596e672a44150 (patch)
treeabfbddd40dccf9d8821bac327f009a7b0029fa2f /misc
parent85c3d4a72582d14985a5d1e581af0e91d68a8122 (diff)
downloadports-a6d5f8ab5e10cf5632c7096f28d596e672a44150.tar.gz
ports-a6d5f8ab5e10cf5632c7096f28d596e672a44150.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/dtach/Makefile34
-rw-r--r--misc/dtach/distinfo2
-rw-r--r--misc/dtach/pkg-descr7
-rw-r--r--misc/dtach/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index dfb28eb2e109..8c7686c15f20 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -67,6 +67,7 @@
SUBDIR += documancer
SUBDIR += dog
SUBDIR += dotfile
+ SUBDIR += dtach
SUBDIR += dvorak7min
SUBDIR += dvorakng
SUBDIR += earthview
diff --git a/misc/dtach/Makefile b/misc/dtach/Makefile
new file mode 100644
index 000000000000..e5cd77339c22
--- /dev/null
+++ b/misc/dtach/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: dtach
+# Date created: 21 Jun 2004
+# Whom: bkhl@elektrubadur.se
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtach
+PORTVERSION= 0.6
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dtach
+
+MAINTAINER= bkhl@elektrubadur.se
+COMMENT= A small program that emulates the detach feature of screen
+
+GNU_CONFIGURE= yes
+ALL_TARGET= dtach
+
+MAN1= dtach.1
+PORTDOCS= COPYING README dtach.spec
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dtach ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/dtach.1 ${MANPREFIX}/man/man1
+
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/dtach/distinfo b/misc/dtach/distinfo
new file mode 100644
index 000000000000..1562a8e5fe8b
--- /dev/null
+++ b/misc/dtach/distinfo
@@ -0,0 +1,2 @@
+MD5 (dtach-0.6.tar.gz) = 7f4d593220f685f614983274559ea62e
+SIZE (dtach-0.6.tar.gz) = 49201
diff --git a/misc/dtach/pkg-descr b/misc/dtach/pkg-descr
new file mode 100644
index 000000000000..a98459e0b2ff
--- /dev/null
+++ b/misc/dtach/pkg-descr
@@ -0,0 +1,7 @@
+dtach is a tiny program that emulates the detach feature of screen,
+allowing you to run a program in an environment that is protected from
+the controlling terminal and attach to it later. dtach does not keep
+track of the contents of the screen, and thus works best with programs
+that know how to redraw themselves.
+
+WWW: http://dtach.sourceforge.net/
diff --git a/misc/dtach/pkg-plist b/misc/dtach/pkg-plist
new file mode 100644
index 000000000000..a45f9351e34b
--- /dev/null
+++ b/misc/dtach/pkg-plist
@@ -0,0 +1 @@
+bin/dtach