aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 14:53:06 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 14:53:06 +0000
commite5662ea30a19fbde05bff7b3007f1727efbc1b0a (patch)
tree5c81b18867a555c9b5133a18cce0cc241ed23c07 /misc
parent49db5b7e2a2f1a8175b8e7680fcf2db70c176014 (diff)
downloadports-e5662ea30a19fbde05bff7b3007f1727efbc1b0a.tar.gz
ports-e5662ea30a19fbde05bff7b3007f1727efbc1b0a.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/digitemp/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/misc/digitemp/Makefile b/misc/digitemp/Makefile
index 264a3a13fcde..d5e51288cdd3 100644
--- a/misc/digitemp/Makefile
+++ b/misc/digitemp/Makefile
@@ -14,9 +14,9 @@ LICENSE= GPLv2
USES= gmake
MAKE_ARGS+= CC="${CC}"
-MAN1= digitemp.1
PLIST_FILES= bin/digitemp_DS9097 bin/digitemp_DS9097U \
- etc/digitemp.conf.sample
+ etc/digitemp.conf.sample \
+ man/man1/digitemp.1.gz
DOCFILES= ChangeLog COPYRIGHT CREDITS FAQ README TODO \
dthowto.txt DS9097_Schematic.gif
@@ -27,29 +27,26 @@ ALL_TARGET= ds9097 ds9097u
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
pre-install:
- ${CP} ${WRKSRC}/${MAN1} ${WRKSRC}/digitemp.1.M
- ${CAT} ${WRKSRC}/digitemp.1.M | ${SED} -e "s/dev\/ttyS/dev\/cuau/g" > ${WRKSRC}/${MAN1}
+ ${REINPLACE_CMD} -e "s/dev\/ttyS/dev\/cuau/g" ${WRKSRC}/${PORTNAME}.1
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/digitemp_DS9097 ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/digitemp_DS9097U ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/digitemp_DS9097 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/digitemp_DS9097U ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.for dir in perl python/gui python/mysql rrdb
- @${MKDIR} ${DOCSDIR}/${dir}
- ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_DATA} \{\} ${DOCSDIR}/${dir} \;
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/${dir}
+ ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_DATA} \{\} ${STAGEDIR}${DOCSDIR}/${dir} \;
.endfor
.endif
- ${CAT} ${PKGMESSAGE}
- ${INSTALL_DATA} ${FILESDIR}/digitemp.conf.sample ${PREFIX}/etc/
+ ${INSTALL_DATA} ${FILESDIR}/digitemp.conf.sample ${STAGEDIR}${PREFIX}/etc/
@${ECHO_MSG} ""
@${ECHO_MSG} "Sample config installed at ${PREFIX}/etc/digitemp.conf.sample"
@${ECHO_MSG} ""