aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-08-13 20:16:08 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-08-13 20:16:08 +0000
commit0b1558fe45d558f8f775b664cbdfd2a20a8d56cd (patch)
tree5554bbf2d8a5812a24d3ea7261be7d1838022361 /misc
parent962c853e3619da1001f3debd7d2acd9d93b0b2a4 (diff)
downloadports-0b1558fe45d558f8f775b664cbdfd2a20a8d56cd.tar.gz
ports-0b1558fe45d558f8f775b664cbdfd2a20a8d56cd.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/cdcollect/Makefile8
-rw-r--r--misc/cdcollect/files/patch-src_DBsql.cs4
2 files changed, 7 insertions, 5 deletions
diff --git a/misc/cdcollect/Makefile b/misc/cdcollect/Makefile
index 0a73274082e0..6e602b91858c 100644
--- a/misc/cdcollect/Makefile
+++ b/misc/cdcollect/Makefile
@@ -13,12 +13,14 @@ COMMENT= Simple CD catalog for GNOME
BUILD_DEPENDS= sqlite3>=3.0:databases/sqlite3
RUN_DEPENDS:= ${BUILD_DEPENDS}
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
-USES= tar:bzip2 pathfix gettext gmake mono pkgconfig
+USES= gettext gmake localbase mono pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix intlhack libgnome gnomesharp20
GCONF_SCHEMAS= cdcollect.schemas
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+NO_ARCH= yes
post-extract:
${REINPLACE_CMD} -e 's,SqliteClient,Sqlite,' \
diff --git a/misc/cdcollect/files/patch-src_DBsql.cs b/misc/cdcollect/files/patch-src_DBsql.cs
index 1fabeaf61567..2083e9194b9b 100644
--- a/misc/cdcollect/files/patch-src_DBsql.cs
+++ b/misc/cdcollect/files/patch-src_DBsql.cs
@@ -1,6 +1,6 @@
---- src/DBsql.cs.orig
+--- src/DBsql.cs.orig 2006-11-24 17:12:13 UTC
+++ src/DBsql.cs
-@@ -958,10 +958,10 @@
+@@ -958,10 +958,10 @@ public class CDDatabaseSql
private int sql_command_id (string comm)
{
IDbCommand command = sqlite_connection.CreateCommand ();