aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-08 23:35:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-09 00:19:52 +0000
commitc374177f76c4cda1694935d3046c4719d7455675 (patch)
tree933c2e04404f971db30fde376ea45b0eb4fba376 /misc
parent1f3a01615af5308e1277380de5ee072e5791f5d1 (diff)
downloadports-c374177f76c4cda1694935d3046c4719d7455675.tar.gz
ports-c374177f76c4cda1694935d3046c4719d7455675.zip
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/fastscapelib/Makefile26
-rw-r--r--misc/fastscapelib/distinfo3
-rw-r--r--misc/fastscapelib/pkg-descr5
-rw-r--r--misc/fastscapelib/pkg-plist24
5 files changed, 59 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a04c708946be..d354675c9496 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -99,6 +99,7 @@
SUBDIR += explosions
SUBDIR += ezc3d
SUBDIR += far2l
+ SUBDIR += fastscapelib
SUBDIR += felis
SUBDIR += figlet
SUBDIR += figlet-fonts
diff --git a/misc/fastscapelib/Makefile b/misc/fastscapelib/Makefile
new file mode 100644
index 000000000000..6df1bc0ea60f
--- /dev/null
+++ b/misc/fastscapelib/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= fastscapelib
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.3-53
+DISTVERSIONSUFFIX= -g5698347
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library of efficient algorithms for topographic data
+WWW= https://fastscapelib.readthedocs.io/en/latest/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= xtensor>0:math/xtensor
+RUN_DEPENDS= xtensor>0:math/xtensor
+
+USES= cmake:testing
+
+USE_GITHUB= yes
+GH_ACCOUNT= fastscape-lem
+
+CMAKE_TESTING_ON= BUILD_TESTS
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/fastscapelib/distinfo b/misc/fastscapelib/distinfo
new file mode 100644
index 000000000000..cfde1fb9f4f9
--- /dev/null
+++ b/misc/fastscapelib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1673219854
+SHA256 (fastscape-lem-fastscapelib-v0.1.3-53-g5698347_GH0.tar.gz) = 57c3e83041ba7b2e7e8bc789711d20fefc68b223c5e689e5801b23d18bc89c3c
+SIZE (fastscape-lem-fastscapelib-v0.1.3-53-g5698347_GH0.tar.gz) = 107177
diff --git a/misc/fastscapelib/pkg-descr b/misc/fastscapelib/pkg-descr
new file mode 100644
index 000000000000..712069d9c14b
--- /dev/null
+++ b/misc/fastscapelib/pkg-descr
@@ -0,0 +1,5 @@
+fastscapelib is a C++ library of efficient algorithms for processing topographic
+data and landscape evolution modeling.
+
+This library currently has Python bindings and is easily extensible to other
+languages.
diff --git a/misc/fastscapelib/pkg-plist b/misc/fastscapelib/pkg-plist
new file mode 100644
index 000000000000..80ba359ae5e0
--- /dev/null
+++ b/misc/fastscapelib/pkg-plist
@@ -0,0 +1,24 @@
+include/fastscapelib/base.hpp
+include/fastscapelib/basin_graph.hpp
+include/fastscapelib/consts.hpp
+include/fastscapelib/diffusion_adi.hpp
+include/fastscapelib/flow_graph.hpp
+include/fastscapelib/flow_graph_impl.hpp
+include/fastscapelib/flow_router.hpp
+include/fastscapelib/flow_routing.hpp
+include/fastscapelib/iterators.hpp
+include/fastscapelib/pflood.hpp
+include/fastscapelib/profile_grid.hpp
+include/fastscapelib/raster_grid.hpp
+include/fastscapelib/sink_resolver.hpp
+include/fastscapelib/spl.hpp
+include/fastscapelib/structured_grid.hpp
+include/fastscapelib/union_find.hpp
+include/fastscapelib/unstructured_mesh.hpp
+include/fastscapelib/utils.hpp
+include/fastscapelib/version.hpp
+include/fastscapelib/xtensor_utils.hpp
+lib/cmake/fastscapelib/fastscapelibConfig.cmake
+lib/cmake/fastscapelib/fastscapelibConfigVersion.cmake
+lib/cmake/fastscapelib/fastscapelibTargets.cmake
+libdata/pkgconfig/fastscapelib.pc