aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2012-06-27 17:13:55 +0000
committerMax Khon <fjoe@FreeBSD.org>2012-06-27 17:13:55 +0000
commit26cf8652827f849703749761f71f808c3dc4ac41 (patch)
tree4e34584439250f0eb5cc8abefd9897b7fdaff73f /misc
parentcc4f88827c43be2015c74f343897760e23abbbbe (diff)
downloadports-26cf8652827f849703749761f71f808c3dc4ac41.tar.gz
ports-26cf8652827f849703749761f71f808c3dc4ac41.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/openr2/Makefile29
-rw-r--r--misc/openr2/distinfo2
-rw-r--r--misc/openr2/files/patch-Makefile.in13
-rw-r--r--misc/openr2/pkg-descr10
-rw-r--r--misc/openr2/pkg-plist20
6 files changed, 75 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index ac52b471a6b0..ddc580188cd8 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -376,6 +376,7 @@
SUBDIR += nut
SUBDIR += ondir
SUBDIR += opencyc
+ SUBDIR += openr2
SUBDIR += orville-write
SUBDIR += ossp-uuid
SUBDIR += otter
diff --git a/misc/openr2/Makefile b/misc/openr2/Makefile
new file mode 100644
index 000000000000..7087d4e19799
--- /dev/null
+++ b/misc/openr2/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: openr2
+# Date created: 28 Jun 2012
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openr2
+PORTVERSION= 1.3.2
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= MFC/R2 call setup library
+
+BUILD_DEPENDS= ${LOCALBASE}/include/dahdi/user.h:${PORTSDIR}/misc/dahdi
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+USE_LDCONFIG= yes
+
+CONF_FILES= etc/r2proto.conf etc/r2test.conf
+
+post-install:
+.for f in ${CONF_FILES}
+ [ -e ${PREFIX}/$f ] || ${INSTALL_DATA} ${PREFIX}/$f-dist ${PREFIX}/$f
+.endfor
+
+.include <bsd.port.mk>
diff --git a/misc/openr2/distinfo b/misc/openr2/distinfo
new file mode 100644
index 000000000000..852a958793ef
--- /dev/null
+++ b/misc/openr2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openr2-1.3.2.tar.gz) = 944f3d6b23e3cc72a6a6bb35c9bd18b1ca642df2b41a0c9c51abae86bbbd3240
+SIZE (openr2-1.3.2.tar.gz) = 749556
diff --git a/misc/openr2/files/patch-Makefile.in b/misc/openr2/files/patch-Makefile.in
new file mode 100644
index 000000000000..00afd72d6b48
--- /dev/null
+++ b/misc/openr2/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.orig 2012-06-26 19:49:39.000000000 +0700
++++ Makefile.in 2012-06-26 19:50:31.000000000 +0700
+@@ -370,8 +370,8 @@
+ @list='$(dist_sysconf_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(am__strip_dir) \
+- echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
+- $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
++ echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f-dist'"; \
++ $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f-dist"; \
+ done
+
+ uninstall-dist_sysconfDATA:
diff --git a/misc/openr2/pkg-descr b/misc/openr2/pkg-descr
new file mode 100644
index 000000000000..be405eee2f3a
--- /dev/null
+++ b/misc/openr2/pkg-descr
@@ -0,0 +1,10 @@
+OpenR2 is a library that implements the MFC/R2 signalling over E1 lines using
+the Zapata Telephony interface (or DAHDI). The MF R2 tones required for the
+signaling are generated by code borrowed from the LGPL library SpanDSP
+written by Steve Underwood, the user has the option to provide a MF interface
+to use his own MF R2 tone generation and detection so the library will use
+them when needed, that's why this library does not depend directly on spandsp,
+libteletone or zaptel for tone generation and detection (depends on zaptel
+for CAS bits and general media transmission though)
+
+WWW: http://libopenr2.org/
diff --git a/misc/openr2/pkg-plist b/misc/openr2/pkg-plist
new file mode 100644
index 000000000000..2a87cada0af3
--- /dev/null
+++ b/misc/openr2/pkg-plist
@@ -0,0 +1,20 @@
+bin/r2dtmf_detect
+bin/r2test
+@unexec if cmp -s %D/etc/r2proto.conf %D/etc/r2proto.conf-dist; then rm -f %D/etc/r2proto.conf; fi
+etc/r2proto.conf-dist
+@exec if test ! -e %D/etc/r2proto.conf; then cp -p %D/etc/r2proto.conf-dist %D/etc/r2proto.conf; fi
+@unexec if cmp -s %D/etc/r2test.conf %D/etc/r2test.conf-dist; then rm -f %D/etc/r2test.conf; fi
+etc/r2test.conf-dist
+@exec if test ! -e %D/etc/r2test.conf; then cp -p %D/etc/r2test.conf-dist %D/etc/r2test.conf; fi
+@exec false
+include/openr2.h
+include/openr2/r2chan.h
+include/openr2/r2context.h
+include/openr2/r2log.h
+include/openr2/r2proto.h
+include/openr2/r2utils.h
+lib/libopenr2.a
+lib/libopenr2.la
+lib/libopenr2.so
+lib/libopenr2.so.4
+@dirrm include/openr2