aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2010-05-14 19:48:55 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2010-05-14 19:48:55 +0000
commit0a847c83cedeb94d86444f998475873796e4ef93 (patch)
tree0c3bec19b1a2c56179182272af40aeebffc47f5f /misc
parent6d7de17a5fbec1dbeac16910a734ad5d1cd30a0d (diff)
Retire misc/ldconfig_compat. Thee served us well
PR: ports/146532 Submitted by: Alex Kozlov <spam@rm-rf.kiev.ua>
Notes
Notes: svn path=/head/; revision=254330
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ldconfig_compat/Makefile59
-rw-r--r--misc/ldconfig_compat/bsd.ldconfig.mk2
-rw-r--r--misc/ldconfig_compat/files/ldconfig_compat.sh.in59
-rw-r--r--misc/ldconfig_compat/pkg-descr5
5 files changed, 0 insertions, 126 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b99f2abdaf92..1d3ed3bf8e61 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -333,7 +333,6 @@
SUBDIR += kwatch
SUBDIR += latex-mk
SUBDIR += lc
- SUBDIR += ldconfig_compat
SUBDIR += lesspipe
SUBDIR += libeatmydata
SUBDIR += libhome
diff --git a/misc/ldconfig_compat/Makefile b/misc/ldconfig_compat/Makefile
deleted file mode 100644
index 740054c1284f..000000000000
--- a/misc/ldconfig_compat/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# New ports collection makefile for: ldconfig_compat
-# Date created: 30 Dec 2005
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= ldconfig_compat
-PORTVERSION= 1.0
-PORTREVISION= 8
-CATEGORIES= misc
-MASTER_SITES= # none
-DISTFILES= # none
-
-MAINTAINER= flz@FreeBSD.org
-COMMENT= Ldconfig compatibility script
-
-NO_BUILD= yes
-SUB_FILES= ldconfig_compat.sh
-USE_RC_SUBR= yes
-
-LOCAL_DIRS= ${LDCONFIG_DIR} \
- ${LDCONFIG32_DIR}
-
-SUB_LIST= LDCONFIG_DIR=${LDCONFIG_DIR} \
- LDCONFIG32_DIR=${LDCONFIG32_DIR}
-
-.if !defined(WITHOUT_X11)
-LOCAL_PREFIXES= ${PREFIX} ${LOCALBASE}
-.else
-LOCAL_PREFIXES= ${PREFIX}
-.endif
-
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/bsd.ldconfig.mk"
-
-.if !( ${OSVERSION} < 504105 || \
- ( ${OSVERSION} >= 700000 && ${OSVERSION} < 700012 ) || \
- ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600104 ) )
-IGNORE= isn't needed (part of base rc.d)
-.endif
-
-do-fetch:
- @${DO_NADA}
-
-do-install:
-.if ${OSVERSION} >= 600101
- @${INSTALL_SCRIPT} ${WRKDIR}/ldconfig_compat.sh ${PREFIX}/etc/rc.d/ldconfig_compat
- @${ECHO_CMD} "etc/rc.d/ldconfig_compat" >> ${TMPPLIST}
-.elif ${OSVERSION} >= 500037
- @${INSTALL_SCRIPT} ${WRKDIR}/ldconfig_compat.sh /etc/rc.d/ldconfig_compat
- @${ECHO_CMD} "@cwd /" >> ${TMPPLIST}
- @${ECHO_CMD} "etc/rc.d/ldconfig_compat" >> ${TMPPLIST}
-.else
- @${INSTALL_SCRIPT} ${WRKDIR}/ldconfig_compat.sh ${PREFIX}/etc/rc.d/000.ldconfig_compat.sh
- @${ECHO_CMD} "etc/rc.d/000.ldconfig_compat.sh" >> ${TMPPLIST}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/misc/ldconfig_compat/bsd.ldconfig.mk b/misc/ldconfig_compat/bsd.ldconfig.mk
deleted file mode 100644
index 416f4c5f2e91..000000000000
--- a/misc/ldconfig_compat/bsd.ldconfig.mk
+++ /dev/null
@@ -1,2 +0,0 @@
-LDCONFIG_DIR= libdata/ldconfig
-LDCONFIG32_DIR= libdata/ldconfig32
diff --git a/misc/ldconfig_compat/files/ldconfig_compat.sh.in b/misc/ldconfig_compat/files/ldconfig_compat.sh.in
deleted file mode 100644
index 865d31b571d0..000000000000
--- a/misc/ldconfig_compat/files/ldconfig_compat.sh.in
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: ldconfig_compat
-# REQUIRE: mountcritremote ldconfig
-# BEFORE: DAEMON
-
-. /etc/rc.subr
-
-name="ldconfig"
-ldconfig_command="/sbin/ldconfig"
-start_cmd="ldconfig_start"
-stop_cmd=":"
-
-load_rc_config $name
-: ${ldconfig_local_dirs="%%PREFIX%%/%%LDCONFIG_DIR%% %%LOCALBASE%%/%%LDCONFIG_DIR%%"}
-: ${ldconfig_local32_dirs="%%PREFIX%%/%%LDCONFIG32_DIR%% %%LOCALBASE%%/%%LDCONFIG32_DIR%%"}
-
-ldconfig_start()
-{
- local _files
-
- _ins=
- ldconfig=${ldconfig_command}
- checkyesno ldconfig_insecure && _ins="-i"
- if [ -x "${ldconfig_command}" ]; then
- ldconfig_paths=""
- for i in ${ldconfig_local_dirs}; do
- if [ -d "${i}" ]; then
- _files=`find ${i} -type f`
- if [ -n "${_files}" ]; then
- ldconfig_paths="${ldconfig_paths} `cat ${_files} | sort -u`"
- fi
- fi
- done
- echo 'Local ldconfig path:' ${ldconfig_paths}
- ${ldconfig} -m ${_ins} ${ldconfig_paths}
-
- case `sysctl -n hw.machine_arch` in
- amd64)
- ldconfig32_paths=""
- for i in ${ldconfig_local32_dirs}; do
- if [ -d "${i}" ]; then
- _files=`find ${i} -type f`
- if [ -n "${_files}" ]; then
- ldconfig32_paths="${ldconfig32_paths} `cat ${_files} | sort -u`"
- fi
- fi
- done
- echo 'Local 32-bits ldconfig path:' ${ldconfig32_paths}
- ${ldconfig} -32 -m ${_ins} ${ldconfig32_paths}
- ;;
- esac
- fi
-}
-
-run_rc_command "$1"
diff --git a/misc/ldconfig_compat/pkg-descr b/misc/ldconfig_compat/pkg-descr
deleted file mode 100644
index 8c931e93dddf..000000000000
--- a/misc/ldconfig_compat/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This port installs a compatibility script that enable old
-FreeBSD systems to use ldconfig local directories.
-
-- Florent Thoumie
-flz@FreeBSD.org