aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-12-19 08:14:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-12-19 08:14:05 +0000
commitebf6615d5c378def8df484dc5428a43b9f0b4f58 (patch)
tree1a45ced1e10af52c709bb7f1ec31ac6971948158 /misc
parent4566ce779e5b09d60c0998d651d05c238398b980 (diff)
downloadports-ebf6615d5c378def8df484dc5428a43b9f0b4f58.tar.gz
ports-ebf6615d5c378def8df484dc5428a43b9f0b4f58.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/yaunc/Makefile29
-rw-r--r--misc/yaunc/distinfo2
-rw-r--r--misc/yaunc/files/patch-aa64
-rw-r--r--misc/yaunc/files/patch-ab11
-rw-r--r--misc/yaunc/files/patch-ac14
-rw-r--r--misc/yaunc/files/patch-ad11
6 files changed, 60 insertions, 71 deletions
diff --git a/misc/yaunc/Makefile b/misc/yaunc/Makefile
index eb40390c8ba6..bbea94b4e6ee 100644
--- a/misc/yaunc/Makefile
+++ b/misc/yaunc/Makefile
@@ -1,28 +1,29 @@
-# New ports collection makefile for: yaunc
-# Date created: 5 March 2000
-# Whom: nsayer@freebsd.org
+# New ports collection makefile for: yaunc
+# Date created: 5 March 2000
+# Whom: nsayer@freebsd.org
#
# $FreeBSD$
#
PORTNAME= yaunc
-PORTVERSION= 0.02
+PORTVERSION= 0.05
CATEGORIES= misc
MASTER_SITES= http://www.redterror.net/code/yaunc/
-MAINTAINER= ports@freebsd.org
-
-WRKSRC= ${WRKDIR}/yaunc
+MAINTAINER= ports@FreeBSD.org
+ALL_TARGET= bsd
MAN1= yaunc.1
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/yaunc.1
+
do-install:
- ( cd ${WRKSRC} ;\
- ${INSTALL_PROGRAM} yaunc ${PREFIX}/bin ;\
- ${INSTALL_DATA} -m 600 yaunc.conf ${PREFIX}/etc/yaunc.conf.sample ;\
- ${INSTALL_MAN} yaunc.man ${PREFIX}/man/man1/yaunc.1 ;\
- ${SED} s+%%PREFIX%%+${PREFIX}+g < ${FILESDIR}/startup > \
- ${PREFIX}/etc/rc.d/yaunc.sh ;\
- chmod 755 ${PREFIX}/etc/rc.d/yaunc.sh )
+ ${INSTALL_PROGRAM} ${WRKSRC}/yaunc ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/yaunc.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} -m 600 ${WRKSRC}/yaunc.conf ${PREFIX}/etc/yaunc.conf.sample
+ ${SED} -e "s:%%PREFIX%%:${PREFIX}:g" ${FILESDIR}/startup > \
+ ${PREFIX}/etc/rc.d/yaunc.sh
+ ${CHMOD} 755 ${PREFIX}/etc/rc.d/yaunc.sh
.include <bsd.port.mk>
diff --git a/misc/yaunc/distinfo b/misc/yaunc/distinfo
index fe5976d94773..dde396d619f3 100644
--- a/misc/yaunc/distinfo
+++ b/misc/yaunc/distinfo
@@ -1 +1 @@
-MD5 (yaunc-0.02.tar.gz) = a5c9bf1e1e72064c80dc5c3d66292863
+MD5 (yaunc-0.05.tar.gz) = 9f84d4f0bf065e9b4a49d3b871cb951d
diff --git a/misc/yaunc/files/patch-aa b/misc/yaunc/files/patch-aa
index 1cb387e3f1a1..22e850774fa3 100644
--- a/misc/yaunc/files/patch-aa
+++ b/misc/yaunc/files/patch-aa
@@ -1,50 +1,24 @@
---- Makefile.orig Sun Mar 5 11:18:06 2000
-+++ Makefile Sun Mar 5 11:29:57 2000
-@@ -1,6 +1,9 @@
+--- Makefile.orig Sun Aug 13 16:12:37 2000
++++ Makefile Sat Dec 16 16:45:06 2000
+@@ -1,15 +1,15 @@
# Compiler, flags, etc...
-CC = gcc
--CFLAGS = -ansi -pedantic -Wall -O3 #-DDEBUG2 -DDEBUG1
-+#CC = gcc
-+#CFLAGS = -ansi -pedantic -Wall -O3 #-DDEBUG2 -DDEBUG1
-+CFLAGS+= -DETCDIR=\"$(PREFIX)/etc/\"
-+
-+all: bsd
+-CFLAGS = -Wall -O3 #-g -DDEBUG2 -DDEBUG1
++CC ?= gcc
++CFLAGS += -DDEFAULT_CONF_PATH=\"$(CONFPATH)/$(CONFFILE)\"
+
+ # program variables
+ LINKNAME = yaunc
+-FILENAME = yaunc-`cat VERSION`
+-FILEPATH = /usr/local/bin
++FILENAME = yaunc
++FILEPATH = ${PREFIX}/bin
+ MANPAGE = yaunc.1
+-MANPATH = /usr/local/man/man1
++MANPATH = ${PREFIX}/man/man1
+ CONFFILE = yaunc.conf
+-CONFPATH = /etc
++CONFPATH = ${PREFIX}/etc
# platform dependant stuff has the appropriate suffix :)
OBJ1 = read_conf.o usage.o unp_error.o encode.o unp_sock_wrappers.o \
-@@ -24,23 +27,23 @@
- linux_funcs.o get_ut_proc.o get_ut_bsd.o : yaunc.h my_hdrs.h
-
- # housekeeping
--.PHONY : clean distclean install uninstall package backup
--clean :
-- rm -f *.o core
--distclean : clean
-- rm -f yaunc
-+#.PHONY : clean distclean install uninstall package backup
-+#clean :
-+# rm -f *.o core
-+#distclean : clean
-+# rm -f yaunc
-
- install :
-- cp yaunc /usr/local/bin ; \
-- cp yaunc.1 /usr/local/man/man1 ; \
-- cp yaunc.conf /etc/
-+ ${INSTALL_PROGRAM} yaunc $(PREFIX)/bin
-+ ${INSTALL_MAN} yaunc.1 $(PREFIX)/man/man1
-+ ${INSTALL_DATA} yaunc.conf $(PREFIX)/etc
-
- uninstall :
- rm /usr/local/bin/yaunc ; \
- rm /usr/local/man/man1/yaunc.1 ; \
- rm /etc/yaunc.conf
-
--package : distclean
-- cd .. ; tar -cf - yaunc | gzip -9 > yaunc-`cat yaunc/VERSION`.tar.gz
--backup : distclean
-- cp -a . ../src_backup
-+#package : distclean
-+# cd .. ; tar -cf - yaunc | gzip -9 > yaunc-`cat yaunc/VERSION`.tar.gz
-+#backup : distclean
-+# cp -a . ../src_backup
diff --git a/misc/yaunc/files/patch-ab b/misc/yaunc/files/patch-ab
deleted file mode 100644
index db393d6669da..000000000000
--- a/misc/yaunc/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.c.orig Sun Mar 5 11:26:38 2000
-+++ main.c Sun Mar 5 11:26:57 2000
-@@ -13,7 +13,7 @@
- struct utsname sys_info;
- struct info info;
- time_t uptime;
-- char * path = "/etc/yaunc.conf";
-+ char * path = ETCDIR"yaunc.conf";
- char * data_ptr;
-
- /* read data from the conf file */
diff --git a/misc/yaunc/files/patch-ac b/misc/yaunc/files/patch-ac
new file mode 100644
index 000000000000..5b58fdb78cde
--- /dev/null
+++ b/misc/yaunc/files/patch-ac
@@ -0,0 +1,14 @@
+--- usage.c.orig Wed Jul 26 09:38:02 2000
++++ usage.c Sat Dec 16 16:51:31 2000
+@@ -10,9 +10,9 @@
+ fprintf(stderr, "\n");
+ fprintf(stderr, "Options:\n");
+ fprintf(stderr, "\t-f <config file> - use the specified config file instead of \n");
+- fprintf(stderr, "\t of /etc/yaunc.conf\n");
++ fprintf(stderr, "\t " DEFAULT_CONF_PATH "\n");
+ fprintf(stderr, "\t-d <0/1> - turn daemon mode off/on\n");
+- fprintf(stderr, "\t-l <0/1> - specify logging off/on");
++ fprintf(stderr, "\t-l <0/1> - specify logging off/on\n");
+ fprintf(stderr, "\t-h - display this help\n");
+ fprintf(stderr, "\n");
+ exit(0);
diff --git a/misc/yaunc/files/patch-ad b/misc/yaunc/files/patch-ad
new file mode 100644
index 000000000000..cee954cf092b
--- /dev/null
+++ b/misc/yaunc/files/patch-ad
@@ -0,0 +1,11 @@
+--- yaunc.1.origt Fri Mar 17 17:38:45 2000
++++ yaunc.1 Sat Dec 16 16:40:02 2000
+@@ -25,7 +25,7 @@
+ \fIYauc\fP accepts the following options:
+ .TP 8
+ .B \-f conf_file
+-Specify an alternate configuration file. Default is /etc/yaunc.conf.
++Specify an alternate configuration file. Default is %%PREFIX%%/etc/yaunc.conf.
+ .B \-h
+ Display usage information.
+ .