aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:48:40 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:48:40 +0000
commit9b109c24d6453aea846c332f453fb689d39ca2c8 (patch)
tree74b2d02890f6b376c36b3ac884532732db90be38 /misc
parent5c3cefb426b4cd20e34b499b0d285043edece9ab (diff)
downloadports-9b109c24d6453aea846c332f453fb689d39ca2c8.tar.gz
ports-9b109c24d6453aea846c332f453fb689d39ca2c8.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-TomTom/Makefile36
-rw-r--r--misc/p5-Geo-Coder-TomTom/distinfo2
-rw-r--r--misc/p5-Geo-Coder-TomTom/pkg-descr4
-rw-r--r--misc/p5-Geo-Coder-TomTom/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a54972c924cb..f7dd23ebaae9 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -411,6 +411,7 @@
SUBDIR += p5-Geo-Coder-OSM
SUBDIR += p5-Geo-Coder-Ovi
SUBDIR += p5-Geo-Coder-PlaceFinder
+ SUBDIR += p5-Geo-Coder-TomTom
SUBDIR += p5-Geo-Postcodes
SUBDIR += p5-Geo-Postcodes-DK
SUBDIR += p5-Geo-Postcodes-NO
diff --git a/misc/p5-Geo-Coder-TomTom/Makefile b/misc/p5-Geo-Coder-TomTom/Makefile
new file mode 100644
index 000000000000..2faca1d6e494
--- /dev/null
+++ b/misc/p5-Geo-Coder-TomTom/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Geo-Coder-TomTom
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-TomTom
+PORTVERSION= 0.03
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode addresses with the TomTom route planner
+
+BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::TomTom.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-TomTom/distinfo b/misc/p5-Geo-Coder-TomTom/distinfo
new file mode 100644
index 000000000000..2899a65dd329
--- /dev/null
+++ b/misc/p5-Geo-Coder-TomTom/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-TomTom-0.03.tar.gz) = 4df31d1436be57ae249c19f8e88e778587e64c64e8474f6d8bc17f96e501d268
+SIZE (Geo-Coder-TomTom-0.03.tar.gz) = 5521
diff --git a/misc/p5-Geo-Coder-TomTom/pkg-descr b/misc/p5-Geo-Coder-TomTom/pkg-descr
new file mode 100644
index 000000000000..64718c1e4fa9
--- /dev/null
+++ b/misc/p5-Geo-Coder-TomTom/pkg-descr
@@ -0,0 +1,4 @@
+Geo::Coder::TomTom provides an interface to the geocoding service of the TomTom
+route planner through the unofficial (as-yet unpublished) REST API.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-TomTom/
diff --git a/misc/p5-Geo-Coder-TomTom/pkg-plist b/misc/p5-Geo-Coder-TomTom/pkg-plist
new file mode 100644
index 000000000000..f3093521a06c
--- /dev/null
+++ b/misc/p5-Geo-Coder-TomTom/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/TomTom.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/TomTom/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/TomTom
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo