aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2010-06-01 14:57:55 +0000
committerMax Khon <fjoe@FreeBSD.org>2010-06-01 14:57:55 +0000
commit193f33ad74a5b65349955e740b6388f124dfcd31 (patch)
tree82177c87956bb20debdb2047957f055b4de5abfb /misc
parentbca2b42272ae86cac4ab8e7fe4c8ca053a8d23a9 (diff)
downloadports-193f33ad74a5b65349955e740b6388f124dfcd31.tar.gz
ports-193f33ad74a5b65349955e740b6388f124dfcd31.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/dahdi-kmod/Makefile21
-rw-r--r--misc/dahdi-kmod/distinfo6
-rw-r--r--misc/dahdi-kmod/files/patch-tools-Makefile32
-rw-r--r--misc/dahdi-kmod/files/patch-tools-dahdi_monitor.c14
-rw-r--r--misc/dahdi-kmod/files/patch-tools-tonezone.c25
-rw-r--r--misc/dahdi-kmod/pkg-plist11
-rw-r--r--misc/dahdi/Makefile21
-rw-r--r--misc/dahdi/distinfo6
-rw-r--r--misc/dahdi/files/patch-tools-Makefile32
-rw-r--r--misc/dahdi/files/patch-tools-dahdi_monitor.c14
-rw-r--r--misc/dahdi/files/patch-tools-tonezone.c25
-rw-r--r--misc/dahdi/pkg-plist11
12 files changed, 76 insertions, 142 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index 336e405c5532..f4541128e651 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 4
+PORTREVISION= 0
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fjoe
@@ -19,8 +19,8 @@ COMMENT= Digium/Asterisk Hardware Device Interface
BUILD_DEPENDS= gmake:${PORTSDIR}/devel/gmake
LIB_DEPENDS= newt.52:${PORTSDIR}/devel/newt
-DAHDI_VERSION= 2.2.1-rc2
-DAHDI_TOOLS_VERSION= 2.2.1.1-rc1
+DAHDI_VERSION= 2.3.0-rc2
+DAHDI_TOOLS_VERSION= 2.3.0
NO_PACKAGE= Should be in sync with the kernel to work correctly
GNU_CONFIGURE= yes
@@ -39,8 +39,23 @@ MAN8= dahdi_cfg.8\
dahdi_tool.8\
fxotune.8
+OPTIONS= EXPERIMENTAL "Enable experimental drivers" off
+
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+PLIST_SUB+= X86=""
+.else
+PLIST_SUB+= X86="@comment "
+.endif
+
+.if defined(WITH_EXPERIMENTAL)
+MAKE_FLAGS+= WITH_EXPERIMENTAL=yes
+PLIST_SUB+= WITH_EXPERIMENTAL=""
+.else
+PLIST_SUB+= WITH_EXPERIMENTAL="@comment "
+.endif
+
pre-everything::
@if [ ! -f /usr/src/sys/Makefile ]; then \
${ECHO_MSG} ">> The dahdi port needs FreeBSD kernel source code to compile."; \
diff --git a/misc/dahdi-kmod/distinfo b/misc/dahdi-kmod/distinfo
index b133f06bcd65..ba5f9996b6a6 100644
--- a/misc/dahdi-kmod/distinfo
+++ b/misc/dahdi-kmod/distinfo
@@ -1,3 +1,3 @@
-MD5 (dahdi-freebsd-complete-2.2.1-rc2+2.2.1.1-rc1.tar.gz) = fc3c1423336661545fa9218dda392732
-SHA256 (dahdi-freebsd-complete-2.2.1-rc2+2.2.1.1-rc1.tar.gz) = 3f02bb178e0e3fb39497ba5b1f44eba7e3ada0a83628ee649a5a90a1c9712973
-SIZE (dahdi-freebsd-complete-2.2.1-rc2+2.2.1.1-rc1.tar.gz) = 1984887
+MD5 (dahdi-freebsd-complete-2.3.0-rc2+2.3.0.tar.gz) = 3885e017536e75cd1cb2a210e6668970
+SHA256 (dahdi-freebsd-complete-2.3.0-rc2+2.3.0.tar.gz) = aa56f9a87584de6c96e8efd4598e74760febaac470bd4616d7ee22b0ac398e08
+SIZE (dahdi-freebsd-complete-2.3.0-rc2+2.3.0.tar.gz) = 2013326
diff --git a/misc/dahdi-kmod/files/patch-tools-Makefile b/misc/dahdi-kmod/files/patch-tools-Makefile
index 4cd89f5d414f..48028dd64066 100644
--- a/misc/dahdi-kmod/files/patch-tools-Makefile
+++ b/misc/dahdi-kmod/files/patch-tools-Makefile
@@ -1,5 +1,5 @@
---- tools/Makefile.orig 2009-11-04 22:36:21.000000000 +0600
-+++ tools/Makefile 2010-03-03 17:36:39.000000000 +0600
+--- tools/Makefile.orig 2010-04-01 22:45:47.000000000 +0700
++++ tools/Makefile 2010-06-01 17:18:37.000000000 +0700
@@ -27,7 +27,7 @@
endif
@@ -9,32 +9,16 @@
OPTFLAGS=-O2
CFLAGS+=-I. $(OPTFLAGS) -g -fPIC -Wall -DBUILDING_TONEZONE #-DTONEZONE_DRIVER
-@@ -229,13 +229,13 @@
+@@ -229,10 +229,8 @@
install -d $(DESTDIR)$(MAN_DIR)
install -m 644 $(MAN_PAGES) $(DESTDIR)$(MAN_DIR)/
endif
-ifeq (,$(wildcard $(DESTDIR)$(CONFIG_FILE)))
-- $(INSTALL) -D -m 644 system.conf.sample $(DESTDIR)$(CONFIG_FILE)
+- $(INSTALL) -d $(DESTDIR)$(CONFIG_DIR)
+- $(INSTALL) -m 644 system.conf.sample $(DESTDIR)$(CONFIG_FILE)
-endif
-+ $(INSTALL) -d -m755 $(DESTDIR)$(CONFIG_DIR)
-+ $(INSTALL) -m 644 system.conf.sample $(DESTDIR)$(CONFIG_DIR)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(CONFIG_DIR)
++ $(INSTALL) -m 644 system.conf.sample $(DESTDIR)$(CONFIG_FILE).sample
install-libs: libs
-- $(INSTALL) -D -m 755 $(LTZ_A) $(DESTDIR)$(LIB_DIR)/$(LTZ_A)
-- $(INSTALL) -D -m 755 $(LTZ_SO) $(DESTDIR)$(LIB_DIR)/$(LTZ_SO).$(LTZ_SO_MAJOR_VER).$(LTZ_SO_MINOR_VER)
-+ $(INSTALL) -d -m755 $(DESTDIR)$(LIB_DIR)
-+ $(INSTALL) -m 755 $(LTZ_A) $(DESTDIR)$(LIB_DIR)/$(LTZ_A)
-+ $(INSTALL) -m 755 $(LTZ_SO) $(DESTDIR)$(LIB_DIR)/$(LTZ_SO).$(LTZ_SO_MAJOR_VER).$(LTZ_SO_MINOR_VER)
- ifeq (,$(DESTDIR))
- if [ `id -u` = 0 ]; then \
- /sbin/ldconfig || : ;\
-@@ -260,7 +260,8 @@
- /sbin/restorecon -v $(DESTDIR)$(LIB_DIR)/$(LTZ_SO)
- endif
- endif
-- $(INSTALL) -D -m 644 tonezone.h $(DESTDIR)$(INC_DIR)/tonezone.h
-+ $(INSTALL) -d -m755 $(DESTDIR)$(INC_DIR)
-+ $(INSTALL) -m 644 tonezone.h $(DESTDIR)$(INC_DIR)/tonezone.h
-
- install-utils-subdirs:
- @for dir in $(SUBDIRS_UTILS); do \
+ $(INSTALL) -d -m 755 $(DESTDIR)/$(LIB_DIR)
diff --git a/misc/dahdi-kmod/files/patch-tools-dahdi_monitor.c b/misc/dahdi-kmod/files/patch-tools-dahdi_monitor.c
deleted file mode 100644
index b175aaf1199f..000000000000
--- a/misc/dahdi-kmod/files/patch-tools-dahdi_monitor.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- tools/dahdi_monitor.c.orig 2009-04-21 20:44:58.000000000 +0700
-+++ tools/dahdi_monitor.c 2010-03-03 17:24:25.000000000 +0600
-@@ -40,7 +40,11 @@
- #include <dahdi/user.h>
- #include "dahdi_tools_version.h"
-
-+#if defined(__FreeBSD__)
-+#include <sys/soundcard.h>
-+#else
- #include <linux/soundcard.h>
-+#endif
-
- /*
- * defines for file handle numbers
diff --git a/misc/dahdi-kmod/files/patch-tools-tonezone.c b/misc/dahdi-kmod/files/patch-tools-tonezone.c
deleted file mode 100644
index 66bb1c0034b9..000000000000
--- a/misc/dahdi-kmod/files/patch-tools-tonezone.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- tools/tonezone.c.orig 2008-08-06 06:43:02.000000000 +0700
-+++ tools/tonezone.c 2010-03-03 17:24:01.000000000 +0600
-@@ -46,6 +46,10 @@
- #define CLIP 32635
- #define BIAS 0x84
-
-+#ifndef ENODATA
-+#define ENODATA EINVAL
-+#endif
-+
- struct tone_zone *tone_zone_find(char *country)
- {
- struct tone_zone *z;
-@@ -440,7 +444,11 @@
- dump_tone_zone(h, MAX_SIZE - space);
- #endif
-
-+#if defined(__FreeBSD__)
-+ if ((res = ioctl(fd, DAHDI_LOADZONE, &h))) {
-+#else
- if ((res = ioctl(fd, DAHDI_LOADZONE, h))) {
-+#endif
- fprintf(stderr, "ioctl(DAHDI_LOADZONE) failed: %s\n", strerror(errno));
- return res;
- }
diff --git a/misc/dahdi-kmod/pkg-plist b/misc/dahdi-kmod/pkg-plist
index 92b324ba89ee..f64df1431013 100644
--- a/misc/dahdi-kmod/pkg-plist
+++ b/misc/dahdi-kmod/pkg-plist
@@ -3,6 +3,9 @@ include/dahdi/compat/types.h
include/dahdi/tonezone.h
include/dahdi/user.h
include/dahdi/wctdm_user.h
+lib/dahdi/dahdi-fw-hx8.bin.ko
+lib/dahdi/dahdi-fw-oct6114-064.bin.ko
+lib/dahdi/dahdi-fw-oct6114-128.bin.ko
lib/dahdi/dahdi.ko
lib/dahdi/dahdi_dynamic.ko
lib/dahdi/dahdi_dynamic_eth.ko
@@ -13,14 +16,17 @@ lib/dahdi/dahdi_echocan_kb1.ko
lib/dahdi/dahdi_echocan_mg2.ko
lib/dahdi/dahdi_echocan_sec.ko
lib/dahdi/dahdi_echocan_sec2.ko
-lib/dahdi/dahdi_fw_oct6114_064.ko
-lib/dahdi/dahdi_fw_oct6114_128.ko
lib/dahdi/dahdi_voicebus.ko
lib/dahdi/linker.hints
lib/dahdi/ng_dahdi_netdev.ko
lib/dahdi/wcb4xxp.ko
+lib/dahdi/wcfxo.ko
lib/dahdi/wct4xxp.ko
lib/dahdi/wctdm24xxp.ko
+%%X86%%%%WITH_EXPERIMENTAL%%lib/dahdi/dahdi_vpmadt032_loader.ko
+%%WITH_EXPERIMENTAL%%lib/dahdi/wctdm.ko
+%%WITH_EXPERIMENTAL%%lib/dahdi/wcte11xp.ko
+%%WITH_EXPERIMENTAL%%lib/dahdi/wcte12xp.ko
lib/libtonezone.a
lib/libtonezone.so
lib/libtonezone.so.1
@@ -28,6 +34,7 @@ lib/libtonezone.so.1.0
lib/libtonezone.so.2
lib/libtonezone.so.2.0
sbin/dahdi_cfg
+sbin/dahdi_maint
sbin/dahdi_monitor
sbin/dahdi_scan
sbin/dahdi_speed
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index 336e405c5532..f4541128e651 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 4
+PORTREVISION= 0
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fjoe
@@ -19,8 +19,8 @@ COMMENT= Digium/Asterisk Hardware Device Interface
BUILD_DEPENDS= gmake:${PORTSDIR}/devel/gmake
LIB_DEPENDS= newt.52:${PORTSDIR}/devel/newt
-DAHDI_VERSION= 2.2.1-rc2
-DAHDI_TOOLS_VERSION= 2.2.1.1-rc1
+DAHDI_VERSION= 2.3.0-rc2
+DAHDI_TOOLS_VERSION= 2.3.0
NO_PACKAGE= Should be in sync with the kernel to work correctly
GNU_CONFIGURE= yes
@@ -39,8 +39,23 @@ MAN8= dahdi_cfg.8\
dahdi_tool.8\
fxotune.8
+OPTIONS= EXPERIMENTAL "Enable experimental drivers" off
+
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+PLIST_SUB+= X86=""
+.else
+PLIST_SUB+= X86="@comment "
+.endif
+
+.if defined(WITH_EXPERIMENTAL)
+MAKE_FLAGS+= WITH_EXPERIMENTAL=yes
+PLIST_SUB+= WITH_EXPERIMENTAL=""
+.else
+PLIST_SUB+= WITH_EXPERIMENTAL="@comment "
+.endif
+
pre-everything::
@if [ ! -f /usr/src/sys/Makefile ]; then \
${ECHO_MSG} ">> The dahdi port needs FreeBSD kernel source code to compile."; \
diff --git a/misc/dahdi/distinfo b/misc/dahdi/distinfo
index b133f06bcd65..ba5f9996b6a6 100644
--- a/misc/dahdi/distinfo
+++ b/misc/dahdi/distinfo
@@ -1,3 +1,3 @@
-MD5 (dahdi-freebsd-complete-2.2.1-rc2+2.2.1.1-rc1.tar.gz) = fc3c1423336661545fa9218dda392732
-SHA256 (dahdi-freebsd-complete-2.2.1-rc2+2.2.1.1-rc1.tar.gz) = 3f02bb178e0e3fb39497ba5b1f44eba7e3ada0a83628ee649a5a90a1c9712973
-SIZE (dahdi-freebsd-complete-2.2.1-rc2+2.2.1.1-rc1.tar.gz) = 1984887
+MD5 (dahdi-freebsd-complete-2.3.0-rc2+2.3.0.tar.gz) = 3885e017536e75cd1cb2a210e6668970
+SHA256 (dahdi-freebsd-complete-2.3.0-rc2+2.3.0.tar.gz) = aa56f9a87584de6c96e8efd4598e74760febaac470bd4616d7ee22b0ac398e08
+SIZE (dahdi-freebsd-complete-2.3.0-rc2+2.3.0.tar.gz) = 2013326
diff --git a/misc/dahdi/files/patch-tools-Makefile b/misc/dahdi/files/patch-tools-Makefile
index 4cd89f5d414f..48028dd64066 100644
--- a/misc/dahdi/files/patch-tools-Makefile
+++ b/misc/dahdi/files/patch-tools-Makefile
@@ -1,5 +1,5 @@
---- tools/Makefile.orig 2009-11-04 22:36:21.000000000 +0600
-+++ tools/Makefile 2010-03-03 17:36:39.000000000 +0600
+--- tools/Makefile.orig 2010-04-01 22:45:47.000000000 +0700
++++ tools/Makefile 2010-06-01 17:18:37.000000000 +0700
@@ -27,7 +27,7 @@
endif
@@ -9,32 +9,16 @@
OPTFLAGS=-O2
CFLAGS+=-I. $(OPTFLAGS) -g -fPIC -Wall -DBUILDING_TONEZONE #-DTONEZONE_DRIVER
-@@ -229,13 +229,13 @@
+@@ -229,10 +229,8 @@
install -d $(DESTDIR)$(MAN_DIR)
install -m 644 $(MAN_PAGES) $(DESTDIR)$(MAN_DIR)/
endif
-ifeq (,$(wildcard $(DESTDIR)$(CONFIG_FILE)))
-- $(INSTALL) -D -m 644 system.conf.sample $(DESTDIR)$(CONFIG_FILE)
+- $(INSTALL) -d $(DESTDIR)$(CONFIG_DIR)
+- $(INSTALL) -m 644 system.conf.sample $(DESTDIR)$(CONFIG_FILE)
-endif
-+ $(INSTALL) -d -m755 $(DESTDIR)$(CONFIG_DIR)
-+ $(INSTALL) -m 644 system.conf.sample $(DESTDIR)$(CONFIG_DIR)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(CONFIG_DIR)
++ $(INSTALL) -m 644 system.conf.sample $(DESTDIR)$(CONFIG_FILE).sample
install-libs: libs
-- $(INSTALL) -D -m 755 $(LTZ_A) $(DESTDIR)$(LIB_DIR)/$(LTZ_A)
-- $(INSTALL) -D -m 755 $(LTZ_SO) $(DESTDIR)$(LIB_DIR)/$(LTZ_SO).$(LTZ_SO_MAJOR_VER).$(LTZ_SO_MINOR_VER)
-+ $(INSTALL) -d -m755 $(DESTDIR)$(LIB_DIR)
-+ $(INSTALL) -m 755 $(LTZ_A) $(DESTDIR)$(LIB_DIR)/$(LTZ_A)
-+ $(INSTALL) -m 755 $(LTZ_SO) $(DESTDIR)$(LIB_DIR)/$(LTZ_SO).$(LTZ_SO_MAJOR_VER).$(LTZ_SO_MINOR_VER)
- ifeq (,$(DESTDIR))
- if [ `id -u` = 0 ]; then \
- /sbin/ldconfig || : ;\
-@@ -260,7 +260,8 @@
- /sbin/restorecon -v $(DESTDIR)$(LIB_DIR)/$(LTZ_SO)
- endif
- endif
-- $(INSTALL) -D -m 644 tonezone.h $(DESTDIR)$(INC_DIR)/tonezone.h
-+ $(INSTALL) -d -m755 $(DESTDIR)$(INC_DIR)
-+ $(INSTALL) -m 644 tonezone.h $(DESTDIR)$(INC_DIR)/tonezone.h
-
- install-utils-subdirs:
- @for dir in $(SUBDIRS_UTILS); do \
+ $(INSTALL) -d -m 755 $(DESTDIR)/$(LIB_DIR)
diff --git a/misc/dahdi/files/patch-tools-dahdi_monitor.c b/misc/dahdi/files/patch-tools-dahdi_monitor.c
deleted file mode 100644
index b175aaf1199f..000000000000
--- a/misc/dahdi/files/patch-tools-dahdi_monitor.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- tools/dahdi_monitor.c.orig 2009-04-21 20:44:58.000000000 +0700
-+++ tools/dahdi_monitor.c 2010-03-03 17:24:25.000000000 +0600
-@@ -40,7 +40,11 @@
- #include <dahdi/user.h>
- #include "dahdi_tools_version.h"
-
-+#if defined(__FreeBSD__)
-+#include <sys/soundcard.h>
-+#else
- #include <linux/soundcard.h>
-+#endif
-
- /*
- * defines for file handle numbers
diff --git a/misc/dahdi/files/patch-tools-tonezone.c b/misc/dahdi/files/patch-tools-tonezone.c
deleted file mode 100644
index 66bb1c0034b9..000000000000
--- a/misc/dahdi/files/patch-tools-tonezone.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- tools/tonezone.c.orig 2008-08-06 06:43:02.000000000 +0700
-+++ tools/tonezone.c 2010-03-03 17:24:01.000000000 +0600
-@@ -46,6 +46,10 @@
- #define CLIP 32635
- #define BIAS 0x84
-
-+#ifndef ENODATA
-+#define ENODATA EINVAL
-+#endif
-+
- struct tone_zone *tone_zone_find(char *country)
- {
- struct tone_zone *z;
-@@ -440,7 +444,11 @@
- dump_tone_zone(h, MAX_SIZE - space);
- #endif
-
-+#if defined(__FreeBSD__)
-+ if ((res = ioctl(fd, DAHDI_LOADZONE, &h))) {
-+#else
- if ((res = ioctl(fd, DAHDI_LOADZONE, h))) {
-+#endif
- fprintf(stderr, "ioctl(DAHDI_LOADZONE) failed: %s\n", strerror(errno));
- return res;
- }
diff --git a/misc/dahdi/pkg-plist b/misc/dahdi/pkg-plist
index 92b324ba89ee..f64df1431013 100644
--- a/misc/dahdi/pkg-plist
+++ b/misc/dahdi/pkg-plist
@@ -3,6 +3,9 @@ include/dahdi/compat/types.h
include/dahdi/tonezone.h
include/dahdi/user.h
include/dahdi/wctdm_user.h
+lib/dahdi/dahdi-fw-hx8.bin.ko
+lib/dahdi/dahdi-fw-oct6114-064.bin.ko
+lib/dahdi/dahdi-fw-oct6114-128.bin.ko
lib/dahdi/dahdi.ko
lib/dahdi/dahdi_dynamic.ko
lib/dahdi/dahdi_dynamic_eth.ko
@@ -13,14 +16,17 @@ lib/dahdi/dahdi_echocan_kb1.ko
lib/dahdi/dahdi_echocan_mg2.ko
lib/dahdi/dahdi_echocan_sec.ko
lib/dahdi/dahdi_echocan_sec2.ko
-lib/dahdi/dahdi_fw_oct6114_064.ko
-lib/dahdi/dahdi_fw_oct6114_128.ko
lib/dahdi/dahdi_voicebus.ko
lib/dahdi/linker.hints
lib/dahdi/ng_dahdi_netdev.ko
lib/dahdi/wcb4xxp.ko
+lib/dahdi/wcfxo.ko
lib/dahdi/wct4xxp.ko
lib/dahdi/wctdm24xxp.ko
+%%X86%%%%WITH_EXPERIMENTAL%%lib/dahdi/dahdi_vpmadt032_loader.ko
+%%WITH_EXPERIMENTAL%%lib/dahdi/wctdm.ko
+%%WITH_EXPERIMENTAL%%lib/dahdi/wcte11xp.ko
+%%WITH_EXPERIMENTAL%%lib/dahdi/wcte12xp.ko
lib/libtonezone.a
lib/libtonezone.so
lib/libtonezone.so.1
@@ -28,6 +34,7 @@ lib/libtonezone.so.1.0
lib/libtonezone.so.2
lib/libtonezone.so.2.0
sbin/dahdi_cfg
+sbin/dahdi_maint
sbin/dahdi_monitor
sbin/dahdi_scan
sbin/dahdi_speed