aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-07-05 05:49:59 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-07-05 05:49:59 +0000
commit6313c635c662c01b28b0c33c2bc4fcf4ddc4af31 (patch)
tree549ee61c94546edc8217d1bd94e035942ce1f383 /misc
parent8a2f7b0bd7d1f2b5c215cbf1e39b4d1f9917b1cf (diff)
downloadports-6313c635c662c01b28b0c33c2bc4fcf4ddc4af31.tar.gz
ports-6313c635c662c01b28b0c33c2bc4fcf4ddc4af31.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/metromap/Makefile26
-rw-r--r--misc/metromap/distinfo2
-rw-r--r--misc/metromap/pkg-descr4
-rw-r--r--misc/metromap/pkg-plist24
5 files changed, 57 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 4a3660993cb6..5c5f15ce322b 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -296,6 +296,7 @@
SUBDIR += mc
SUBDIR += mc-light
SUBDIR += menushki
+ SUBDIR += metromap
SUBDIR += mgp-mode.el
SUBDIR += mime-support
SUBDIR += mirmon
diff --git a/misc/metromap/Makefile b/misc/metromap/Makefile
new file mode 100644
index 000000000000..b0b13f78b318
--- /dev/null
+++ b/misc/metromap/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: metromap
+# Date created: 2005-07-01
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metromap
+PORTVERSION= 0.1.0
+CATEGORIES= misc
+MASTER_SITES= http://metromap.antex.ru/
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= A simple application for finding paths in different subways maps
+
+USE_PYTHON= yes
+USE_GNOME= pygtk2
+USE_BZIP2= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr,${PREFIX},' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,/usr/bin/python,${SETENV} python,' ${WRKSRC}/metromap.py
+
+.include <bsd.port.mk>
diff --git a/misc/metromap/distinfo b/misc/metromap/distinfo
new file mode 100644
index 000000000000..e9f60dbd7e17
--- /dev/null
+++ b/misc/metromap/distinfo
@@ -0,0 +1,2 @@
+MD5 (metromap-0.1.0.tar.bz2) = aa9b0256d42427a081eb064c3ec020e0
+SIZE (metromap-0.1.0.tar.bz2) = 76362
diff --git a/misc/metromap/pkg-descr b/misc/metromap/pkg-descr
new file mode 100644
index 000000000000..61bd270d2f73
--- /dev/null
+++ b/misc/metromap/pkg-descr
@@ -0,0 +1,4 @@
+Metromap is a simple pygtk+2 programm for finding pathes in metro(subway) maps.
+Maps for Moscow, St. Petersburg, Kiev, London and Berlin are included.
+
+WWW: http://metromap.antex.ru/
diff --git a/misc/metromap/pkg-plist b/misc/metromap/pkg-plist
new file mode 100644
index 000000000000..0d1278097caf
--- /dev/null
+++ b/misc/metromap/pkg-plist
@@ -0,0 +1,24 @@
+bin/metromap
+share/locale/ru/LC_MESSAGES/metromap.mo
+%%DATADIR%%/data/Berlin/Metro.ini
+%%DATADIR%%/data/KievUkr/Metro.ini
+%%DATADIR%%/data/London/Metro.ini
+%%DATADIR%%/data/Metro.ini
+%%DATADIR%%/data/Moscow/Metro.ini
+%%DATADIR%%/data/Peterburg/Metro.ini
+%%DATADIR%%/modules/FindPath.py
+%%DATADIR%%/modules/FindPath.pyc
+%%DATADIR%%/modules/Interface.py
+%%DATADIR%%/modules/Interface.pyc
+%%DATADIR%%/modules/MapDisplay.py
+%%DATADIR%%/modules/MapDisplay.pyc
+%%DATADIR%%/modules/ReadMap.py
+%%DATADIR%%/modules/ReadMap.pyc
+@dirrm %%DATADIR%%/data/Berlin
+@dirrm %%DATADIR%%/data/KievUkr
+@dirrm %%DATADIR%%/data/London
+@dirrm %%DATADIR%%/data/Moscow
+@dirrm %%DATADIR%%/data/Peterburg
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/modules
+@dirrm %%DATADIR%%