aboutsummaryrefslogtreecommitdiff
path: root/multimedia/aegisub
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-11 08:56:05 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-11 08:56:05 +0000
commit80952d35e99278b4740ed2300c0dab43bec58246 (patch)
tree72343604d80cec644e7488b63ff7ca575af3ccad /multimedia/aegisub
parent386aaf550f0a6b0a263be792a61de434568d0050 (diff)
downloadports-80952d35e99278b4740ed2300c0dab43bec58246.tar.gz
ports-80952d35e99278b4740ed2300c0dab43bec58246.zip
Notes
Diffstat (limited to 'multimedia/aegisub')
-rw-r--r--multimedia/aegisub/Makefile110
-rw-r--r--multimedia/aegisub/distinfo3
-rw-r--r--multimedia/aegisub/pkg-descr6
-rw-r--r--multimedia/aegisub/pkg-plist72
4 files changed, 191 insertions, 0 deletions
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
new file mode 100644
index 000000000000..3ac3c7deb9d7
--- /dev/null
+++ b/multimedia/aegisub/Makefile
@@ -0,0 +1,110 @@
+# New ports collection makefile for: aegisub
+# Date created: 2nd March 2010
+# Whom: Leinier Cruz Salfran <salfrancl@yahoo.es>
+#
+# $FreeBSD$
+# $MCom: ports-stable/multimedia/aegisub/Makefile,v 0.14 2010/03/10 17:02:00 salfrancl Exp $
+# $Id: Makefile,v 0.14 2010/03/10 17:02:00 salfrancl Exp $
+#
+
+PORTNAME= aegisub
+PORTVERSION= 2.1.8
+CATEGORIES= multimedia
+MASTER_SITES= http://ftp.aegisub.org/pub/releases/ \
+ http://ftp2.aegisub.org/pub/releases/ \
+ ftp://ftp.aegisub.org/pub/releases/ \
+ ftp://ftp2.aegisub.org/pub/releases/
+
+MAINTAINER= salfrancl@yahoo.es
+COMMENT= Aegisub Project is a cross-platform subtitle editor
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config \
+ intltoolize:${PORTSDIR}/textproc/intltool \
+ ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig
+
+OPTIONS= DEBUG "Enable debug" Off \
+ PROFILE "Enable profiling" Off \
+ GCOV "Enable GCOV (require profiling)" Off \
+ EFENCE "Enable Electric Fence (require profiling)" Off \
+ NLS "Enable Native Language Support" On \
+ PORTAUDIO "Enable PortAudio2 audio provider (only one)" Off \
+ PULSE "Enable PulseAudio audio provider (only one)" On \
+ OSS "Enable OSS audio player (require portaudio)" Off \
+ FFMPEG "Enable FFMPEG video provider" On \
+ HUNSPELL "Hungarian Spell" On \
+ LUA "LUA Scripting" On \
+ PERL "Perl Scripting" On
+
+USE_FREETYPE2= yes
+USE_ICONV= yes
+USE_WX= 2.8
+WX_COMPS= wx contrib
+WX_UNICODE= yes
+CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include \
+ -I${LOCALBASE}/lib/wx/include/gtk2-unicode-release-2.8/ \
+ -I${LOCALBASE}/include/wx-2.8 \
+ -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+INSTALLS_ICONS= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug --enable-debug-exceptions
+.endif
+.if defined(WITH_GCOV)
+CONFIGURE_ARGS+= --enable-gcov
+WITH_PROFILE= yes
+.endif
+.if defined(WITH_EFENCE)
+CONFIGURE_ARGS+= --enable-efence
+WITH_PROFILE= yes
+.endif
+.if defined(WITH_PROFILE)
+CONFIGURE_ARGS+= --enable-profile
+.endif
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --without-nls
+.else
+USE_GETTEXT= yes
+.endif
+.if defined(WITH_PORTAUDIO)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/portaudio-2.0.pc:${PORTSDIR}/audio/portaudio2
+.endif
+.if defined(WITH_PULSE)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libpulse.pc:${PORTSDIR}/audio/pulseaudio
+.endif
+.if defined(WITH_OSS)
+BUILD_DEPENDS+= ossinfo:${PORTSDIR}/audio/oss
+.endif
+.if defined(WITH_PULSE)
+CONFIGURE_ARGS+= --with-player-audio=pulseaudio
+.else
+.if defined(WITH_OSS)
+CONFIGURE_ARGS+= --with-player-audio=portaudio
+.endif
+.endif
+.if defined(WITH_FFMPEG)
+BUILD_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+= --with-provider-video=ffmpegsource --with-provider-audio=ffmpegsource
+.endif
+.if defined(WITH_HUNSPELL)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/hunspell.pc:${PORTSDIR}/hungarian/hunspell
+.endif
+.if defined(WITH_LUA)
+USE_LUA= 5.1+
+CONFIGURE_ENV+= LUA_CFLAGS="-I${LUA_INCDIR}" LUA_LDFLAGS="-L${LUA_LIBDIR} -llua"
+.endif
+.if defined(WITH_PERL)
+uSE_PERL5= yes
+CONFIGURE_ARGS+= --with-perl
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/aegisub/distinfo b/multimedia/aegisub/distinfo
new file mode 100644
index 000000000000..3b8c9a530f49
--- /dev/null
+++ b/multimedia/aegisub/distinfo
@@ -0,0 +1,3 @@
+MD5 (aegisub-2.1.8.tar.gz) = 04438f9c237618d225d3654cded3d4bb
+SHA256 (aegisub-2.1.8.tar.gz) = a67356e5c4fa376738d363f1cf5e50aa74e6b69e76a089ed0442bf6d7390d769
+SIZE (aegisub-2.1.8.tar.gz) = 2431099
diff --git a/multimedia/aegisub/pkg-descr b/multimedia/aegisub/pkg-descr
new file mode 100644
index 000000000000..c0220c8b6f4a
--- /dev/null
+++ b/multimedia/aegisub/pkg-descr
@@ -0,0 +1,6 @@
+The Aegisub Project is a community-driven effort to write the BSDL licensed
+cross-platform subtitle editor Aegisub. Composed completely of volunteers
+passionate about subtitling, as a project it strives to be open, fair and
+most of all: free.
+
+WWW: http://www.aegisub.org/
diff --git a/multimedia/aegisub/pkg-plist b/multimedia/aegisub/pkg-plist
new file mode 100644
index 000000000000..20e1039a0a5b
--- /dev/null
+++ b/multimedia/aegisub/pkg-plist
@@ -0,0 +1,72 @@
+bin/aegisub-2.1
+%%DATADIR%%/2.1/automation/autoload/cleantags-autoload.lua
+%%DATADIR%%/2.1/automation/autoload/kara-templater.lua
+%%DATADIR%%/2.1/automation/autoload/karaoke-auto-leadin.lua
+%%DATADIR%%/2.1/automation/autoload/macro-1-edgeblur.lua
+%%DATADIR%%/2.1/automation/autoload/macro-1p-edgeblur.pl
+%%DATADIR%%/2.1/automation/autoload/macro-2-mkfullwitdh.lua
+%%DATADIR%%/2.1/automation/include/Aegisub.pm
+%%DATADIR%%/2.1/automation/include/Aegisub/PerlConsole.pm
+%%DATADIR%%/2.1/automation/include/Aegisub/Progress.pm
+%%DATADIR%%/2.1/automation/include/Aegisub/Script.pm
+%%DATADIR%%/2.1/automation/include/Auto4Utils.pm
+%%DATADIR%%/2.1/automation/include/cleantags.lua
+%%DATADIR%%/2.1/automation/include/karaskel-adv.lua
+%%DATADIR%%/2.1/automation/include/karaskel-auto4.lua
+%%DATADIR%%/2.1/automation/include/karaskel-base.lua
+%%DATADIR%%/2.1/automation/include/karaskel.lua
+%%DATADIR%%/2.1/automation/include/unicode.lua
+%%DATADIR%%/2.1/automation/include/utils-auto4.lua
+%%DATADIR%%/2.1/automation/include/utils.lua
+share/applications/aegisub.desktop
+%%DOCSDIR%%/2.1/automation3.txt
+%%DOCSDIR%%/2.1/demos/future-windy-blur.lua
+%%DOCSDIR%%/2.1/demos/perl-console.pl
+%%DOCSDIR%%/2.1/demos/raytracer-test1.ass
+%%DOCSDIR%%/2.1/demos/raytracer.lua
+%%DOCSDIR%%/2.1/v4-docs/basic-function-interface.txt
+%%DOCSDIR%%/2.1/v4-docs/configuration-dialogs.txt
+%%DOCSDIR%%/2.1/v4-docs/file-streams.txt
+%%DOCSDIR%%/2.1/v4-docs/misc.txt
+%%DOCSDIR%%/2.1/v4-docs/overview.txt
+%%DOCSDIR%%/2.1/v4-docs/perl-api.txt
+%%DOCSDIR%%/2.1/v4-docs/progress-reporting.txt
+%%DOCSDIR%%/2.1/v4-docs/subtitle-data.txt
+%%DOCSDIR%%/2.1/v4-docs/template-scripting-ideas.ass
+share/icons/hicolor/16x16/apps/aegisub.png
+share/icons/hicolor/22x22/apps/aegisub.png
+share/icons/hicolor/24x24/apps/aegisub.png
+share/icons/hicolor/32x32/apps/aegisub.png
+share/icons/hicolor/48x48/apps/aegisub.png
+share/icons/hicolor/64x64/apps/aegisub.png
+share/icons/hicolor/scalable/apps/aegisub.svg
+share/locale/ca/LC_MESSAGES/aegisub21.mo
+share/locale/cs/LC_MESSAGES/aegisub21.mo
+share/locale/da/LC_MESSAGES/aegisub21.mo
+share/locale/de/LC_MESSAGES/aegisub21.mo
+share/locale/el/LC_MESSAGES/aegisub21.mo
+share/locale/es/LC_MESSAGES/aegisub21.mo
+share/locale/fi/LC_MESSAGES/aegisub21.mo
+share/locale/fr_FR/LC_MESSAGES/aegisub21.mo
+share/locale/hu/LC_MESSAGES/aegisub21.mo
+share/locale/it/LC_MESSAGES/aegisub21.mo
+share/locale/ja/LC_MESSAGES/aegisub21.mo
+share/locale/ko/LC_MESSAGES/aegisub21.mo
+share/locale/pt_BR/LC_MESSAGES/aegisub21.mo
+share/locale/ru/LC_MESSAGES/aegisub21.mo
+share/locale/vi/LC_MESSAGES/aegisub21.mo
+share/locale/zh_CN/LC_MESSAGES/aegisub21.mo
+share/locale/zh_TW/LC_MESSAGES/aegisub21.mo
+@dirrmtry share/applications
+@dirrmtry share/icons/hicolor
+@dirrmtry share/locale
+@dirrmtry %%DATADIR%%/2.1/automation/autoload
+@dirrmtry %%DATADIR%%/2.1/automation/include/Aegisub
+@dirrmtry %%DATADIR%%/2.1/automation/include
+@dirrmtry %%DATADIR%%/2.1/automation
+@dirrmtry %%DATADIR%%/2.1
+@dirrmtry %%DATADIR%%
+@dirrmtry %%DOCSDIR%%/2.1/demos
+@dirrmtry %%DOCSDIR%%/2.1/v4-docs
+@dirrmtry %%DOCSDIR%%/2.1
+@dirrmtry %%DOCSDIR%%