aboutsummaryrefslogtreecommitdiff
path: root/multimedia/aravis
diff options
context:
space:
mode:
authorIvan Rozhuk <rozhuk.im@gmail.com>2022-01-14 12:45:40 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-02-17 09:31:41 +0000
commit7d0f2b043d4e9d0156a9f98eec740a69193b7ff2 (patch)
tree6bcc494d7c141cad3e0a1044317f3dd860077802 /multimedia/aravis
parent0f4d99434769d6db82fccb07c9b2398ee06262cf (diff)
Diffstat (limited to 'multimedia/aravis')
-rw-r--r--multimedia/aravis/Makefile34
-rw-r--r--multimedia/aravis/distinfo6
-rw-r--r--multimedia/aravis/files/patch-Makefile.am41
-rw-r--r--multimedia/aravis/pkg-plist45
4 files changed, 49 insertions, 77 deletions
diff --git a/multimedia/aravis/Makefile b/multimedia/aravis/Makefile
index c510430496c5..b8da0c3824bf 100644
--- a/multimedia/aravis/Makefile
+++ b/multimedia/aravis/Makefile
@@ -1,8 +1,7 @@
# Created by: Rozhuk Ivan rozhuk.im@gmail.com
PORTNAME= aravis
-DISTVERSIONPREFIX= ARAVIS_
-DISTVERSION= 0_5_12
+DISTVERSION= 0.8.20
CATEGORIES= multimedia
MAINTAINER= rozhuk.im@gmail.com
@@ -11,31 +10,26 @@ COMMENT= Camera control and image acquisition viewer
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
-CONFLICTS_INSTALL= ${PORTNAME}*
-
-LIB_DEPENDS+= libaravis-0.6.so:devel/libaravis \
+LIB_DEPENDS= libaravis-0.8.so:devel/libaravis \
libnotify.so:devel/libnotify
-USES= autoreconf gettext gmake gnome libtool pkgconfig
+USES= gettext gnome meson pkgconfig
USE_GNOME= cairo glib20 intltool gtk30
USE_GSTREAMER1= yes
-GNU_CONFIGURE= yes
-# USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= AravisProject
-CONFIGURE_ARGS= --enable-packet-socket=no --enable-viewer=yes \
- --enable-gst-plugin=no --enable-gst-0.10-plugin=no \
- --enable-gtk-doc=no --enable-cpp-test=no \
- --enable-usb=no --enable-zlib-pc=yes
-MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
-
-pre-configure:
- ${ECHO_CMD} "EXTRA_DIST =" >> ${WRKSRC}/gtk-doc.make
- @${REINPLACE_CMD} -e 's|GTK_DOC_CHECK(\[1.14\],\[--flavour no-tmpl\])||' \
- ${WRKSRC}/configure.ac
- @${REINPLACE_CMD} -e 's|^arv_viewer_LDADD.*=.*|arv_viewer_LDADD = $${ARAVIS_VIEWER_LIBS} -laravis-0.6|' \
- ${WRKSRC}/viewer/Makefile.am
+MESON_ARGS= -Dpacket-socket=disabled -Dviewer=enabled \
+ -Ddocumentation=disabled -Dintrospection=disabled \
+ -Dgst-plugin=disabled -Dtests=false -Dusb=disabled
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|subdir ('src')|aravis_dependencies += dependency ('aravis-0.8', version: '>=0.8', required: true)|g" \
+ -e 's|meson.override_dependency.*||g' \
+ ${WRKSRC}/meson.build
+ @${REINPLACE_CMD} -e "s|.*aravis_library.*||g" \
+ -e "s|library_inc|include_directories('../src')|g" \
+ ${WRKSRC}/viewer/meson.build
.include <bsd.port.mk>
diff --git a/multimedia/aravis/distinfo b/multimedia/aravis/distinfo
index 8c2351305e2b..030dd9c96551 100644
--- a/multimedia/aravis/distinfo
+++ b/multimedia/aravis/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526106632
-SHA256 (AravisProject-aravis-ARAVIS_0_5_12_GH0.tar.gz) = 61467edecb96f7d315770f8d874860e42b2981200edb8bba879f46ec9a83e0b2
-SIZE (AravisProject-aravis-ARAVIS_0_5_12_GH0.tar.gz) = 2986578
+TIMESTAMP = 1641829020
+SHA256 (AravisProject-aravis-0.8.20_GH0.tar.gz) = d8d15970a08538f1c61372a378750451c03856184b60dd6d8c657dca23690135
+SIZE (AravisProject-aravis-0.8.20_GH0.tar.gz) = 950371
diff --git a/multimedia/aravis/files/patch-Makefile.am b/multimedia/aravis/files/patch-Makefile.am
deleted file mode 100644
index c3a76c43e8bf..000000000000
--- a/multimedia/aravis/files/patch-Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
---- Makefile.am.orig 2018-05-03 12:25:25 UTC
-+++ Makefile.am
-@@ -6,7 +6,7 @@ ACLOCAL_AMFLAGS = -I m4
-
- DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-gtk-doc --enable-gst-plugin --enable-gst-0.10-plugin --enable-viewer --enable-cpp-test --enable-appstream-util
-
--SUBDIRS = src man
-+SUBDIRS = man
-
- if ARAVIS_BUILD_VIEWER
- SUBDIRS += viewer
-@@ -20,16 +20,9 @@ if ARAVIS_BUILD_GST_0_10_PLUGIN
- SUBDIRS += gst-0.10
- endif
-
--SUBDIRS += tests po docs
-
--aravisdocdir = ${docdir}/aravis-@ARAVIS_API_VERSION@
--aravisdoc_DATA = \
-- README.md \
-- COPYING \
-- ChangeLog \
-- AUTHORS \
-- NEWS
-
-+
- EXTRA_DIST += m4/introspection.m4 README.md
-
- # Copy all the spec files. Of cource, only one is actually used.
-@@ -40,11 +33,5 @@ dist-hook:
- fi \
- done
-
--pkgconfigdir = $(libdir)/pkgconfig
--pkgconfig_DATA = aravis-@ARAVIS_API_VERSION@.pc
-
--CLEANFILES = $(pkgconfig_DATA)
--
--%-@ARAVIS_API_VERSION@.pc: %.pc
-- cp $< $@
-
diff --git a/multimedia/aravis/pkg-plist b/multimedia/aravis/pkg-plist
index 1198efe13905..9244a5cccb64 100644
--- a/multimedia/aravis/pkg-plist
+++ b/multimedia/aravis/pkg-plist
@@ -1,13 +1,32 @@
-bin/arv-viewer
-man/man1/arv-tool-0.6.1.gz
-man/man1/arv-viewer.1.gz
-share/appdata/arv-viewer.appdata.xml
-share/applications/arv-viewer.desktop
-%%DATADIR%%-0.6/arv-viewer.ui
-share/icons/hicolor/22x22/apps/aravis.png
-share/icons/hicolor/256x256/apps/aravis.png
-share/icons/hicolor/32x32/apps/aravis.png
-share/icons/hicolor/48x48/apps/aravis.png
-share/icons/hicolor/scalable/devices/aravis-fake-symbolic.svg
-share/icons/hicolor/scalable/devices/aravis-gigevision-symbolic.svg
-share/icons/hicolor/scalable/devices/aravis-usb3vision-symbolic.svg
+bin/arv-viewer-0.8
+share/applications/arv-viewer-0.8.desktop
+share/icons/hicolor/128x128/apps/aravis-0.8.png
+share/icons/hicolor/22x22/apps/aravis-0.8.png
+share/icons/hicolor/256x256/apps/aravis-0.8.png
+share/icons/hicolor/32x32/apps/aravis-0.8.png
+share/icons/hicolor/48x48/apps/aravis-0.8.png
+share/locale/bs/LC_MESSAGES/aravis-0.8.mo
+share/locale/ca/LC_MESSAGES/aravis-0.8.mo
+share/locale/cs/LC_MESSAGES/aravis-0.8.mo
+share/locale/da/LC_MESSAGES/aravis-0.8.mo
+share/locale/de/LC_MESSAGES/aravis-0.8.mo
+share/locale/el/LC_MESSAGES/aravis-0.8.mo
+share/locale/es/LC_MESSAGES/aravis-0.8.mo
+share/locale/eu/LC_MESSAGES/aravis-0.8.mo
+share/locale/fi/LC_MESSAGES/aravis-0.8.mo
+share/locale/fr/LC_MESSAGES/aravis-0.8.mo
+share/locale/hu/LC_MESSAGES/aravis-0.8.mo
+share/locale/id/LC_MESSAGES/aravis-0.8.mo
+share/locale/lv/LC_MESSAGES/aravis-0.8.mo
+share/locale/oc/LC_MESSAGES/aravis-0.8.mo
+share/locale/pl/LC_MESSAGES/aravis-0.8.mo
+share/locale/pt/LC_MESSAGES/aravis-0.8.mo
+share/locale/pt_BR/LC_MESSAGES/aravis-0.8.mo
+share/locale/ru/LC_MESSAGES/aravis-0.8.mo
+share/locale/sl/LC_MESSAGES/aravis-0.8.mo
+share/locale/sr/LC_MESSAGES/aravis-0.8.mo
+share/locale/sr@latin/LC_MESSAGES/aravis-0.8.mo
+share/locale/sv/LC_MESSAGES/aravis-0.8.mo
+share/locale/tr/LC_MESSAGES/aravis-0.8.mo
+share/locale/zh_CN/LC_MESSAGES/aravis-0.8.mo
+share/metainfo/arv-viewer-0.8.appdata.xml