aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious-plugins/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2008-03-02 18:05:01 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2008-03-02 18:05:01 +0000
commitf4a98f46cdad64c920bacf4c16ec07bd9563bca2 (patch)
tree3d2247c6d2e5c8962e39deee45e8ea1b9962b918 /multimedia/audacious-plugins/Makefile
parent7f0781fd59fab27b325c692e091d1ea7e03336fa (diff)
downloadports-f4a98f46cdad64c920bacf4c16ec07bd9563bca2.tar.gz
ports-f4a98f46cdad64c920bacf4c16ec07bd9563bca2.zip
Notes
Diffstat (limited to 'multimedia/audacious-plugins/Makefile')
-rw-r--r--multimedia/audacious-plugins/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index af158cac371d..a48514d1fb83 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -36,6 +36,7 @@ PORTDOCS= AUTHORS ChangeLog NEWS
# PROJECTM "Enable projectM vis plugin" off \
OPTIONS= AUDIOCD "Enable audiocd plugin" off \
+ DBUS "Enable dbus support" on \
ESOUND "Enable Esound output output" off \
MP3 "Enable mp3 plugin" on \
ROCKLIGHT "Enable Rocklight vis plugin" on \
@@ -78,6 +79,15 @@ CONFIGURE_ARGS+=--disable-cdaudio
PLIST_SUB+= AUDIOCDPLUGIN="@comment "
.endif
+.if !defined(WITHOUT_DBUS)
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+CONFIGURE_ARGS+=--enable-dbus --enable-gnomeshortcuts
+PLIST_SUB+= DBUS=""
+.else
+CONFIGURE_ARGS+=--disable-dbus --disable-gnomeshortcuts
+PLIST_SUB+= DBUS="@comment "
+.endif
+
.if defined(WITH_ESOUND)
USE_GNOME+= esound
CONFIGURE_ARGS+=--enable-esd