aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious-plugins
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2009-05-21 07:47:01 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2009-05-21 07:47:01 +0000
commit3b298f63e2a0b108163eb40bef94a92cf61c01f8 (patch)
treecfb37372049a1519d3675c6afcf307f2e53afaea /multimedia/audacious-plugins
parent57ba50801d1f3def96bd6f0a4a8fe3c7f7e704b9 (diff)
downloadports-3b298f63e2a0b108163eb40bef94a92cf61c01f8.tar.gz
ports-3b298f63e2a0b108163eb40bef94a92cf61c01f8.zip
Notes
Diffstat (limited to 'multimedia/audacious-plugins')
-rw-r--r--multimedia/audacious-plugins/Makefile42
-rw-r--r--multimedia/audacious-plugins/distinfo6
-rw-r--r--multimedia/audacious-plugins/pkg-plist24
3 files changed, 44 insertions, 28 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index c18dd098f6e9..9c5c7460fa50 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= audacious-plugins
-PORTVERSION= 1.5.1
-PORTREVISION= 2
+PORTVERSION= 2.0.1
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.atheme.org/
EXTRACT_SUFX= .tgz
@@ -15,8 +14,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= oliver@FreeBSD.org
COMMENT= Plugins needed for audacious
-BUILD_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious
-
+BUILD_DEPENDS= audacious2:${PORTSDIR}/multimedia/audacious
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
@@ -55,7 +54,6 @@ OPTIONS= DBUS "Enable dbus support" on \
MPC "Enable musepack input plugin" off \
WMA "Enable wma plugin" on \
JACK "Enable jack output plugin" off \
- ARTS "Enable arts output plugin" off \
SID "Enable sid input plugin" off \
OSS "Enable OSS output plugin" on \
OSS4 "Enable OSS4 output plugin" off \
@@ -68,13 +66,13 @@ OPTIONS= DBUS "Enable dbus support" on \
XSPF "Enable XSPF support" on \
TTA "Enable TrueAudio plugin" on \
GNOME "Build with gnomevfs/gconf support" off \
- NLS "Native Language Support" on \
+ NLS "Native Language Support" on \
CURL "curl for lastfm/scrobbler support" off
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_DBUS)
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus --enable-gnomeshortcuts
PLIST_SUB+= DBUS=""
.else
@@ -98,10 +96,10 @@ PLIST_SUB+= ESDPLUGIN="@comment "
.if !defined(WITHOUT_MP3)
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
-CONFIGURE_ARGS+=--enable-mad
+CONFIGURE_ARGS+=--enable-libmad
PLIST_SUB+= MP3PLUGIN=""
.else
-CONFIGURE_ARGS+=--disable-mad
+CONFIGURE_ARGS+=--disable-libmad
PLIST_SUB+= MP3PLUGIN="@comment "
.endif
@@ -248,15 +246,8 @@ CONFIGURE_ARGS+=--disable-jack
PLIST_SUB+= JACKPLUGIN="@comment "
.endif
-.if defined(WITH_ARTS)
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
-CONFIGURE_ARGS+=--enable-arts
-PLIST_SUB+= ARTSPLUGIN=""
-.else
-CONFIGURE_ARGS+=--disable-arts
-PLIST_SUB+= ARTSPLUGIN="@comment "
-.endif
-
+#OSS4 only works with recent changed in HEAD
+.if ${OSVERSION} >= 800061
.if !defined(WITHOUT_OSS)
PLIST_SUB+= OSSPLUGIN=""
CONFIGURE_ARGS+=--enable-oss
@@ -272,6 +263,17 @@ CONFIGURE_ARGS+=--enable-oss4
PLIST_SUB+= OSS4PLUGIN="@comment "
CONFIGURE_ARGS+=--disable-oss4
.endif
+.else
+PLIST_SUB+= OSS4PLUGIN="@comment "
+CONFIGURE_ARGS+=--disable-oss4
+.if defined(WITH_OSS) || defined(WITH_OSS4)
+PLIST_SUB+= OSSPLUGIN=""
+CONFIGURE_ARGS+=--enable-oss
+.else
+PLIST_SUB+= OSSPLUGIN="@comment "
+CONFIGURE_ARGS+=--disable-oss
+.endif
+.endif
.if defined(WITH_SID)
LIB_DEPENDS+= sidplay.1:${PORTSDIR}/audio/libsidplay
@@ -283,7 +285,7 @@ CONFIGURE_ARGS+=--disable-sid
.endif
.if !defined(WITHOUT_TIMIDITY)
-RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity
+RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity
CONFIGURE_ARGS+=--enable-timidity
PLIST_SUB+= TIMIDITYPLUGIN=""
.else
@@ -364,7 +366,7 @@ CONFIGURE_ARGS+=--enable-gnome-vfs --enable-gconf
.endif
.if !defined(WITHOUT_CURL) || exists(${LOCALBASE}/lib/libcurl.so)
-LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
PLIST_SUB+= CURLPLUGIN=""
.else
PLIST_SUB+= CURLPLUGIN="@comment "
diff --git a/multimedia/audacious-plugins/distinfo b/multimedia/audacious-plugins/distinfo
index 43bb1fc8218d..757bcd392687 100644
--- a/multimedia/audacious-plugins/distinfo
+++ b/multimedia/audacious-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (audacious-plugins-1.5.1.tgz) = 057b91f33aaf06bb4cde7260177c2f5f
-SHA256 (audacious-plugins-1.5.1.tgz) = aed33732c55566604a24cd2cd1751c24d159ff8eca510647c5c3c7889fd8ae15
-SIZE (audacious-plugins-1.5.1.tgz) = 2944448
+MD5 (audacious-plugins-2.0.1.tgz) = 5de2767d232e8f9f84fbd15d3b960f8b
+SHA256 (audacious-plugins-2.0.1.tgz) = 3279a2160d026c16828a850dd2d0b289bd69569c3a8ad6e060c6673b5d8cf648
+SIZE (audacious-plugins-2.0.1.tgz) = 3505273
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
index 32b5955448bc..2ccf131b528c 100644
--- a/multimedia/audacious-plugins/pkg-plist
+++ b/multimedia/audacious-plugins/pkg-plist
@@ -1,4 +1,3 @@
-%%ARTSPLUGIN%%bin/audacious-arts-helper
lib/audacious/Container/m3u.so
lib/audacious/Container/pls.so
%%XSPFPLUGIN%%lib/audacious/Container/xspf.so
@@ -15,14 +14,17 @@ lib/audacious/General/alarm.so
lib/audacious/General/hotkey.so
%%LIRCPLUGIN%%lib/audacious/General/lirc.so
%%CURLPLUGIN%%lib/audacious/General/scrobbler.so
+lib/audacious/General/skins.so
lib/audacious/General/song_change.so
-lib/audacious/General/statusicon.so
+%%STATUSICONPLUGIN%%lib/audacious/General/statusicon.so
+lib/audacious/General/streambrowser.so
+lib/audacious/General/vfstrace.so
%%AACPLUGIN%%lib/audacious/Input/aac.so
%%ADPLUGPLUGIN%%lib/audacious/Input/adplug.so
lib/audacious/Input/alac.so
%%CDAUDIOPLUGIN%%lib/audacious/Input/cdaudio-ng.so
+lib/audacious/Input/cuesheet_ng.so
lib/audacious/Input/console.so
-lib/audacious/Input/cuesheet.so
lib/audacious/Input/demac.so
%%FLACPLUGIN%%lib/audacious/Input/flacng.so
%%MP3PLUGIN%%lib/audacious/Input/madplug.so
@@ -30,8 +32,10 @@ lib/audacious/Input/metronom.so
%%MODPLUG%%lib/audacious/Input/modplug.so
%%MTPPLUGIN%%lib/audacious/General/mtp_up.so
%%MPCPLUGIN%%lib/audacious/Input/musepack.so
+lib/audacious/Input/psf2.so
lib/audacious/Input/sexypsf.so
%%SIDPLUGIN%%lib/audacious/Input/sid.so
+%%SNDFILEPLUGIN%%lib/audacious/Input/sndfile.so
%%TIMIDITYPLUGIN%%lib/audacious/Input/timidity.so
lib/audacious/Input/tonegen.so
%%TTAPLUGIN%%lib/audacious/Input/tta.so
@@ -39,16 +43,18 @@ lib/audacious/Input/tonegen.so
lib/audacious/Input/vtx.so
%%WAVPACKPLUGIN%%lib/audacious/Input/wavpack.so
%%WMAPLUGIN%%lib/audacious/Input/wma.so
+lib/audacious/Input/xsf.so
%%OSSPLUGIN%%lib/audacious/Output/OSS.so
%%OSS4PLUGIN%%lib/audacious/Output/OSS4.so
%%ESDPLUGIN%%lib/audacious/Output/ESD.so
-%%ARTSPLUGIN%%lib/audacious/Output/arts.so
+lib/audacious/Output/crossfade.so
lib/audacious/Output/filewriter.so
%%JACKPLUGIN%%lib/audacious/Output/jackout.so
lib/audacious/Output/null.so
+lib/audacious/Transport/gio.so
%%CURLPLUGIN%%lib/audacious/Transport/lastfm.so
+%%MMSPLUGIN%%lib/audacious/Transport/mms.so
%%NEONPLUGIN%%lib/audacious/Transport/neon.so
-lib/audacious/Transport/stdio.so
lib/audacious/Visualization/blur_scope.so
%%PARANORMALPLUGIN%%lib/audacious/Visualization/paranormal.so
%%ROCKLIGHTPLUGIN%%lib/audacious/Visualization/rocklight.so
@@ -88,6 +94,13 @@ lib/audacious/Visualization/spectrum.so
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/nenolod_-_worms.pnv
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/ticpu_-_colored_beat-o-scope.pnv
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/aerdan_-_bloody_vortex.pnv
+%%CURLPLUGIN%%share/audacious/images/audioscrobbler.png
+%%CURLPLUGIN%%share/audacious/images/audioscrobbler_badge.png
+share/audacious/images/bookmarks.png
+share/audacious/images/shoutcast.png
+share/audacious/images/streambrowser-16x16.png
+share/audacious/images/streambrowser-64x64.png
+share/audacious/images/xiph.png
%%NLS%%share/locale/ca/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/cs/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/cy/LC_MESSAGES/audacious-plugins.mo
@@ -109,4 +122,5 @@ lib/audacious/Visualization/spectrum.so
@dirrmtry lib/audacious
%%PARANORMALPLUGIN%%@dirrm share/audacious/paranormal/Presets
%%PARANORMALPLUGIN%%@dirrm share/audacious/paranormal
+@dirrmtry share/audacious/images
@dirrmtry share/audacious