aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious-plugins
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2012-12-18 15:55:50 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2012-12-18 15:55:50 +0000
commit995c3a3654d9b92f9b9b199459e2d4ad1d452763 (patch)
tree51e2e8fbb05f84985ceeeed444055325bf5e6f5a /multimedia/audacious-plugins
parentd6b35875df7e2f3e4b3f6e9796ca43ebdde94cc6 (diff)
downloadports-995c3a3654d9b92f9b9b199459e2d4ad1d452763.tar.gz
ports-995c3a3654d9b92f9b9b199459e2d4ad1d452763.zip
Notes
Diffstat (limited to 'multimedia/audacious-plugins')
-rw-r--r--multimedia/audacious-plugins/Makefile223
-rw-r--r--multimedia/audacious-plugins/distinfo4
-rw-r--r--multimedia/audacious-plugins/files/patch-src-OSS-audio.c38
-rw-r--r--multimedia/audacious-plugins/files/patch-src-OSS4-audio.c11
-rw-r--r--multimedia/audacious-plugins/pkg-plist273
5 files changed, 247 insertions, 302 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 99c4bf413ecb..60a6ec216851 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= audacious-plugins
-PORTVERSION= 3.2.4
-PORTREVISION= 1
+PORTVERSION= 3.3.3
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.audacious-media-player.org/
@@ -29,45 +28,31 @@ WANT_SDL= yes
PORTDOCS= AUTHORS
-# no ports for:
-# PULSE "Enable PulseAudio output plugin" on \
-# FFAUDIO "Enable FFAUDIO input plugin" off \
-
-OPTIONS= DBUS "Enable dbus support" on \
- OSS "Enable OSS output plugin" off \
- OSS4 "Enable OSS4 output plugin" off \
- SDLOUT "Enable SDL output plugin" off \
- ALSA "Enable ALSA output plugin" off \
- CUE "Enable CUE support" on \
- MP3 "Enable mp3 plugin" on \
- STATUSICON "Enable X11 Status Icon plugin" on \
- AOSD "Enable X11 Audacious OSD plugin" on \
- AOSDXCOMP "Enable X11 Audacious OSD X Composite Support" on \
- ADPLUG "Enable AdPlug plugin" off \
- VORBIS "Enable Ogg Vorbis input plugin" off \
- FLAC "Enable FLAC input plugin" off \
- WAVPACK "Enable WavPack input plugin" off \
- AAC "Enable aac plugin" on \
- SNDFILE "Enable sndfile extensions" off \
- MODPLUG "Enable ModPlug plugin" off \
- JACK "Enable jack output plugin" off \
- SID "Enable Commodore 64 audio (SID) input plugin" off \
- CDAUDIO "Enable cdaudio-ng input plugin" on \
- SCROBBLER "Enable Scrobbler Plugin" on \
- NEON "Enable neon (HTTP) transport plugin" on \
- MMS "Enable mms transport plugin" off \
- GIO "Enable GIO transport plugin" off \
- SMB "Enable SMB transport plugin" off \
- MTP "Enable MTP upload support" off \
- NLS "Native Language Support" on \
- RESAMPLE "Enable resample support" off \
- AMIDI "Enable amidi support" off \
- NOTIFY "Enable libnotify support" off \
- BS2B "Enable Bauer stereophonic-to-binaural (bs2b) support" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_SDLOUT)
+OPTIONS_DEFINE= DBUS OSS4 SDLOUT ALSA CUE MP3 STATUSICON AOSD AOSDXCOMP \
+ ADPLUG VORBIS FLAC WAVPACK AAC SNDFILE MODPLUG JACK SID \
+ CDAUDIO SCROBBLER MMS GIO SMB MTP NLS RESAMPLE AMIDI \
+ NOTIFY BS2B FFAUDIO PULSE
+OPTIONS_DEFAULT= DBUS CUE MP3 STATUSICON AOSD AOSDXCOMP AAC CDAUDIO \
+ SCROBBLER NEON NLS OSS4
+ADPLUG_DESC= ADPLUG decoder
+AMIDI_DESC= Amidi decoder
+AOSD_DESC= Audacious OSD
+AOSDXCOMP_DESC= Audacious OSD X Composite
+BS2B_DESC= BS2B effect
+CDAUDIO_DESC= CD audio input
+FFAUDIO_DESC= FFAudio decoder
+GIO_DESC= GIO support
+OSS4_DESC= Open Sound System 4
+PULSE_DESC= PulseAudio support
+RESAMPLE_DESC= Resample effect
+SCROBBLER_DESC= Scrobbler decoder
+SDLOUT_DESC= SDL Output
+SID_DESC= Commodore64
+STATUSICON_DESC= X11 Status icon
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSDLOUT}
PLIST_SUB+= SDL=""
USE_SDL= sdl
CONFIGURE_ARGS+=--enable-sdlout
@@ -76,8 +61,8 @@ PLIST_SUB+= SDL="@comment "
CONFIGURE_ARGS+=--disable-sdlout
.endif
-.if defined(WITH_NOTIFY) || exists(${LOCALBASE}/lib/libnotify.so.1)
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+.if ${PORT_OPTIONS:MNOTIFY} || exists(${LOCALBASE}/lib/libnotify.so.1)
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-notify
PLIST_SUB+= NOTIFY=""
.else
@@ -85,8 +70,8 @@ PLIST_SUB+= NOTIFY="@comment "
CONFIGURE_ARGS+=--disable-notify
.endif
-.if !defined(WITHOUT_DBUS)
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+.if ${PORT_OPTIONS:MDBUS}
+LIB_DEPENDS+= dbus-glib:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-gnomeshortcuts
PLIST_SUB+= DBUS=""
.else
@@ -94,8 +79,8 @@ CONFIGURE_ARGS+=--disable-gnomeshortcuts
PLIST_SUB+= DBUS="@comment "
.endif
-.if !defined(WITHOUT_CUE)
-LIB_DEPENDS+= cue.1:${PORTSDIR}/textproc/libcue
+.if ${PORT_OPTIONS:MCUE}
+LIB_DEPENDS+= cue:${PORTSDIR}/textproc/libcue
CONFIGURE_ARGS+=--enable-cue
PLIST_SUB+= CUEPLUGIN=""
.else
@@ -103,8 +88,8 @@ CONFIGURE_ARGS+=--disable-cue
PLIST_SUB+= CUEPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_MP3)
-LIB_DEPENDS+= mpg123.0:${PORTSDIR}/audio/mpg123
+.if ${PORT_OPTIONS:MMP3}
+LIB_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
CONFIGURE_ARGS+=--enable-mp3
PLIST_SUB+= MP3PLUGIN=""
.else
@@ -112,8 +97,8 @@ CONFIGURE_ARGS+=--disable-mp3
PLIST_SUB+= MP3PLUGIN="@comment "
.endif
-.if !defined(WITHOUT_STATUSICON)
-USE_GNOME+= gtk20
+.if ${PORT_OPTIONS:MSTATUSICON}
+USE_GNOME+= gtk30
CONFIGURE_ARGS+=--enable-statusicon
PLIST_SUB+= STATUSICONPLUGIN=""
.else
@@ -121,7 +106,7 @@ CONFIGURE_ARGS+=--disable-statusicon
PLIST_SUB+= STATUSICONPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_AOSD)
+.if ${PORT_OPTIONS:MAOSD}
USE_GNOME+= pango
CONFIGURE_ARGS+=--enable-aosd
PLIST_SUB+= AOSDPLUGIN=""
@@ -130,8 +115,8 @@ CONFIGURE_ARGS+=--disable-aosd
PLIST_SUB+= AOSDPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_AOSDXCOMP)
-LIB_DEPENDS+= Xcomposite.1:${PORTSDIR}/x11/libXcomposite
+.if ${PORT_OPTIONS:MAOSDXCOMP}
+LIB_DEPENDS+= Xcomposite:${PORTSDIR}/x11/libXcomposite
CONFIGURE_ARGS+=--enable-aosd-xcomp
PLIST_SUB+= AOSDXCOMPPLUGIN=""
.else
@@ -139,8 +124,8 @@ CONFIGURE_ARGS+=--disable-aosd-xcomp
PLIST_SUB+= AOSDXCOMPPLUGIN="@comment "
.endif
-.if defined(WITH_ADPLUG)
-LIB_DEPENDS+= binio.1:${PORTSDIR}/devel/libbinio
+.if ${PORT_OPTIONS:MADPLUG}
+LIB_DEPENDS+= binio:${PORTSDIR}/devel/libbinio
CONFIGURE_ARGS+=--enable-adplug
PLIST_SUB+= ADPLUGPLUGIN=""
.else
@@ -148,8 +133,8 @@ CONFIGURE_ARGS+=--disable-adplug
PLIST_SUB+= ADPLUGPLUGIN="@comment "
.endif
-.if defined(WITH_VORBIS)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.if ${PORT_OPTIONS:MVORBIS}
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--enable-vorbis
PLIST_SUB+= VORBISPLUGIN=""
.else
@@ -157,8 +142,8 @@ CONFIGURE_ARGS+=--disable-vorbis
PLIST_SUB+= VORBISPLUGIN="@comment "
.endif
-.if defined(WITH_FLAC)
-LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
+.if ${PORT_OPTIONS:MFLAC}
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
CONFIGURE_ARGS+=--enable-flacng --enable-filewriter_flac
PLIST_SUB+= FLACPLUGIN=""
.else
@@ -166,18 +151,17 @@ CONFIGURE_ARGS+=--disable-flacng --disable-filewriter_flac
PLIST_SUB+= FLACPLUGIN="@comment "
.endif
-# Needs a newer version of ffmpeg
-#.if defined(WITH_FFAUDIO)
-#LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
-#CONFIGURE_ARGS+=--enable-ffaudio
-#PLIST_SUB+= FFAUDIOPLUGIN=""
-#.else
-#CONFIGURE_ARGS+=--disable-ffaudio
-#PLIST_SUB+= FFAUDIOPLUGIN="@comment "
-#.endif
+.if ${PORT_OPTIONS:MFFAUDIO}
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg1
+CONFIGURE_ARGS+=--enable-ffaudio
+PLIST_SUB+= FFAUDIOPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-ffaudio
+PLIST_SUB+= FFAUDIOPLUGIN="@comment "
+.endif
-.if defined(WITH_WAVPACK)
-LIB_DEPENDS+= wavpack.2:${PORTSDIR}/audio/wavpack
+.if ${PORT_OPTIONS:MWAVPACK}
+LIB_DEPENDS+= wavpack:${PORTSDIR}/audio/wavpack
CONFIGURE_ARGS+=--enable-wavpack
PLIST_SUB+= WAVPACKPLUGIN=""
.else
@@ -185,17 +169,17 @@ CONFIGURE_ARGS+=--disable-wavpack
PLIST_SUB+= WAVPACKPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_AAC)
+.if ${PORT_OPTIONS:MAAC}
CONFIGURE_ARGS+=--enable-aac
PLIST_SUB+= AACPLUGIN=""
-LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad
+LIB_DEPENDS+= faad:${PORTSDIR}/audio/faad
.else
CONFIGURE_ARGS+=--disable-aac
PLIST_SUB+= AACPLUGIN="@comment "
.endif
-.if defined(WITH_SNDFILE)
-LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+.if ${PORT_OPTIONS:MSNDFILE}
+LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile
CONFIGURE_ARGS+=--enable-sndfile
PLIST_SUB+= SNDFILEPLUGIN=""
.else
@@ -203,8 +187,8 @@ CONFIGURE_ARGS+=--disable-sndfile
PLIST_SUB+= SNDFILEPLUGIN="@comment "
.endif
-.if defined(WITH_MODPLUG)
-LIB_DEPENDS+= modplug.1:${PORTSDIR}/audio/libmodplug
+.if ${PORT_OPTIONS:MMODPLUG}
+LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
PLIST_SUB+= MODPLUG=""
CONFIGURE_ARGS+=--enable-modplug
.else
@@ -212,9 +196,9 @@ PLIST_SUB+= MODPLUG="@comment "
CONFIGURE_ARGS+=--disable-modplug
.endif
-.if defined(WITH_JACK)
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack \
- samplerate.1:${PORTSDIR}/audio/libsamplerate
+.if ${PORT_OPTIONS:MJACK}
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack \
+ samplerate:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+=--enable-jack
PLIST_SUB+= JACKPLUGIN=""
.else
@@ -222,16 +206,8 @@ CONFIGURE_ARGS+=--disable-jack
PLIST_SUB+= JACKPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_OSS)
-PLIST_SUB+= OSSPLUGIN=""
-CONFIGURE_ARGS+=--enable-oss
-.else
-PLIST_SUB+= OSSPLUGIN="@comment "
-CONFIGURE_ARGS+=--disable-oss
-.endif
-
-.if !defined(WITHOUT_SCROBBLER)
-LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.if ${PORT_OPTIONS:MSCROBBLER}
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
PLIST_SUB+= SCROBBLERPLUGIN=""
CONFIGURE_ARGS+=--enable-scrobbler
.else
@@ -239,7 +215,7 @@ PLIST_SUB+= SCROBBLERPLUGIN="@comment "
CONFIGURE_ARGS+=--disable-scrobbler
.endif
-.if !defined(WITHOUT_OSS4)
+.if ${PORT_OPTIONS:MOSS4}
BUILD_DEPENDS+= ${LOCALBASE}/lib/oss/include/sys/soundcard.h:${PORTSDIR}/audio/oss
PLIST_SUB+= OSS4PLUGIN=""
CONFIGURE_ARGS+=--enable-oss4
@@ -248,8 +224,8 @@ PLIST_SUB+= OSS4PLUGIN="@comment "
CONFIGURE_ARGS+=--disable-oss4
.endif
-.if defined(WITH_SID)
-LIB_DEPENDS+= sidplay.1:${PORTSDIR}/audio/libsidplay
+.if ${PORT_OPTIONS:MSID}
+LIB_DEPENDS+= sidplay:${PORTSDIR}/audio/libsidplay
PLIST_SUB+= SIDPLUGIN=""
CONFIGURE_ARGS+=--enable-sid
.else
@@ -257,9 +233,9 @@ PLIST_SUB+= SIDPLUGIN="@comment "
CONFIGURE_ARGS+=--disable-sid
.endif
-.if defined(WITH_CDAUDIO)
-LIB_DEPENDS+= cdio.13:${PORTSDIR}/sysutils/libcdio \
- cddb.4:${PORTSDIR}/audio/libcddb
+.if ${PORT_OPTIONS:MCDAUDIO}
+LIB_DEPENDS+= cdio:${PORTSDIR}/sysutils/libcdio \
+ cddb:${PORTSDIR}/audio/libcddb
CONFIGURE_ARGS+=--enable-cdaudio
PLIST_SUB+= CDAUDIOPLUGIN=""
.else
@@ -267,8 +243,8 @@ CONFIGURE_ARGS+=--disable-cdaudio
PLIST_SUB+= CDAUDIOPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_NEON)
-LIB_DEPENDS+= neon.27:${PORTSDIR}/www/neon29
+.if ${PORT_OPTIONS:MNEON}
+LIB_DEPENDS+= neon:${PORTSDIR}/www/neon29
CONFIGURE_ARGS+=--enable-neon
PLIST_SUB+= NEONPLUGIN=""
.else
@@ -276,8 +252,8 @@ CONFIGURE_ARGS+=--disable-neon
PLIST_SUB+= NEONPLUGIN="@comment "
.endif
-.if defined(WITH_MMS)
-LIB_DEPENDS+= mms.0:${PORTSDIR}/net/libmms
+.if ${PORT_OPTIONS:MMMS}
+LIB_DEPENDS+= mms:${PORTSDIR}/net/libmms
CONFIGURE_ARGS+=--enable-mms
PLIST_SUB+= MMSPLUGIN=""
.else
@@ -285,8 +261,8 @@ CONFIGURE_ARGS+=--disable-mms
PLIST_SUB+= MMSPLUGIN="@comment "
.endif
-.if defined(WITH_MTP)
-LIB_DEPENDS+= mtp.9:${PORTSDIR}/audio/libmtp
+.if ${PORT_OPTIONS:MMTP}
+LIB_DEPENDS+= mtp:${PORTSDIR}/audio/libmtp
CONFIGURE_ARGS+=--enable-mtp_up
PLIST_SUB+= MTPPLUGIN=""
.else
@@ -294,8 +270,8 @@ CONFIGURE_ARGS+=--disable-mtp_up
PLIST_SUB+= MTPPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_RESAMPLE)
-LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+.if ${PORT_OPTIONS:MRESAMPLE}
+LIB_DEPENDS+= samplerate:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+=--enable-resample
PLIST_SUB+= RESAMPLEPLUGIN=""
.else
@@ -303,8 +279,8 @@ CONFIGURE_ARGS+=--disable-resample
PLIST_SUB+= RESAMPLEPLUGIN="@comment "
.endif
-.if defined(WITH_ALSA)
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+.if ${PORT_OPTIONS:MALSA}
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
CONFIGURE_ARGS+=--enable-alsa
PLIST_SUB+= ALSAPLUGIN=""
.else
@@ -312,13 +288,13 @@ CONFIGURE_ARGS+=--disable-alsa
PLIST_SUB+= ALSAPLUGIN="@comment "
.endif
-.if defined(WITH_AMIDI)
-.if defined(WITH_ALSA)
+.if ${PORT_OPTIONS:MAMIDI}
+.if ${PORT_OPTIONS:MALSA}
CONFIGURE_ARGS+=--enable-amidiplug --enable-amidiplug-alsa
PLIST_SUB+= AMIDIFPLUGIN="@comment "
PLIST_SUB+= AMIDIAPLUGIN=""
.else
-LIB_DEPENDS+= fluidsynth.1:${PORTSDIR}/audio/fluidsynth
+LIB_DEPENDS+= fluidsynth:${PORTSDIR}/audio/fluidsynth
CONFIGURE_ARGS+=--enable-amidiplug --enable-amidiplug-flsyn
PLIST_SUB+= AMIDIFPLUGIN=""
PLIST_SUB+= AMIDIAPLUGIN="@comment "
@@ -331,8 +307,8 @@ PLIST_SUB+= AMIDIAPLUGIN="@comment "
PLIST_SUB+= AMIDIPLUGIN="@comment "
.endif
-.if defined(WITH_BS2B)
-LIB_DEPENDS+= bs2b.0:${PORTSDIR}/audio/libbs2b
+.if ${PORT_OPTIONS:MBS2B}
+LIB_DEPENDS+= bs2b:${PORTSDIR}/audio/libbs2b
CONFIGURE_ARGS+=--enable-bs2b
PLIST_SUB+= BS2BPLUGIN=""
.else
@@ -340,7 +316,7 @@ CONFIGURE_ARGS+=--disable-bs2b
PLIST_SUB+= BS2BPLUGIN="@comment "
.endif
-.if defined(WITH_GIO)
+.if ${PORT_OPTIONS:MGIO}
USE_GNOME+= glib20
CONFIGURE_ARGS+=--enable-gio
PLIST_SUB+= GIOPLUGIN=""
@@ -349,9 +325,9 @@ CONFIGURE_ARGS+=--disable-gio
PLIST_SUB+= GIOPLUGIN="@comment "
.endif
-.if defined(WITH_SMB)
+.if ${PORT_OPTIONS:MSMB}
SAMBA_PORT?= net/samba34
-LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+LIB_DEPENDS+= smbclient:${PORTSDIR}/net/samba-libsmbclient
CONFIGURE_ARGS+=--enable-smb
PLIST_SUB+= SMBPLUGIN=""
.else
@@ -359,7 +335,7 @@ CONFIGURE_ARGS+=--disable-smb
PLIST_SUB+= SMBPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -368,15 +344,24 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.if ${PORT_OPTIONS:MPULSE}
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
+CONFIGURE_ARGS+=--enable-pulse
+PLIST_SUB+= PULSE=""
+.else
+CONFIGURE_ARGS+=--disable-pulse
+PLIST_SUB+= PULSE="@comment "
+.endif
+
pre-everything::
-.if defined(WITH_AUDIOCD) && !exists(${LOCALBASE}/lib/libcdio_cdda.so)
+.if ${PORT_OPTIONS:MAUDIOCD} && !exists(${LOCALBASE}/lib/libcdio_cdda.so)
@${ECHO_CMD} ""
@${ECHO_CMD} "Make sure you select the PARANOIA option when installing libcdio!"
@${ECHO_CMD} ""
.endif
pre-configure:
-.if defined(WITH_AUDIOCD) && !exists(${LOCALBASE}/lib/libcdio_cdda.so)
+.if ${PORT_OPTIONS:MAUDIOCD} && !exists(${LOCALBASE}/lib/libcdio_cdda.so)
@${ECHO_CMD} ""
@${ECHO_CMD} "sysutils/libcdio got not installed with PARANOIA enabled!"
@${ECHO_CMD} "To use the audiocd option you have to install libcdio with"
@@ -386,7 +371,7 @@ pre-configure:
.endif
post-install:
-.if defined(WITH_GNOME)
+.if ${PORT_OPTIONS:MGNOME}
@${ECHO_MSG} ""
@${ECHO_MSG} "You have installed audacious with gconf support."
@${ECHO_MSG} "ALL PRESETS will be stored in the gconf database."
@@ -399,4 +384,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/audacious-plugins/distinfo b/multimedia/audacious-plugins/distinfo
index 10b87c54f695..312c3e0bcca6 100644
--- a/multimedia/audacious-plugins/distinfo
+++ b/multimedia/audacious-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (audacious-plugins-3.2.4.tar.bz2) = 0f03556de593d85d4aba0895c4586643026d15f5c1243e7353a4636e84b31882
-SIZE (audacious-plugins-3.2.4.tar.bz2) = 1921658
+SHA256 (audacious-plugins-3.3.3.tar.bz2) = 3906a70090edb09b94504fa37c823635b752b408e129fc0156286d409d350f8f
+SIZE (audacious-plugins-3.3.3.tar.bz2) = 1740185
diff --git a/multimedia/audacious-plugins/files/patch-src-OSS-audio.c b/multimedia/audacious-plugins/files/patch-src-OSS-audio.c
deleted file mode 100644
index 622d29f2be93..000000000000
--- a/multimedia/audacious-plugins/files/patch-src-OSS-audio.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/OSS/audio.c.original 2008-04-16 22:16:27.000000000 +0200
-+++ src/OSS/audio.c 2008-04-16 22:16:50.000000000 +0200
-@@ -497,7 +497,7 @@
- do_pause = FALSE;
- paused = TRUE;
-
-- ioctl(fd, SNDCTL_DSP_SYNC, 0);
-+ ioctl(fd, SNDCTL_DSP_RESET, 0);
- }
- else if (unpause && paused) {
- unpause = FALSE;
-@@ -514,7 +514,7 @@
- * the driver to get fucked up by a reset
- */
-
-- ioctl(fd, SNDCTL_DSP_SYNC, 0);
-+ ioctl(fd, SNDCTL_DSP_RESET, 0);
- close(fd);
- fd = open(device_name, O_WRONLY);
- oss_set_audio_params();
-@@ -527,7 +527,7 @@
-
- }
-
-- ioctl(fd, SNDCTL_DSP_SYNC, 0);
-+ ioctl(fd, SNDCTL_DSP_RESET, 0);
- close(fd);
- g_free(buffer);
- return NULL;
-@@ -540,7 +540,7 @@
- struct timeval tv;
- fd_set set;
-
-- ioctl(fd, SNDCTL_DSP_SYNC, 0);
-+ ioctl(fd, SNDCTL_DSP_RESET, 0);
- frag = (NFRAGS << 16) | fragsize;
- ioctl(fd, SNDCTL_DSP_SETFRAGMENT, &frag);
- /*
diff --git a/multimedia/audacious-plugins/files/patch-src-OSS4-audio.c b/multimedia/audacious-plugins/files/patch-src-OSS4-audio.c
deleted file mode 100644
index f531d5708ca9..000000000000
--- a/multimedia/audacious-plugins/files/patch-src-OSS4-audio.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/oss4/oss.c.orig 2011-11-08 17:38:49.000000000 +0100
-+++ src/oss4/oss.c 2011-11-24 11:26:36.000000000 +0100
-@@ -191,7 +191,7 @@
- {
- AUDDBG("Drain.\n");
-
-- if (ioctl(oss_data->fd, SNDCTL_DSP_SYNC, NULL) == -1)
-+ if (ioctl(oss_data->fd, SNDCTL_DSP_RESET, NULL) == -1)
- DESCRIBE_ERROR;
- }
-
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
index 6b0f5d9e3d08..6323a1c464b0 100644
--- a/multimedia/audacious-plugins/pkg-plist
+++ b/multimedia/audacious-plugins/pkg-plist
@@ -1,151 +1,154 @@
-%%NLS%%share/locale/et/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/es/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/cy/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/es_AR/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/de/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/es_MX/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/lv/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/eu/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/it/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/pt_PT/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/audacious-plugins.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/audacious-plugins.mo
-share/audacious/ui/mainwin.ui
-share/audacious/ui/playlist.ui
-share/audacious/ui/equalizer.ui
-share/audacious/Skins/Classic1.3/eqmain.png
-share/audacious/Skins/Classic1.3/titlebar.png
-share/audacious/Skins/Classic1.3/volume.png
-share/audacious/Skins/Classic1.3/posbar.png
-share/audacious/Skins/Classic1.3/shufrep.png
-share/audacious/Skins/Classic1.3/skin-classic.hints
-share/audacious/Skins/Classic1.3/balance.png
-share/audacious/Skins/Classic1.3/cbuttons.png
-share/audacious/Skins/Classic1.3/viscolor.txt
-share/audacious/Skins/Classic1.3/playpaus.png
-share/audacious/Skins/Classic1.3/pledit.txt
-share/audacious/Skins/Classic1.3/eq_ex.png
-share/audacious/Skins/Classic1.3/monoster.png
-share/audacious/Skins/Classic1.3/text.png
-share/audacious/Skins/Classic1.3/main.png
-share/audacious/Skins/Classic1.3/skin.hints
-share/audacious/Skins/Classic1.3/pledit.png
-share/audacious/Skins/Classic1.3/nums_ex.png
-share/audacious/Skins/Classic/shufrep.png
-share/audacious/Skins/Classic/titlebar.png
+share/audacious/Skins/Classic/balance.png
+share/audacious/Skins/Classic/cbuttons.png
share/audacious/Skins/Classic/eq_ex.png
+share/audacious/Skins/Classic/eqmain.png
+share/audacious/Skins/Classic/main.png
+share/audacious/Skins/Classic/monoster.png
+share/audacious/Skins/Classic/nums_ex.png
+share/audacious/Skins/Classic/playpaus.png
share/audacious/Skins/Classic/pledit.png
+share/audacious/Skins/Classic/pledit.txt
+share/audacious/Skins/Classic/posbar.png
+share/audacious/Skins/Classic/shufrep.png
+share/audacious/Skins/Classic/skin-classic.hints
share/audacious/Skins/Classic/skin.hints
-share/audacious/Skins/Classic/cbuttons.png
-share/audacious/Skins/Classic/playpaus.png
-share/audacious/Skins/Classic/viscolor.txt
-share/audacious/Skins/Classic/monoster.png
-share/audacious/Skins/Classic/main.png
-share/audacious/Skins/Classic/balance.png
share/audacious/Skins/Classic/text.png
-share/audacious/Skins/Classic/pledit.txt
+share/audacious/Skins/Classic/titlebar.png
+share/audacious/Skins/Classic/viscolor.txt
share/audacious/Skins/Classic/volume.png
-share/audacious/Skins/Classic/skin-classic.hints
-share/audacious/Skins/Classic/nums_ex.png
-share/audacious/Skins/Classic/eqmain.png
-share/audacious/Skins/Classic/posbar.png
-share/audacious/Skins/Refugee/shufrep.png
-share/audacious/Skins/Refugee/pledit.txt
-share/audacious/Skins/Refugee/posbar.png
-share/audacious/Skins/Refugee/eqmain.png
-share/audacious/Skins/Refugee/volume.png
-share/audacious/Skins/Refugee/monoster.png
-share/audacious/Skins/Refugee/playpaus.png
-share/audacious/Skins/Refugee/viscolor.txt
-share/audacious/Skins/Refugee/pledit.png
-share/audacious/Skins/Refugee/cbuttons.png
-share/audacious/Skins/Refugee/text.png
-share/audacious/Skins/Refugee/main.png
-share/audacious/Skins/Refugee/skin.hints
-share/audacious/Skins/Refugee/eq_ex.png
-share/audacious/Skins/Refugee/nums_ex.png
-share/audacious/Skins/Refugee/titlebar.png
-share/audacious/Skins/Ivory/nums_ex.png
-share/audacious/Skins/Ivory/skin.hints
-share/audacious/Skins/Ivory/eq_ex.png
-share/audacious/Skins/Ivory/pledit.png
-share/audacious/Skins/Ivory/text.png
-share/audacious/Skins/Ivory/main.png
-share/audacious/Skins/Ivory/volume.png
+share/audacious/Skins/Classic1.3/balance.png
+share/audacious/Skins/Classic1.3/cbuttons.png
+share/audacious/Skins/Classic1.3/eq_ex.png
+share/audacious/Skins/Classic1.3/eqmain.png
+share/audacious/Skins/Classic1.3/main.png
+share/audacious/Skins/Classic1.3/monoster.png
+share/audacious/Skins/Classic1.3/nums_ex.png
+share/audacious/Skins/Classic1.3/playpaus.png
+share/audacious/Skins/Classic1.3/pledit.png
+share/audacious/Skins/Classic1.3/pledit.txt
+share/audacious/Skins/Classic1.3/posbar.png
+share/audacious/Skins/Classic1.3/shufrep.png
+share/audacious/Skins/Classic1.3/skin-classic.hints
+share/audacious/Skins/Classic1.3/skin.hints
+share/audacious/Skins/Classic1.3/text.png
+share/audacious/Skins/Classic1.3/titlebar.png
+share/audacious/Skins/Classic1.3/viscolor.txt
+share/audacious/Skins/Classic1.3/volume.png
+share/audacious/Skins/Default/cbuttons.png
+share/audacious/Skins/Default/eq_ex.png
+share/audacious/Skins/Default/eqmain.png
+share/audacious/Skins/Default/main.png
+share/audacious/Skins/Default/monoster.png
+share/audacious/Skins/Default/nums_ex.png
+share/audacious/Skins/Default/playpaus.png
+share/audacious/Skins/Default/pledit.png
+share/audacious/Skins/Default/pledit.txt
+share/audacious/Skins/Default/posbar.png
+share/audacious/Skins/Default/shufrep.png
+share/audacious/Skins/Default/skin.hints
+share/audacious/Skins/Default/text.png
+share/audacious/Skins/Default/titlebar.png
+share/audacious/Skins/Default/viscolor.txt
+share/audacious/Skins/Default/volume.png
+share/audacious/Skins/Ivory/balance.png
share/audacious/Skins/Ivory/cbuttons.png
+share/audacious/Skins/Ivory/eq_ex.png
share/audacious/Skins/Ivory/eqmain.png
-share/audacious/Skins/Ivory/viscolor.txt
-share/audacious/Skins/Ivory/playpaus.png
-share/audacious/Skins/Ivory/balance.png
-share/audacious/Skins/Ivory/posbar.png
+share/audacious/Skins/Ivory/main.png
share/audacious/Skins/Ivory/monoster.png
+share/audacious/Skins/Ivory/nums_ex.png
+share/audacious/Skins/Ivory/playpaus.png
+share/audacious/Skins/Ivory/pledit.png
share/audacious/Skins/Ivory/pledit.txt
-share/audacious/Skins/Ivory/titlebar.png
+share/audacious/Skins/Ivory/posbar.png
share/audacious/Skins/Ivory/shufrep.png
+share/audacious/Skins/Ivory/skin.hints
+share/audacious/Skins/Ivory/text.png
+share/audacious/Skins/Ivory/titlebar.png
+share/audacious/Skins/Ivory/viscolor.txt
+share/audacious/Skins/Ivory/volume.png
+share/audacious/Skins/Osmosis/balance.png
+share/audacious/Skins/Osmosis/cbuttons.png
+share/audacious/Skins/Osmosis/eq_ex.png
share/audacious/Skins/Osmosis/eqmain.png
-share/audacious/Skins/Osmosis/titlebar.png
-share/audacious/Skins/Osmosis/volume.png
-share/audacious/Skins/Osmosis/posbar.png
+share/audacious/Skins/Osmosis/main.png
+share/audacious/Skins/Osmosis/monoster.png
share/audacious/Skins/Osmosis/nums_ex.png
-share/audacious/Skins/Osmosis/viscolor.txt
share/audacious/Skins/Osmosis/playpaus.png
-share/audacious/Skins/Osmosis/cbuttons.png
-share/audacious/Skins/Osmosis/pledit.txt
-share/audacious/Skins/Osmosis/monoster.png
-share/audacious/Skins/Osmosis/text.png
-share/audacious/Skins/Osmosis/skin.hints
-share/audacious/Skins/Osmosis/balance.png
-share/audacious/Skins/Osmosis/main.png
-share/audacious/Skins/Osmosis/eq_ex.png
share/audacious/Skins/Osmosis/pledit.png
+share/audacious/Skins/Osmosis/pledit.txt
+share/audacious/Skins/Osmosis/posbar.png
share/audacious/Skins/Osmosis/shufrep.png
+share/audacious/Skins/Osmosis/skin.hints
+share/audacious/Skins/Osmosis/text.png
+share/audacious/Skins/Osmosis/titlebar.png
+share/audacious/Skins/Osmosis/viscolor.txt
+share/audacious/Skins/Osmosis/volume.png
+share/audacious/Skins/Refugee/cbuttons.png
+share/audacious/Skins/Refugee/eq_ex.png
+share/audacious/Skins/Refugee/eqmain.png
+share/audacious/Skins/Refugee/main.png
+share/audacious/Skins/Refugee/monoster.png
+share/audacious/Skins/Refugee/nums_ex.png
+share/audacious/Skins/Refugee/playpaus.png
+share/audacious/Skins/Refugee/pledit.png
+share/audacious/Skins/Refugee/pledit.txt
+share/audacious/Skins/Refugee/posbar.png
+share/audacious/Skins/Refugee/shufrep.png
+share/audacious/Skins/Refugee/skin.hints
+share/audacious/Skins/Refugee/text.png
+share/audacious/Skins/Refugee/titlebar.png
+share/audacious/Skins/Refugee/viscolor.txt
+share/audacious/Skins/Refugee/volume.png
+share/audacious/Skins/TinyPlayer/balance.png
share/audacious/Skins/TinyPlayer/cbuttons.png
-share/audacious/Skins/TinyPlayer/playpaus.png
-share/audacious/Skins/TinyPlayer/viscolor.txt
-share/audacious/Skins/TinyPlayer/pledit.png
-share/audacious/Skins/TinyPlayer/monoster.png
+share/audacious/Skins/TinyPlayer/eq_ex.png
+share/audacious/Skins/TinyPlayer/eqmain.png
share/audacious/Skins/TinyPlayer/main.png
-share/audacious/Skins/TinyPlayer/titlebar.png
-share/audacious/Skins/TinyPlayer/skin.hints
-share/audacious/Skins/TinyPlayer/text.png
+share/audacious/Skins/TinyPlayer/monoster.png
share/audacious/Skins/TinyPlayer/nums_ex.png
+share/audacious/Skins/TinyPlayer/playpaus.png
+share/audacious/Skins/TinyPlayer/pledit.png
share/audacious/Skins/TinyPlayer/pledit.txt
+share/audacious/Skins/TinyPlayer/posbar.png
share/audacious/Skins/TinyPlayer/shufrep.png
-share/audacious/Skins/TinyPlayer/balance.png
-share/audacious/Skins/TinyPlayer/eqmain.png
-share/audacious/Skins/TinyPlayer/eq_ex.png
+share/audacious/Skins/TinyPlayer/skin.hints
+share/audacious/Skins/TinyPlayer/text.png
+share/audacious/Skins/TinyPlayer/titlebar.png
+share/audacious/Skins/TinyPlayer/viscolor.txt
share/audacious/Skins/TinyPlayer/volume.png
-share/audacious/Skins/TinyPlayer/posbar.png
-share/audacious/Skins/Default/pledit.txt
-share/audacious/Skins/Default/posbar.png
-share/audacious/Skins/Default/volume.png
-share/audacious/Skins/Default/eqmain.png
-share/audacious/Skins/Default/nums_ex.png
-share/audacious/Skins/Default/cbuttons.png
-share/audacious/Skins/Default/viscolor.txt
-share/audacious/Skins/Default/playpaus.png
-share/audacious/Skins/Default/shufrep.png
-share/audacious/Skins/Default/pledit.png
-share/audacious/Skins/Default/eq_ex.png
-share/audacious/Skins/Default/monoster.png
-share/audacious/Skins/Default/titlebar.png
-share/audacious/Skins/Default/main.png
-share/audacious/Skins/Default/skin.hints
-share/audacious/Skins/Default/text.png
+share/audacious/ui/equalizer.ui
+share/audacious/ui/mainwin.ui
+share/audacious/ui/playlist.ui
+%%NLS%%share/locale/be/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/de/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/el/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/es/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/es_AR/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/es_MX/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/et/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/id_ID/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/it/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/ky/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/sr_RS/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/audacious-plugins.mo
%%MMSPLUGIN%%lib/audacious/Transport/mms.so
%%NEONPLUGIN%%lib/audacious/Transport/neon.so
lib/audacious/Transport/unix-io.so
@@ -167,7 +170,7 @@ lib/audacious/Input/metronom.so
%%SIDPLUGIN%%lib/audacious/Input/sid.so
lib/audacious/Input/console.so
lib/audacious/Input/psf2.so
-%%MP3PLUGIN%%lib/audacious/Input/madplug.so
+lib/audacious/Input/madplug.so
%%SNDFILEPLUGIN%%lib/audacious/Input/sndfile.so
%%CDAUDIOPLUGIN%%lib/audacious/Input/cdaudio-ng.so
lib/audacious/Effect/stereo.so
@@ -177,7 +180,6 @@ lib/audacious/Effect/crossfade.so
lib/audacious/Effect/compressor.so
lib/audacious/Effect/ladspa.so
lib/audacious/Effect/mixer.so
-lib/audacious/Effect/sndstretch.so
lib/audacious/Effect/echo.so
lib/audacious/Effect/voice_removal.so
%%BS2BPLUGIN%%lib/audacious/Effect/bs2b.so
@@ -197,11 +199,9 @@ lib/audacious/General/albumart.so
lib/audacious/General/skins.so
lib/audacious/General/song_change.so
%%STATUSICONPLUGIN%%lib/audacious/General/statusicon.so
-%%CDAUDIOPLUGIN%%lib/audacious/General/cd-menu-items.so
-%%OSSPLUGIN%%lib/audacious/Output/OSS.so
+lib/audacious/General/cd-menu-items.so
%%OSS4PLUGIN%%lib/audacious/Output/oss4.so
%%ALSAPLUGIN%%lib/audacious/Output/alsa.so
-lib/audacious/Output/null.so
lib/audacious/Output/filewriter.so
%%JACKPLUGIN%%lib/audacious/Output/jackout.so
%%SDL%%lib/audacious/Output/sdlout.so
@@ -229,4 +229,13 @@ lib/audacious/Container/pls.so
@dirrm share/audacious/Skins/Classic1.3
@dirrm share/audacious/Skins
@dirrm share/audacious/ui
+%%NLS%%@dirrmtry share/locale/id_ID/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/id_ID
+%%NLS%%@dirrmtry share/locale/ky/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ky
+%%NLS%%@dirrmtry share/locale/sr_RS/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sr_RS
+%%NLS%%@dirrmtry share/locale/es_AR/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_AR
+@dirrm %%DOCSDIR%%
@dirrmtry share/audacious